Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > Need help deploying Struts under JBOSS

Reply
Thread Tools

Need help deploying Struts under JBOSS

 
 
Steve Lewis
Guest
Posts: n/a
 
      08-08-2004
I have a web application that runs well under Tomcat and Resin but is
failing to load struts classes properly under JBOSS. It ssys it cannot
find the Strut packages givig a ClassNotFoundError when any subclass
i.e. ActionForm is loaded.
The following jars are in WEB-INF/lib
commons-beanutils.jar
commons-collections.jar
commons-digester.jar
commons-fileupload.jar
commons-lang.jar
commons-logging.jar
commons-validator.jar
jakarta-oro.jar
jstl.jar
servlet.jar
standard.jar
struts.jar
struts-legacy.jar
I get the error stand alone and under the lomboz debugger rinning on
eclipse. I have seen this problem in the past with other
configurations and would love to hear from someone who has it working.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Deploying a web service configured under IIS 7 to one under IIS 6 Whiskey Romeo Lima ASP General 1 07-16-2009 01:05 AM
Internet Application in JBoss Portal on Liferay JBoss LprzemekL Java 0 04-10-2008 12:03 PM
Eclipse/Lomboz/JBoss: Cannot Start JBoss (Debug) Server from Eclipse Using Lomboz Plugin Jubz Java 0 05-30-2006 10:24 PM
jboss 4.0.3 jboss portal 2.2.1 han Java 0 05-08-2006 10:35 AM
deploying EJB code under Jboss Nachiketh Java 1 04-16-2004 05:29 PM



Advertisments