Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > SMTP mail error

Reply
Thread Tools

SMTP mail error

 
 
Mark K.
Guest
Posts: n/a
 
      06-24-2004
I am getting this error after approx. 10 -15 minutes of no mail being
sent thru this system. What I found was that if I go to the server
that is initiating the traffic(mail) I type telnet mailhost.***.com 25
and get:

telnet mailhost.***.com 25
Trying...
Connected to mailhost.***.com.
Escape character is '^]'.
Connection closed.

If we re-run the same command immediately after that we get

: telnet mailhost.***.com 25
Trying...
Connected to mailhost.***.com.
Escape character is '^]'.
220 kch1xv01.***.com Trend Micro InterScan Messaging Security Suite,
Version: 5.5 ready at Thu, 24 Jun 2004 13:13:57 -0500

If we run it again we will continue to get the second listed response,
which is correct. Because this seems to be a timeout issue I am
confused what is missing or misconfigured and where. Here is the error
itself on the site when executing this call.



System Error #141220 java.lang.Exception:
com.inet.utility.ExceptionError: javax.mail.SendFailedException:
Sending failed;
nested exception is:
class javax.mail.MessagingException: Could not connect to SMTP host:
mailhost.cna.com, port: 25
at javax.mail.Transport.send0(Transport.java(Compiled Code))
at javax.mail.Transport.send(Transport.java:80)
at com.inet.utility.SmtpMail.send(SmtpMail.java:154)
at com.inet.bapp.utility.RiskControlSurveyMail.sendMa il(RiskControlSurveyMail.java:102)
at com.inet.bapp.pageobjects.BappPolIssueBean.process InputData(BappPolIssueBean.java:442)
at com.inet.core.pageDriverBean.processApp(pageDriver Bean.java(Compiled
Code))
at com.inet.core.pageDriverBean.startApplication(page DriverBean.java(Compiled
Code))
at CDataServlet.getData(CDataServlet.java(Compiled Code))
at CDataServlet.doGet(CDataServlet.java:24)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:740)
at javax.servlet.http.HttpServlet.service(HttpServlet .java:853)
at com.ibm.servlet.engine.webapp.StrictServletInstanc e.doService(ServletManager.java:827)
at com.ibm.servlet.engine.webapp.StrictLifecycleServl et._service(StrictLifecycleServlet.java:167)
at com.ibm.servlet.engine.webapp.IdleServletState.ser vice(StrictLifecycleServlet.java:297)
at com.ibm.servlet.engine.webapp.StrictLifecycleServl et.service(StrictLifecycleServlet.java:110)
at com.ibm.servlet.engine.webapp.ServletInstance.serv ice(ServletManager.java:472)
at com.ibm.servlet.engine.webapp.ValidServletReferenc eState.dispatch(ServletManager.java:1012)
at com.ibm.servlet.engine.webapp.ServletInstanceRefer ence.dispatch(ServletManager.java(Inlined
Compiled Code))
at com.ibm.servlet.engine.webapp.WebAppRequestDispatc her.handleWebAppDispatch(WebAppRequestDispatcher.j ava(Compiled
Code))
at com.ibm.servlet.engine.webapp.WebAppRequestDispatc her.dispatch(WebAppRequestDispatcher.java(Compiled
Code))
at com.ibm.servlet.engine.webapp.WebAppRequestDispatc her.forward(WebAppRequestDispatcher.java(Compiled
Code))
at com.ibm.servlet.engine.srt.WebAppInvoker.doForward (WebAppInvoker.java:134)
at com.ibm.servlet.engine.srt.WebAppInvoker.handleInv ocationHook(WebAppInvoker.java:239)
at com.ibm.servlet.engine.invocation.CachedInvocation .handleInvocation(CachedInvocation.java:67)
at com.ibm.servlet.engine.invocation.CacheableInvocat ionContext.invoke(CacheableInvocationContext.java: 106)
at com.ibm.servlet.engine.srp.ServletRequestProcessor .dispatchByURI(ServletRequestProcessor.java:154)
at com.ibm.servlet.engine.oselistener.OSEListenerDisp atcher.service(OSEListener.java:315)
at com.ibm.servlet.engine.http11.HttpConnection.handl eRequest(HttpConnection.java:60)
at com.ibm.ws.http.HttpConnection.readAndHandleReques t(HttpConnection.java(Compiled
Code))
at com.ibm.ws.http.HttpConnection.run(HttpConnection. java(Compiled
Code))
at com.ibm.ws.util.CachedThread.run(ThreadPool.java:1 3
 
Reply With Quote
 
 
 
 
Yu SONG
Guest
Posts: n/a
 
      06-25-2004
Mark K. wrote:
> I am getting this error after approx. 10 -15 minutes of no mail being
> sent thru this system. What I found was that if I go to the server
> that is initiating the traffic(mail) I type telnet mailhost.***.com 25
> and get:
>
> telnet mailhost.***.com 25
> Trying...
> Connected to mailhost.***.com.
> Escape character is '^]'.
> Connection closed.
>
> If we re-run the same command immediately after that we get
>
> : telnet mailhost.***.com 25
> Trying...
> Connected to mailhost.***.com.
> Escape character is '^]'.
> 220 kch1xv01.***.com Trend Micro InterScan Messaging Security Suite,
> Version: 5.5 ready at Thu, 24 Jun 2004 13:13:57 -0500
>
> If we run it again we will continue to get the second listed response,
> which is correct. Because this seems to be a timeout issue I am
> confused what is missing or misconfigured and where. Here is the error
> itself on the site when executing this call.
>


I think it's something to do with your SMTP server, not your Java code.
You may want to try sending the same message again to the SMTP server,
to see what could happen.


>
>
> System Error #141220 java.lang.Exception:
> com.inet.utility.ExceptionError: javax.mail.SendFailedException:
> Sending failed;
> nested exception is:
> class javax.mail.MessagingException: Could not connect to SMTP host:





--
Song

/* E-mail.c */
#define User "Yu.Song"
#define Warwick "warwick.ac.uk"
int main() {
printf("Yu Song's E-mail: %s@%s", User, Warwick);
return 0;}

Further Info. : http://www.dcs.warwick.ac.uk/~esubbn/
__________________________________________________ _____

 
Reply With Quote
 
 
 
 
Sumukh
Guest
Posts: n/a
 
      06-25-2004
right i also think its problem of connection time out. chk connetion
timeout settings mail server side..

Yu SONG wrote:
> Mark K. wrote:
>
>> I am getting this error after approx. 10 -15 minutes of no mail being
>> sent thru this system. What I found was that if I go to the server
>> that is initiating the traffic(mail) I type telnet mailhost.***.com 25
>> and get:
>>
>> telnet mailhost.***.com 25
>> Trying...
>> Connected to mailhost.***.com.
>> Escape character is '^]'.
>> Connection closed.
>>
>> If we re-run the same command immediately after that we get
>>
>> : telnet mailhost.***.com 25
>> Trying...
>> Connected to mailhost.***.com.
>> Escape character is '^]'.
>> 220 kch1xv01.***.com Trend Micro InterScan Messaging Security Suite,
>> Version: 5.5 ready at Thu, 24 Jun 2004 13:13:57 -0500
>>
>> If we run it again we will continue to get the second listed response,
>> which is correct. Because this seems to be a timeout issue I am
>> confused what is missing or misconfigured and where. Here is the error
>> itself on the site when executing this call.
>>

>
> I think it's something to do with your SMTP server, not your Java code.
> You may want to try sending the same message again to the SMTP server,
> to see what could happen.
>
>
>>
>> System Error #141220 java.lang.Exception:
>> com.inet.utility.ExceptionError: javax.mail.SendFailedException:
>> Sending failed;
>> nested exception is:
>> class javax.mail.MessagingException: Could not connect to SMTP host:

>
>
>
>
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending SMTP mail when SMTP server is unavailable matthewjbarr@gmail.com Java 3 01-24-2006 06:53 PM
smtplib.SMTP "no attributes SMTP" Copelandia Cyanescens Python 2 07-31-2004 07:24 PM
sending of mail (smtp) - connection refused - but smtp server isrunning! Alex Hunsley Python 4 06-29-2004 04:30 PM
RE: sending of mail (smtp) - connection refused - but smtp serveris running! Raaijmakers, Vincent \(GE Infrastructure\) Python 0 06-29-2004 02:38 PM
SMTP mail, need way of making sure mail is sent Curt_C [MVP] ASP .Net 5 05-19-2004 04:23 PM



Advertisments