Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > mod_jk only works from local host

Reply
Thread Tools

mod_jk only works from local host

 
 
Patrick
Guest
Posts: n/a
 
      01-22-2004
I just installed mod_jk on my RH box using the instructions from the
following link:

http://johnturner.com/howto/apache2-...rh9-howto.html

The following links work:

http://localhost
http://localhost:8080
http://localhost:8080/examples
http://localhost/example
http://ipaddress
http://ipaddress:8080
http://ipaddress:8080/examples

The only one that doesn't work (and clearly an important one) is

http://ipaddress/examples

The apache error log shows it just appending the /examples to the
document root (and therefore getting a 400) when coming from a remote
computer. But when it's done from localhost things work just fine.
Thoughts?
 
Reply With Quote
 
 
 
 
Sudsy
Guest
Posts: n/a
 
      01-23-2004
Patrick wrote:
> I just installed mod_jk on my RH box using the instructions from the
> following link:
>
> http://johnturner.com/howto/apache2-...rh9-howto.html
>
> The following links work:
>
> http://localhost
> http://localhost:8080
> http://localhost:8080/examples
> http://localhost/example
> http://ipaddress
> http://ipaddress:8080
> http://ipaddress:8080/examples
>
> The only one that doesn't work (and clearly an important one) is
>
> http://ipaddress/examples
>
> The apache error log shows it just appending the /examples to the
> document root (and therefore getting a 400) when coming from a remote
> computer. But when it's done from localhost things work just fine.
> Thoughts?


How about http://ipaddress/example?
Peer carefully back at the list you provided.

 
Reply With Quote
 
 
 
 
Patrick
Guest
Posts: n/a
 
      01-23-2004
Sudsy <(E-Mail Removed)> wrote in message news:<(E-Mail Removed)>...
> Patrick wrote:
> > I just installed mod_jk on my RH box using the instructions from the
> > following link:
> >
> > http://johnturner.com/howto/apache2-...rh9-howto.html
> >
> > The following links work:
> >
> > http://localhost
> > http://localhost:8080
> > http://localhost:8080/examples
> > http://localhost/example
> > http://ipaddress
> > http://ipaddress:8080
> > http://ipaddress:8080/examples
> >
> > The only one that doesn't work (and clearly an important one) is
> >
> > http://ipaddress/examples
> >
> > The apache error log shows it just appending the /examples to the
> > document root (and therefore getting a 400) when coming from a remote
> > computer. But when it's done from localhost things work just fine.
> > Thoughts?

>
> How about http://ipaddress/example?
> Peer carefully back at the list you provided.


I left an S off, sorry. It only works from localhost.
 
Reply With Quote
 
Sudsy
Guest
Posts: n/a
 
      01-23-2004
Patrick wrote:
> I left an S off, sorry. It only works from localhost.


It looks like you're talking to two different servers. When you
don't include a port number then 80 will be used by default. So
it would appear that you've got one HTTP server sitting on port
80 and one on 8080. The second one is probably the stand-alone
Tomcat.
Hard to track it down without further details.

 
Reply With Quote
 
Patrick
Guest
Posts: n/a
 
      01-25-2004
Sudsy <(E-Mail Removed)> wrote in message news:<(E-Mail Removed)>...
> Patrick wrote:
> > I left an S off, sorry. It only works from localhost.

>
> It looks like you're talking to two different servers. When you
> don't include a port number then 80 will be used by default. So
> it would appear that you've got one HTTP server sitting on port
> 80 and one on 8080. The second one is probably the stand-alone
> Tomcat.
> Hard to track it down without further details.


That's exactly what I have, and the purpose of mod_jk is to take
listen to requests on 80 and pass servlet request to Tomcat,
transparent to the user. When I do it from the local machine, it will
pass request on 80 that include the servlet in the url to Tomcat.
When I do it from a different box, they are not passed.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
When I turn on my PC, it works, works, works. Problem! Fogar Computer Information 1 01-17-2006 12:57 AM
Browser link to local file works when local, not work when servedfrom http lurker HTML 1 04-05-2005 05:10 AM
After rebooting my PC works, works, works! Antivirus problem? Adriano Computer Information 1 12-15-2003 05:30 AM
VS 2003 can only connect to local host when connected to intenet leveraged ASP .Net 3 12-03-2003 12:43 PM
help with jboss + tomcat + apache + mod_jk in a load balanced config Golem Java 0 11-27-2003 07:11 PM



Advertisments