Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > Struts and Tiles in tomcat 4.1.18, arabic characters cannot be viewed?

Reply
Thread Tools

Struts and Tiles in tomcat 4.1.18, arabic characters cannot be viewed?

 
 
Conor
Guest
Posts: n/a
 
      01-15-2004
Dear All,
I'm using the struts and tiles frameworks in tomcat(version
4.1.1. I have an action that reads arabic text from a sybase
database, writes to a file (to verfiy database string is in arabic)
then sets a forms string property, then forwards to a jsp which views
the result.
When not using tiles, just struts in tomcat, I get the correct
result, arabic text on the screen. However, when I attempt to do the
exact same in tiles, I get ???? ???? ??? characters instead of the
correct arabic text?
Has anyone come across this problem before? If so, did they
find a workaround? My charset is utf-8, which I set both in the struts
controller, plus in every jsp at the top using this line:

<%@ page contentType="text/html;charset=UTF-8" language="java" %>

Makes no difference, still just see question-mark characters coming
back!

Any help/pointers appreciated?
Best regards,
Conor
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tiles and Struts problem Giox Java 3 10-30-2006 12:13 PM
Struts and Tiles pathing issues. spivee@excite.com Java 2 02-02-2005 12:22 PM
Struts / tiles ignore tag in tiles:insert not working Rich M Java 0 03-05-2004 06:54 PM
Web form and Arabic characters... Greg ASP .Net 4 03-03-2004 08:17 AM
A question about "integration of Struts and Tiles" Jun Java 1 11-17-2003 10:43 PM



Advertisments