Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > fireStateChanged() not working

Reply
Thread Tools

fireStateChanged() not working

 
 
IKerr.
Guest
Posts: n/a
 
      10-24-2003
Hi,

I have a custom spinner model attached to a JSpinner. I have used this
before in a banually built app and can attach an event handler to it and
capture the events, but now I have made it into a bean, dropped it onto a
form and the ide's events tab where you choose which event you want to
listen to is blan - as though no events whatsoever are available to attach
to.

I have 2 classes, a main class which instantiates the custom model and binds
itself to it. This class extends JSpinner. The second class is the spinner
model and it has the following included in it.

public void setValue(Object value) {
int new_value = ((Number)value).intValue();

if (new_value != this.currentValue) {
this.currentValue = new_value;
fireStateChanged();
}
}

As I say, this is working in a manually built app, why won't the property
sheet for events in forte display any events - what have I done wrong ? I
have beaninfoclasses generated by forte.

thanks

Iain


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
response.redirect is not working but server.transfer is working gaurav tyagi ASP .Net 14 01-20-2006 04:22 AM
wifi not working on new hp, or not working after live update =?Utf-8?B?RHJhZ29ueA==?= Wireless Networking 1 10-01-2005 11:17 PM
ASP.NET client-side validation working, but button click not working Alan Silver ASP .Net 1 08-02-2005 03:50 PM
Cookies working on intranet but NOT working on Internet Martin Heuckeroth ASP .Net 5 04-01-2005 01:37 AM
Regular Expression validators NOT working, Required Field validators ARE working Ratman ASP .Net 0 09-14-2004 09:36 PM



Advertisments