Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > Java > Creating an Apache SOAP document problem.

Reply
Thread Tools

Creating an Apache SOAP document problem.

 
 
Jon
Guest
Posts: n/a
 
      08-28-2003
Hi All,
I have a document that I need to send to a .NET server via SOAP and
I'm not able to figure out how to construct it. I am able to send and
receive the simple 'Echo String' document with only one element. Now
I have multiple elements (not a problem) within various child nodes
and such. This is where I am confused and flustered - on how to add
these child nodes. Is it possible for someone to post an example on
how to create these more complex documents or at least point me
somewhere.

I am using Java 1.3 and Apache SOAP 2.3.1
Thanks & regards
Jon


An example of what I need to send is:

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlnssi="http://www.w3.org/2001/XMLSchema-instance"
xmlnssd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<UpdateDocuments xmlns="http://xxx.com/authoring/catalog">
<Documents>
<Document>
<DocumentType>Iso</DocumentType>
<Link>/pub/docs/iso/12345678.zip</Link>
<Products>
<string>12345678</string>
</Products>
</Document>
<Document>
</Documents>
</UpdateDocuments>
</soap:Body>
</soap:Envelope>
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache SOAP - creating a envelope DownTheLine Java 2 12-27-2006 04:17 PM
org/apache/xpath/objects/XObject incompatible with org/apache/xpath/objects/XNodeSet duduch_1er@hotmail.com XML 4 08-10-2006 01:38 PM
Apache FileUpload - java.lang.NoClassDefFoundError: org/apache/commons/io/FileCleaner kebabkongen@hotmail.com Java 2 03-16-2006 09:20 AM
AXIS jars org.apache.axis.wsi.* and org.apache.axis.transport.jms.* unkwb@web.de Java 0 02-23-2005 04:02 PM
Problem of using apache soap to consume WSE 2.0 soap attachment Mullin Yu ASP .Net Web Services 0 10-08-2003 08:09 AM



Advertisments