Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Mysterious malfunctioning menus with a new router!!

Reply
Thread Tools

Mysterious malfunctioning menus with a new router!!

 
 
John
Guest
Posts: n/a
 
      03-03-2006
Today something weird happened:

I bought myself a new wireless router for home, got it set up, and
everything was great. Browsing, email, even Shareaza p2p.

Until I tried to use the ASP.NET 2 menus on one of my apps (hosted
remotely). The menu options just wouldn't work, the browser just sitting
there waiting for a response for ever.

Not all menu options though, only the ones requiring postback. Hyperlink
menu items were fine.

I tried it on a second PC at home, and it worked perfectly.. so it wasn't
the server, or the router itself.

I turned off the software firewall (Sygate) on my original PC, and again the
problem was fixed! Studying the firewall logs, when a menu item was clicked
the *router* sent an ICMP packet to my workstation, which the software
firewall was set to ignore (my old router didn't do this!). Here are the
details:

Ethernet II (Packet Length: 70)
Type: IP (0x0800)
Internet Protocol
Version: 4
Header Length: 20 bytes
Flags:
.0.. = Don't fragment: Not set
..0. = More fragments: Not set
Fragment offset:0
Time to live: 155
Protocol: 0x1 (ICMP - Internet Control Message Protocol)
Header checksum: 0xde9a (Correct)
Source: 192.168.1.1
Destination: 192.168.1.2
Internet Control Message Protocol
Type: 3 (Destination Unreachable)
Code: 4 (Fragmentation Required, but the Do Not Fragment flag is set)
Data (32 bytes)

Setting up a rule on the software firewall to allow the router to send ICMP
packets fixed the problem, but why on earth should the router be initiating
this with a workstation? The packet doesn't originate from outside, it's
actually being generated by the router (source 192.168.1.1).

Anyway, maybe my config is weird, but thought I'd tell you about it in case
someone else experiences the same malfunction.

John


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless network will not enable - device malfunctioning =?Utf-8?B?RGl2YWZldmE=?= Wireless Networking 4 03-30-2010 07:22 PM
Malfunctioning of JSP application Sameer Java 3 02-24-2007 05:38 AM
Malfunctioning LCD Screen Scott Digital Photography 14 03-09-2005 02:54 AM
Select menus above flyout menus? help? news.west.cox.net HTML 8 12-09-2004 12:54 PM
OE6 malfunctioning pDik66 Computer Support 3 01-30-2004 02:04 PM



Advertisments