Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Sending Mail via System.Net.Mail problem

Reply
Thread Tools

Sending Mail via System.Net.Mail problem

 
 
=?Utf-8?B?T3Bh?=
Guest
Posts: n/a
 
      01-25-2006
Hi,

I'm trying to send mail from my ASP.NET application using the new
System.Net.Mail classes.
The code is fairly basic

string SMTPServer = "smtp.atlanticbb.net";
SmtpClient client = new SmtpClient(SMTPServer);
client.DeliveryMethod = SmtpDeliveryMethod.Network;
client.Send("(E-Mail Removed)", "(E-Mail Removed)","test", "test");

I get no errors, but I never recieve the message.

My environment is a development machine (XP pro)
the smtp server I'm using comes from my ISP.

I have norton antivirus, and it does indicate that the message was sent, but
I don't receive anything.

Any thoughts?

Thanks


 
Reply With Quote
 
 
 
 
sloan
Guest
Posts: n/a
 
      01-25-2006

Try adding some basic authenitication. I have this issue with road runner
email.



http://blogs.wwwcoder.com/pradeepd/a...01/28/236.aspx







int cdoBasic = 1;
string username = "(E-Mail Removed)";

mail.Fields.Add("<http://schemas.microsoft.com/cdo/con...on/smtpauthent
icate>, cdoBasic);
mail.Fields.Add("<http://schemas.microsoft.com/cdo/con...on/sendusernam
e>, username);






This is not complete code, just the extra parts you may need.









"Opa" <(E-Mail Removed)> wrote in message
news:<(E-Mail Removed)>...

> Hi,


>


> I'm trying to send mail from my ASP.NET application using the new


> System.Net.Mail classes.


> The code is fairly basic


>


> string SMTPServer = "smtp.atlanticbb.net";


> SmtpClient client = new SmtpClient(SMTPServer);


> client.DeliveryMethod = SmtpDeliveryMethod.Network;


> client.Send("(E-Mail Removed)", "(E-Mail Removed)","test", "test");


>


> I get no errors, but I never recieve the message.


>


> My environment is a development machine (XP pro)


> the smtp server I'm using comes from my ISP.


>


> I have norton antivirus, and it does indicate that the message was sent,

but

> I don't receive anything.


>


> Any thoughts?


>


> Thanks


>


>









"Opa" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi,
>
> I'm trying to send mail from my ASP.NET application using the new
> System.Net.Mail classes.
> The code is fairly basic
>
> string SMTPServer = "smtp.atlanticbb.net";
> SmtpClient client = new SmtpClient(SMTPServer);
> client.DeliveryMethod = SmtpDeliveryMethod.Network;
> client.Send("(E-Mail Removed)", "(E-Mail Removed)","test", "test");
>
> I get no errors, but I never recieve the message.
>
> My environment is a development machine (XP pro)
> the smtp server I'm using comes from my ISP.
>
> I have norton antivirus, and it does indicate that the message was sent,

but
> I don't receive anything.
>
> Any thoughts?
>
> Thanks
>
>



 
Reply With Quote
 
 
 
 
=?Utf-8?B?T3Bh?=
Guest
Posts: n/a
 
      01-26-2006
Thanks for the reply. I tried adding the DefaultNetworkCredentials, but
I still get no emails delivered to me. Any other ideas?



"sloan" wrote:

>
> Try adding some basic authenitication. I have this issue with road runner
> email.
>
>
>
> http://blogs.wwwcoder.com/pradeepd/a...01/28/236.aspx
>
>
>
>
>
>
>
> int cdoBasic = 1;
> string username = "(E-Mail Removed)";
>
> mail.Fields.Add("<http://schemas.microsoft.com/cdo/con...on/smtpauthent
> icate>, cdoBasic);
> mail.Fields.Add("<http://schemas.microsoft.com/cdo/con...on/sendusernam
> e>, username);
>
>
>
>
>
>
> This is not complete code, just the extra parts you may need.
>
>
>
>
>
>
>
>
>
> "Opa" <(E-Mail Removed)> wrote in message
> news:<(E-Mail Removed)>...
>
> > Hi,

>
> >

>
> > I'm trying to send mail from my ASP.NET application using the new

>
> > System.Net.Mail classes.

>
> > The code is fairly basic

>
> >

>
> > string SMTPServer = "smtp.atlanticbb.net";

>
> > SmtpClient client = new SmtpClient(SMTPServer);

>
> > client.DeliveryMethod = SmtpDeliveryMethod.Network;

>
> > client.Send("(E-Mail Removed)", "(E-Mail Removed)","test", "test");

>
> >

>
> > I get no errors, but I never recieve the message.

>
> >

>
> > My environment is a development machine (XP pro)

>
> > the smtp server I'm using comes from my ISP.

>
> >

>
> > I have norton antivirus, and it does indicate that the message was sent,

> but
>
> > I don't receive anything.

>
> >

>
> > Any thoughts?

>
> >

>
> > Thanks

>
> >

>
> >

>
>
>
>
>
>
>
>
> "Opa" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Hi,
> >
> > I'm trying to send mail from my ASP.NET application using the new
> > System.Net.Mail classes.
> > The code is fairly basic
> >
> > string SMTPServer = "smtp.atlanticbb.net";
> > SmtpClient client = new SmtpClient(SMTPServer);
> > client.DeliveryMethod = SmtpDeliveryMethod.Network;
> > client.Send("(E-Mail Removed)", "(E-Mail Removed)","test", "test");
> >
> > I get no errors, but I never recieve the message.
> >
> > My environment is a development machine (XP pro)
> > the smtp server I'm using comes from my ISP.
> >
> > I have norton antivirus, and it does indicate that the message was sent,

> but
> > I don't receive anything.
> >
> > Any thoughts?
> >
> > Thanks
> >
> >

>
>
>

 
Reply With Quote
 
sachya
Guest
Posts: n/a
 
      01-31-2006
Disabling Norton Antivirus should resolve this. If it , I don't exactly
know the reason.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem sending mail: Sending the email to the following server failed Luke Java 2 03-15-2007 10:54 AM
pls help me when i sent mail, it vil sending twice instead of once ,am using java.mail,am sending my code.... shailajabtech@gmail.com Java 0 09-28-2006 06:38 AM
HELP - problem sending e-mail via wireless =?Utf-8?B?Um9iIEJyb3du?= Wireless Networking 6 06-29-2006 12:43 AM
problem sending mail from netscape mail blacjac Computer Support 2 01-31-2004 06:45 AM
Sending pictures via email Via OE6+Win XP - I no longer get prompt to "make all my pictures smaller" Ian Roberts Digital Photography 3 09-21-2003 04:57 PM



Advertisments