Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Request.ServerVariables("LOGON_USER") acting differently on 2 serv

Reply
Thread Tools

Request.ServerVariables("LOGON_USER") acting differently on 2 serv

 
 
=?Utf-8?B?THluZXJz?=
Guest
Posts: n/a
 
      12-05-2005
We have an intranet where a majority of users are in our active directory,
but not all. We have recently upgraded to using asp.net on our servers and
during the rollout ran into a problem. The users in the non-active directory
list could not access the website because of integrated security. Well after
figuring out how to solve our problems, we have one problem left (which is
actually one of our solutions). On the default.asp page we have created a
redirect depending on what is returned from
Request.ServerVariables("LOGON_USER"). If the user is an active directory
user, they go to the default.aspx page, if they are not an active directory
user, they go to the default_original.asp page. This works on our test
server, but not on our production server.

On the test server, we get the user domain and name, on the production
server we get an empty string. The servers are identical (Windows 2003), and
the IIS is 6.0 and the website appears to be setup the same (security).

Anyone have any suggestions on how to fix this, or where to look?

Thank you,
Lyners
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Passed 70-649 : TS:Upgrading MCSE on Wndws Serv 2003 to Wndws Serv 2008 Harvey Colwell Microsoft Certification 2 03-30-2008 03:28 PM
FireFox / IE acting differently dee ASP .Net 6 09-13-2005 08:22 PM
Login Failed: Error 18456: Unable to login to run SP on local serv =?Utf-8?B?Z2FyaWJhbGRp?= ASP .Net 2 02-25-2005 09:17 PM
Deploy WebForm project to Win Serv 2003 =?Utf-8?B?bWc=?= ASP .Net 1 06-16-2004 01:01 AM
One code behind page acting differently Renuka ASP .Net 2 12-05-2003 03:38 PM



Advertisments