Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP.Net 2.0 IFrame problem...

Reply
Thread Tools

ASP.Net 2.0 IFrame problem...

 
 
=?Utf-8?B?Um90aGFyaWdlcg==?=
Guest
Posts: n/a
 
      11-17-2005
Hello, i have a web application, and i have a menu and below this a IFrame
(width:100% heigth:100%) but if i put the dimensions with % dont show
anything... if i put a fixed dimension in px or pt or anything, it works...
but i need %...
anyone know why this is happening?


thanks!
 
Reply With Quote
 
 
 
 
S.M. Altaf [MVP]
Guest
Posts: n/a
 
      11-17-2005
Hi,

Show us the HTML code that comes as a result of this. How are you setting
the height and width, as an attribute or as a CSS style?

-Altaf
--------------------------------------------------------------------------------
All that glitters has a high refractive index.
www.mendhak.com


"Rothariger" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hello, i have a web application, and i have a menu and below this a IFrame
> (width:100% heigth:100%) but if i put the dimensions with % dont show
> anything... if i put a fixed dimension in px or pt or anything, it
> works...
> but i need %...
> anyone know why this is happening?
>
>
> thanks!



 
Reply With Quote
 
 
 
 
Jose A. Fernandez
Guest
Posts: n/a
 
      11-17-2005
Try to delete the first line in the HTML source

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

I hope it works...

 
Reply With Quote
 
=?Utf-8?B?Um90aGFyaWdlcg==?=
Guest
Posts: n/a
 
      11-17-2005
what jose said it worked, but i post the HTML Code anyway... i only leaves
thats matters...

at the last tr, is the IFrame.


thanks to both of you!!!

<%@ Register TagPrefix="ignav"
Namespace="Infragistics.WebUI.UltraWebNavigator"
Assembly="Infragistics.WebUI.UltraWebNavigator.v5. 1, Version=5.1.20051.37,
Culture=neutral, PublicKeyToken=7dd5c3163f2cd0cb" %>
<%@ Page Language="vb" AutoEventWireup="false"
Inherits="Spinehost.EasyTrack.StartPage" CodeFile="StartPage.aspx.vb" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" >
<head id="Head1" runat=server>
<title>Start Page</title>
</HEAD>
<body id="body" bottomMargin="0" leftMargin="0" topMargin="0"
rightMargin="0">
<form id="Form1" method="post" runat="server">

<table border="0" cellpadding="0" cellspacing="0" style="LEFT: 0px;
WIDTH: 100%; POSITION: absolute; TOP: 0px; HEIGHT: 100%">
<tr height=30px>

</tr>
<tr height=auto>

</tr>
<tr height=auto width=auto>
<td visible=true height="100%" width="100%"><IFRAME id="IFrame"
tabIndex="0" src="UserPage.aspx" frameBorder="no" scrolling="no"
contenteditable="true" style="width: 100%; height: 100%"
runat="server"></IFRAME>
</td>
</tr>
</table>

</form>
</body>
</HTML>
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
form have 2 iframe.problem to input text in other iframe elca Python 0 10-21-2009 10:00 AM
how to use an iframe as a link (make the whole iframe clickable) mi HTML 4 05-21-2008 10:13 PM
Targeting a parent iframe from a sub-iframe albanitus@yahoo.com HTML 0 11-15-2006 04:40 PM
IFRAME - Refresh Table on Parent Window - maintain IFRAME State Scott ASP General 6 04-14-2004 05:48 AM
Get form values from iframe (1) to iframe (2) inside a layer in iframe (1) Daedalous Javascript 3 01-16-2004 11:08 AM



Advertisments