Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Server Error in '/' Application.

Reply
Thread Tools

Server Error in '/' Application.

 
 
ěyvind Isaksen
Guest
Posts: n/a
 
      11-05-2005
Hello!

I have made an asp.net application, and it works fine on my local computer.
But when I transfer it to my webserver (here: http://dev1.softmaker.no/ld/),
I get this error message:

-----------------------------------
Server Error in '/' Application.
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.
----------------------------------

The strange thing is that the web application works fine on the webserver if
I make a "Virtual Directory" and point to the folder with the webfiles
(folder "ld").
Here is the same webside (on the same webserver), but the folder "ld" is a
Virtual Directory: http://www.minewebsider.no/ld/ -As you see, this works
fine!

My webserver runs Windows 2003 and IIS 6.0
Hope someone PLEASE can help me, I can not run all my ASP.NET sites with
Virtual Directories!


Thanks for all replies


 
Reply With Quote
 
 
 
 
Mr Newbie
Guest
Posts: n/a
 
      11-05-2005
How does IIS know that detail.aspx is the default page ?, check your IIS web
folder settings for this application.

--
Best Regards

The Inimitable Mr Newbie ║┐║



"ěyvind Isaksen" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hello!
>
> I have made an asp.net application, and it works fine on my local
> computer.
> But when I transfer it to my webserver (here:
> http://dev1.softmaker.no/ld/), I get this error message:
>
> -----------------------------------
> Server Error in '/' Application.
> Description: An application error occurred on the server. The current
> custom error settings for this application prevent the details of the
> application error from being viewed remotely (for security reasons). It
> could, however, be viewed by browsers running on the local server machine.
> ----------------------------------
>
> The strange thing is that the web application works fine on the webserver
> if I make a "Virtual Directory" and point to the folder with the webfiles
> (folder "ld").
> Here is the same webside (on the same webserver), but the folder "ld" is a
> Virtual Directory: http://www.minewebsider.no/ld/ -As you see, this works
> fine!
>
> My webserver runs Windows 2003 and IIS 6.0
> Hope someone PLEASE can help me, I can not run all my ASP.NET sites with
> Virtual Directories!
>
>
> Thanks for all replies
>



 
Reply With Quote
 
 
 
 
ScottStoecker@excite.com
Guest
Posts: n/a
 
      11-05-2005
If you change the customError tag in the web.config file, what error
message do you get?

 
Reply With Quote
 
ěyvind Isaksen
Guest
Posts: n/a
 
      11-05-2005
Hi!

In IIS under Documents I have default.aspx listed in "Enable default content
page".






"Mr Newbie" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> How does IIS know that detail.aspx is the default page ?, check your IIS
> web folder settings for this application.
>
> --
> Best Regards
>
> The Inimitable Mr Newbie ║┐║
>
>
>
> "ěyvind Isaksen" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> Hello!
>>
>> I have made an asp.net application, and it works fine on my local
>> computer.
>> But when I transfer it to my webserver (here:
>> http://dev1.softmaker.no/ld/), I get this error message:
>>
>> -----------------------------------
>> Server Error in '/' Application.
>> Description: An application error occurred on the server. The current
>> custom error settings for this application prevent the details of the
>> application error from being viewed remotely (for security reasons). It
>> could, however, be viewed by browsers running on the local server
>> machine.
>> ----------------------------------
>>
>> The strange thing is that the web application works fine on the webserver
>> if I make a "Virtual Directory" and point to the folder with the webfiles
>> (folder "ld").
>> Here is the same webside (on the same webserver), but the folder "ld" is
>> a Virtual Directory: http://www.minewebsider.no/ld/ -As you see, this
>> works fine!
>>
>> My webserver runs Windows 2003 and IIS 6.0
>> Hope someone PLEASE can help me, I can not run all my ASP.NET sites with
>> Virtual Directories!
>>
>>
>> Thanks for all replies
>>

>
>



 
Reply With Quote
 
ěyvind Isaksen
Guest
Posts: n/a
 
      11-06-2005
Hello!

The thing is that there is no error in the asp.net code, I know this because
it works when I use Virtual Directory.

Here I use Virtual Directory, it works:
http://www.minewebsider.no/ld/

This is the exactly same page, but I dont use Virtual Directory (I use IIS).
It fails:
http://dev1.softmaker.no/ld/


By the way, this is my web.config file:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="ConnString"
value="server=MY-SERVER;database=MY-DATABASE;uid=***;pwd=***" />
</appSettings>
<system.web>
<compilation defaultLanguage="vb" debug="true" />

<customErrors mode="Off" />
<trace enabled="false" requestLimit="10" pageOutput="false"
traceMode="SortByTime" localOnly="true" />
<sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424"
sqlConnectionString="data source=127.0.0.1;user id=sa;password="
cookieless="false" timeout="20" />
<globalization requestEncoding="utf-8" responseEncoding="utf-8" />
</system.web>
</configuration>


Thanks for helping me!!!!







<(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
> If you change the customError tag in the web.config file, what error
> message do you get?
>



 
Reply With Quote
 
Mr Newbie
Guest
Posts: n/a
 
      11-06-2005
OK, but the link below shows a page called Detail.aspx. not default.aspx

--
Best Regards

The Inimitable Mr Newbie ║┐║
"ěyvind Isaksen" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi!
>
> In IIS under Documents I have default.aspx listed in "Enable default
> content page".
>
>
>
>
>
>
> "Mr Newbie" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> How does IIS know that detail.aspx is the default page ?, check your IIS
>> web folder settings for this application.
>>
>> --
>> Best Regards
>>
>> The Inimitable Mr Newbie ║┐║
>>
>>
>>
>> "ěyvind Isaksen" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>>> Hello!
>>>
>>> I have made an asp.net application, and it works fine on my local
>>> computer.
>>> But when I transfer it to my webserver (here:
>>> http://dev1.softmaker.no/ld/), I get this error message:
>>>
>>> -----------------------------------
>>> Server Error in '/' Application.
>>> Description: An application error occurred on the server. The current
>>> custom error settings for this application prevent the details of the
>>> application error from being viewed remotely (for security reasons). It
>>> could, however, be viewed by browsers running on the local server
>>> machine.
>>> ----------------------------------
>>>
>>> The strange thing is that the web application works fine on the
>>> webserver if I make a "Virtual Directory" and point to the folder with
>>> the webfiles (folder "ld").
>>> Here is the same webside (on the same webserver), but the folder "ld" is
>>> a Virtual Directory: http://www.minewebsider.no/ld/ -As you see, this
>>> works fine!
>>>
>>> My webserver runs Windows 2003 and IIS 6.0
>>> Hope someone PLEASE can help me, I can not run all my ASP.NET sites with
>>> Virtual Directories!
>>>
>>>
>>> Thanks for all replies
>>>

>>
>>

>
>



 
Reply With Quote
 
Greg Burns
Guest
Posts: n/a
 
      11-06-2005

"ěyvind Isaksen" <(E-Mail Removed)> wrote in message
> My webserver runs Windows 2003 and IIS 6.0
> Hope someone PLEASE can help me, I can not run all my ASP.NET sites with
> Virtual Directories!


I believe you have to, don't you?

Greg


 
Reply With Quote
 
Juan T. Llibre
Guest
Posts: n/a
 
      11-06-2005
He could run them as Websites, too, using host headers,
which is probably just what he needs to do.



Juan T. Llibre, ASP.NET MVP
ASP.NET FAQ : http://asp.net.do/faq/
Foros de ASP.NET en Espa˝ol : http://asp.net.do/foros/
======================================
"Greg Burns" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>
> "ěyvind Isaksen" <(E-Mail Removed)> wrote in message
>> My webserver runs Windows 2003 and IIS 6.0
>> Hope someone PLEASE can help me, I can not run all my ASP.NET sites with Virtual
>> Directories!

>
> I believe you have to, don't you?
>
> Greg
>
>



 
Reply With Quote
 
ěyvind Isaksen
Guest
Posts: n/a
 
      11-06-2005
Yes, I need to run them as websites.
When I use Virtual Directory, it works fine.
But, when I use Websutes using Host Header, I get this Parser Error:

------------------------------
Parser Error
Description: An error occurred during the parsing of a resource required to
service this request. Please review the following specific parse error
details and modify your source file appropriately.

Parser Error Message: Could not load type 'ld.test2'.

Source Error:
Line 1: <%@ Page Language="vb" AutoEventWireup="false"
Codebehind="test2.aspx.vb" Inherits="ld.test2"%>
Line 2: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
Line 3: <HTML>

------------------------------

This file is just an aspx-file with a text field, button and
RequiredFieldValidator. Nothing more.
All my ASP3.0 sites run with Host Header, I dont understand why this dont
work with asp.net files?


Thanks







"Juan T. Llibre" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> He could run them as Websites, too, using host headers,
> which is probably just what he needs to do.
>
>
>
> Juan T. Llibre, ASP.NET MVP
> ASP.NET FAQ : http://asp.net.do/faq/
> Foros de ASP.NET en Espa˝ol : http://asp.net.do/foros/
> ======================================
> "Greg Burns" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>>
>> "ěyvind Isaksen" <(E-Mail Removed)> wrote in message
>>> My webserver runs Windows 2003 and IIS 6.0
>>> Hope someone PLEASE can help me, I can not run all my ASP.NET sites with
>>> Virtual Directories!

>>
>> I believe you have to, don't you?
>>
>> Greg
>>
>>

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Web server reported the following error when attempting to create or open the Web project located at the following URL: 'http://localhost/822319ev1'. 'HTTP/1.1 500 Internal Server Error'. chanmm ASP .Net 2 09-07-2010 07:37 AM
System.Net.WebException: The remote server returned an error: (500) Internal Server Error. kuladeep.mohan@gmail.com ASP .Net 5 08-26-2009 09:36 AM
Help. Getting a An error has occurred while establishing a connectionto the server. When connecting to SQL Server 2005, this failure may be causedby the fact that under the default settings SQL Server does not allow remote aboutjav.com@gmail.com ASP .Net 0 05-03-2008 12:43 PM
Server to server = Server client to server? - Java 2 07-29-2005 10:46 PM
Web server reported following error... HTTP/1.1 500 Internal Server Error John Bonds ASP .Net 2 08-03-2004 10:03 PM



Advertisments