Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > The request failed with HTTP status 401: Unauthorized

Reply
Thread Tools

The request failed with HTTP status 401: Unauthorized

 
 
Sachin
Guest
Posts: n/a
 
      11-04-2005
Scenario:

Machine A: ASP.NET Web UI
IIS 6.0
Windows Server 2003
Impersonation Account: domain\Acct1


Machine B: ASP.NET Web Service
IIS 6.0
Windsow Server 2003
Impersonation Account: domain\Acct2



when Web UI calls Web Service, it fails saying "System.Web.Exception The
request failed with HTTP status 401: Unauthorized."

When I look at the IIS log for Web Service I see,

WebService.asmx -> HTTP Code, 401 2
WebService.asmx -> HTTP Code, 401 3
WebService.asmx -> HTTP Code, 401 1


domain\Acct1 has full control over web service web site and all the files
underneath it.



I used filemon on WebService.asmx and found that IIS is even not tring to
read it.


Then I deployed the same Web Service on Machine C, with similar
configuration. Web UI works fine.

Could someone please help me to find out what could be wrong?

Any pointer?

Thanks in advace
Sachin


 
Reply With Quote
 
 
 
 
Bruce Barker
Guest
Posts: n/a
 
      11-04-2005
either pass credentials when calling webservice, or in the webservice vdir
allow anonymous.

-- bruce (sqlwork.com)

"Sachin" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Scenario:
>
> Machine A: ASP.NET Web UI
> IIS 6.0
> Windows Server 2003
> Impersonation Account: domain\Acct1
>
>
> Machine B: ASP.NET Web Service
> IIS 6.0
> Windsow Server 2003
> Impersonation Account: domain\Acct2
>
>
>
> when Web UI calls Web Service, it fails saying "System.Web.Exception The
> request failed with HTTP status 401: Unauthorized."
>
> When I look at the IIS log for Web Service I see,
>
> WebService.asmx -> HTTP Code, 401 2
> WebService.asmx -> HTTP Code, 401 3
> WebService.asmx -> HTTP Code, 401 1
>
>
> domain\Acct1 has full control over web service web site and all the files
> underneath it.
>
>
>
> I used filemon on WebService.asmx and found that IIS is even not tring to
> read it.
>
>
> Then I deployed the same Web Service on Machine C, with similar
> configuration. Web UI works fine.
>
> Could someone please help me to find out what could be wrong?
>
> Any pointer?
>
> Thanks in advace
> Sachin
>
>



 
Reply With Quote
 
 
 
 
Sachin
Guest
Posts: n/a
 
      11-04-2005
I am passing Default credentials while calling the web service.

Even anonumous access is not working.

However, it works on Machine C.

"Bruce Barker" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> either pass credentials when calling webservice, or in the webservice vdir
> allow anonymous.
>
> -- bruce (sqlwork.com)
>
> "Sachin" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Scenario:
> >
> > Machine A: ASP.NET Web UI
> > IIS 6.0
> > Windows Server 2003
> > Impersonation Account: domain\Acct1
> >
> >
> > Machine B: ASP.NET Web Service
> > IIS 6.0
> > Windsow Server 2003
> > Impersonation Account: domain\Acct2
> >
> >
> >
> > when Web UI calls Web Service, it fails saying "System.Web.Exception The
> > request failed with HTTP status 401: Unauthorized."
> >
> > When I look at the IIS log for Web Service I see,
> >
> > WebService.asmx -> HTTP Code, 401 2
> > WebService.asmx -> HTTP Code, 401 3
> > WebService.asmx -> HTTP Code, 401 1
> >
> >
> > domain\Acct1 has full control over web service web site and all the

files
> > underneath it.
> >
> >
> >
> > I used filemon on WebService.asmx and found that IIS is even not tring

to
> > read it.
> >
> >
> > Then I deployed the same Web Service on Machine C, with similar
> > configuration. Web UI works fine.
> >
> > Could someone please help me to find out what could be wrong?
> >
> > Any pointer?
> >
> > Thanks in advace
> > Sachin
> >
> >

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with ReportingService.Credentials - Syste.Net.WebException - "The request failed with HTTP status 401: Unauthorized." Shree ASP .Net 0 09-02-2006 07:33 PM
The request failed with HTTP status 401: Unauthorized ad ASP .Net 2 02-18-2006 12:11 AM
The request failed with HTTP status 401: Unauthorized ad ASP .Net 0 02-17-2006 06:14 AM
The request failed with HTTP status 401: Unauthorized Sachin ASP .Net Web Services 0 11-04-2005 07:24 PM
The request failed with HTTP status 401: Unauthorized. Kevin Burton ASP .Net Web Services 2 12-19-2004 08:02 AM



Advertisments