Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > SSL and IFrames

Reply
Thread Tools

SSL and IFrames

 
 
UJ
Guest
Posts: n/a
 
      10-10-2005
Are iframes ssl compliant? I have a web page with an iframe on it and when I
run it I get the infamous 'Secure and unsecure items' message. When I
comment it out, it works fine.

Anybody seen this before or know how to fix it?

TIA - Jeff.


 
Reply With Quote
 
 
 
 
Bruce Barker
Guest
Posts: n/a
 
      10-10-2005
yes, they are. you get the message when you set the iframe src to a http://
reference, and the container to a https:// reference or vise-versa.

-- bruce (sqlwork.com)

"UJ" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Are iframes ssl compliant? I have a web page with an iframe on it and when
> I run it I get the infamous 'Secure and unsecure items' message. When I
> comment it out, it works fine.
>
> Anybody seen this before or know how to fix it?
>
> TIA - Jeff.
>
>



 
Reply With Quote
 
 
 
 
UJ
Guest
Posts: n/a
 
      10-10-2005
Bruce,
Thanks for the info. I have my web page source as was generated by my
project and I get the secure and unsecure message. If I comment out the
iframe it works fine. If I remove everything except the tag
<iframe></iframe> I still get the message about secure/unsecure. If I remove
that command with the empty tag info, then I don't get the message. So I
know it's the iframe and there's no source command.

If you have an iframe with no source, what does it assume as a default?

Any thoughts?

TIA - Jeff.

"Bruce Barker" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> yes, they are. you get the message when you set the iframe src to a
> http:// reference, and the container to a https:// reference or
> vise-versa.
>
> -- bruce (sqlwork.com)
>
> "UJ" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> Are iframes ssl compliant? I have a web page with an iframe on it and
>> when I run it I get the infamous 'Secure and unsecure items' message.
>> When I comment it out, it works fine.
>>
>> Anybody seen this before or know how to fix it?
>>
>> TIA - Jeff.
>>
>>

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SSL and OpenSSL::SSL::SSLServer accept() born in USSR Ruby 2 09-27-2009 01:46 AM
Maintain session between an SSL page and Non SSL page John Smith Java 0 10-05-2006 12:03 PM
webrick, ssl and non-ssl on the same port Pavel Smerk Ruby 3 08-15-2006 05:51 PM
SSL with backend SSL on CSS 11500 Olivier PELERIN Cisco 0 08-30-2004 08:30 PM
OT: SSL issues with IFRAMES Marina ASP .Net 1 08-11-2003 05:10 PM



Advertisments