Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Enterprise Library deployment problem. Why needs to InstallUtil DLLs to the deployment server? If not, Registry Error whould shown.

Reply
Thread Tools

Enterprise Library deployment problem. Why needs to InstallUtil DLLs to the deployment server? If not, Registry Error whould shown.

 
 
Benny Ng
Guest
Posts: n/a
 
      10-03-2005
Hi,All,
When i deploy Enterprise library with my application ,i used XCOPY to
deploy it into my test server. But when application runs, shown some error
related registry. (But actually I haven't any method or component to wrote
registry)

After I used "InstallUtil" to registry Enterprise Library (those DLLs)
to the deployment server, the application runs smoothly.

Now I wonder why i need to registry those Enterprise Library DLLs into
the server? and XCOPY not?



---The following is the register code-----
@ECHO Installing Services for the Common Application Block

if Exist Microsoft.Practices.EnterpriseLibrary.Common.dll installutil %1
Microsoft.Practices.EnterpriseLibrary.Common.dll

@if errorlevel 1 goto :error

@ECHO Installing Services for the Caching Application Block

if Exist Microsoft.Practices.EnterpriseLibrary.Caching.dll installutil %1
Microsoft.Practices.EnterpriseLibrary.Caching.dll

@if errorlevel 1 goto :error


@ECHO Installing Services for the ConfigurationApplication Block

if Exist Microsoft.Practices.EnterpriseLibrary.Configuratio n.dll installutil
%1 Microsoft.Practices.EnterpriseLibrary.Configuratio n.dll

@if errorlevel 1 goto :error

@ECHO Installing Services for the Cryptography Application Block

if Exist Microsoft.Practices.EnterpriseLibrary.Security.Cry ptography.dll
installutil %1
Microsoft.Practices.EnterpriseLibrary.Security.Cry ptography.dll

@if errorlevel 1 goto :error

@ECHO Installing Services for the Data Access Application Block

if Exist Microsoft.Practices.EnterpriseLibrary.Data.dll installutil %1
Microsoft.Practices.EnterpriseLibrary.Data.dll

@if errorlevel 1 goto :error

@ECHO Installing Services for the Exception Handling Application Block

if Exist Microsoft.Practices.EnterpriseLibrary.ExceptionHan dling.dll
installutil %1 Microsoft.Practices.EnterpriseLibrary.ExceptionHan dling.dll

@if errorlevel 1 goto :error

@ECHO Installing Services for the Logging and Instrumentation Application
Block

if Exist Microsoft.Practices.EnterpriseLibrary.Logging.dll installutil %1
Microsoft.Practices.EnterpriseLibrary.Logging.dll

@if errorlevel 1 goto :error


@ECHO Installing Services for the Security Application Block

if Exist Microsoft.Practices.EnterpriseLibrary.Security.dll installutil %1
Microsoft.Practices.EnterpriseLibrary.Security.dll

@if errorlevel 1 goto :error



@ECHO.

@ECHO ----------------------------------------

@ECHO InstallServices.bat Completed

@ECHO ----------------------------------------

@ECHO.







 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
InstallUtil failed on Production Server tarunbajaj@gmail.com ASP .Net 0 01-16-2007 07:05 PM
findcontrol("PlaceHolderPrice") why why why why why why why why why why why Mr. SweatyFinger ASP .Net 2 12-02-2006 03:46 PM
equested registry access is not allowed (using Enterprise Library) Andrés Cadavid Gómez ASP .Net Security 6 08-23-2005 06:27 PM
Enterprise Library deployment problem Paul Abraham ASP .Net 1 08-04-2005 01:32 PM
Problems using InstallUtil Rob Meade ASP .Net 3 04-25-2004 10:15 AM



Advertisments