Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > tuning...performance

Reply
Thread Tools

tuning...performance

 
 
abcd
Guest
Posts: n/a
 
      09-23-2005
I am using one asp web page with code behind and using C#. The page is very
slow when first hit. some time doesnt display but if I wait and request the
page it is displayed. What could be the wrong. Do I missing any caching,
performance tuning. Also I noticed that when I request the page it goes
twice into Page_Load?

thanks in advance


 
Reply With Quote
 
 
 
 
Marina
Guest
Posts: n/a
 
      09-23-2005
This is the asp.net process loading up your application. It's normal.

The going into Page_Load twice means you have that event handler added
twice. Most likely it is because you are explicitly adding the handler and
have AutoEventWireup set to True. It's not related to the issue above.

"abcd" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>I am using one asp web page with code behind and using C#. The page is very
>slow when first hit. some time doesnt display but if I wait and request the
>page it is displayed. What could be the wrong. Do I missing any caching,
>performance tuning. Also I noticed that when I request the page it goes
>twice into Page_Load?
>
> thanks in advance
>



 
Reply With Quote
 
 
 
 
abcd
Guest
Posts: n/a
 
      09-23-2005
AutoEventWireup false on my page...


"Marina" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
> This is the asp.net process loading up your application. It's normal.
>
> The going into Page_Load twice means you have that event handler added
> twice. Most likely it is because you are explicitly adding the handler and
> have AutoEventWireup set to True. It's not related to the issue above.
>
> "abcd" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>>I am using one asp web page with code behind and using C#. The page is
>>very slow when first hit. some time doesnt display but if I wait and
>>request the page it is displayed. What could be the wrong. Do I missing
>>any caching, performance tuning. Also I noticed that when I request the
>>page it goes twice into Page_Load?
>>
>> thanks in advance
>>

>
>



 
Reply With Quote
 
Marina
Guest
Posts: n/a
 
      09-23-2005
That was a guess, because that is the most common reason why it happens.
Obviously, can't tell you much else since you didn't post any code.

"abcd" <(E-Mail Removed)> wrote in message
news:%23%(E-Mail Removed)...
> AutoEventWireup false on my page...
>
>
> "Marina" <(E-Mail Removed)> wrote in message
> news:%(E-Mail Removed)...
>> This is the asp.net process loading up your application. It's normal.
>>
>> The going into Page_Load twice means you have that event handler added
>> twice. Most likely it is because you are explicitly adding the handler
>> and have AutoEventWireup set to True. It's not related to the issue
>> above.
>>
>> "abcd" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>>>I am using one asp web page with code behind and using C#. The page is
>>>very slow when first hit. some time doesnt display but if I wait and
>>>request the page it is displayed. What could be the wrong. Do I missing
>>>any caching, performance tuning. Also I noticed that when I request the
>>>page it goes twice into Page_Load?
>>>
>>> thanks in advance
>>>

>>
>>

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Advertisments