Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > anonymous authentication

Reply
Thread Tools

anonymous authentication

 
 
=?Utf-8?B?SnVsaWE=?=
Guest
Posts: n/a
 
      09-02-2005
Hi,
I have a problem when I browse my asp.net pages. The style sheet is not
loaded. If I try to browse the style sheet from the IIS I get this message :
"You are not authorized to view this page".

In my config file I have this settings:

<authentication mode="Forms">
<forms loginUrl="AppLogin.aspx" name=".ASPXFORMSAUTH" protection="All"
slidingExpiration="true"/>
</authentication>

<authorization>
<deny users="?" />
</authorization>

And in my IIS I have marked the Enable Anonymos Access. I am running a
Windows Server 2003.

What can I do to fix this?

Thanks
Julia

 
Reply With Quote
 
 
 
 
Kevin Spencer
Guest
Posts: n/a
 
      09-02-2005
Let's have a look at the HTML for the StyleSheet Link.

--
HTH,

Kevin Spencer
Microsoft MVP
..Net Developer
Neither a follower nor a lender be.

"Julia" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi,
> I have a problem when I browse my asp.net pages. The style sheet is not
> loaded. If I try to browse the style sheet from the IIS I get this message
> :
> "You are not authorized to view this page".
>
> In my config file I have this settings:
>
> <authentication mode="Forms">
> <forms loginUrl="AppLogin.aspx" name=".ASPXFORMSAUTH" protection="All"
> slidingExpiration="true"/>
> </authentication>
>
> <authorization>
> <deny users="?" />
> </authorization>
>
> And in my IIS I have marked the Enable Anonymos Access. I am running a
> Windows Server 2003.
>
> What can I do to fix this?
>
> Thanks
> Julia
>



 
Reply With Quote
 
 
 
 
Bruce Barker
Guest
Posts: n/a
 
      09-02-2005
if you style sheet is name.css or name.html, (not aspx) then security is
handled by iis only. iis use directory security, so check the permission of
the stylesheet directory for the anonymous accout given to iis.


-- bruce (sqlwork.com)

"Julia" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi,
> I have a problem when I browse my asp.net pages. The style sheet is not
> loaded. If I try to browse the style sheet from the IIS I get this message
> :
> "You are not authorized to view this page".
>
> In my config file I have this settings:
>
> <authentication mode="Forms">
> <forms loginUrl="AppLogin.aspx" name=".ASPXFORMSAUTH" protection="All"
> slidingExpiration="true"/>
> </authentication>
>
> <authorization>
> <deny users="?" />
> </authorization>
>
> And in my IIS I have marked the Enable Anonymos Access. I am running a
> Windows Server 2003.
>
> What can I do to fix this?
>
> Thanks
> Julia
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is this a local anonymous class or a member anonymous class Reporter Java 3 05-12-2007 05:23 AM
help with an anonymous array of anonymous hashes noeldamonmiller@gmail.com Perl Misc 1 02-10-2005 01:08 AM
Re: use anonymous but get get an authentication box Curt_C [MVP] ASP .Net 2 09-21-2004 06:39 PM
use anonymous but get get an authentication box =?Utf-8?B?U2hhcmlm?= ASP .Net 0 09-21-2004 01:01 PM
Anonymous login and Windows Authentication Darren Oakey ASP .Net 1 10-29-2003 09:18 PM



Advertisments