Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Asp.net pages not displayed correctly

Reply
Thread Tools

Asp.net pages not displayed correctly

 
 
=?Utf-8?B?YmFocg==?=
Guest
Posts: n/a
 
      08-16-2005
Hello, I am fairly new to asp.net so please be patient with me!
I am working on standing up a website to run alone on someones laptop. So
far, i have been working on the registration pages which are written in
asp.net c#, the rest of the pages are in asp. The website works fine on our
webserver, but when i try to get the website to run alone on the laptop the
asp.net pages do not display correctly. This problem needs to be fixed by the
end of today so if anyone can help, please reply.

ps I am just an intern at our company, my supervisor wrote the rest of the
website, and he is conviently gone this week! I have been able to get the
website up and going, all the asp pages display fine, its just the asp.net
pages that are incorrect. I am running .net framework 1.1 and iis 5.1. I am
currently in the process of reinstalling both of them, upgrading to .net
framework 2.0.
 
Reply With Quote
 
 
 
 
Grant Merwitz
Guest
Posts: n/a
 
      08-16-2005
I've often had the problem, where i installed the .NET framework and then
IIS.

They need to be installed in the opposite order, or the aspx extension is
not registered with IIS
i.e.
Install IIS
Then .NET framework.

Running the aspnet_regiis -i might overcome this problem as well

oh, and a way to check if this is the problem
Open IIS
Go to you default website and right click and click properties
Click the 'Home Directory' tab
Click 'Configuration'
Check if the aspx extension is included in the extension list
If its not there, thats the problem

Hope that can help you

"bahr" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hello, I am fairly new to asp.net so please be patient with me!
> I am working on standing up a website to run alone on someones laptop. So
> far, i have been working on the registration pages which are written in
> asp.net c#, the rest of the pages are in asp. The website works fine on
> our
> webserver, but when i try to get the website to run alone on the laptop
> the
> asp.net pages do not display correctly. This problem needs to be fixed by
> the
> end of today so if anyone can help, please reply.
>
> ps I am just an intern at our company, my supervisor wrote the rest of the
> website, and he is conviently gone this week! I have been able to get the
> website up and going, all the asp pages display fine, its just the asp.net
> pages that are incorrect. I am running .net framework 1.1 and iis 5.1. I
> am
> currently in the process of reinstalling both of them, upgrading to .net
> framework 2.0.



 
Reply With Quote
 
 
 
 
=?Utf-8?B?YmFocg==?=
Guest
Posts: n/a
 
      08-16-2005
Thanks for your input, I have already uninstalled IIS so i can not check to
see if the aspx extension was listed or not, but i will make sure to install
them in the correct order. Also, is there any need for the .net framework SDK
v2.0? I installed the .net framework v2.0 but the SDK is taking forever to
download (very slow network). Just asking because if i dont have to wait for
it to download that would save me about and hour and a half.

"Grant Merwitz" wrote:

> I've often had the problem, where i installed the .NET framework and then
> IIS.
>
> They need to be installed in the opposite order, or the aspx extension is
> not registered with IIS
> i.e.
> Install IIS
> Then .NET framework.
>
> Running the aspnet_regiis -i might overcome this problem as well
>
> oh, and a way to check if this is the problem
> Open IIS
> Go to you default website and right click and click properties
> Click the 'Home Directory' tab
> Click 'Configuration'
> Check if the aspx extension is included in the extension list
> If its not there, thats the problem
>
> Hope that can help you
>
> "bahr" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Hello, I am fairly new to asp.net so please be patient with me!
> > I am working on standing up a website to run alone on someones laptop. So
> > far, i have been working on the registration pages which are written in
> > asp.net c#, the rest of the pages are in asp. The website works fine on
> > our
> > webserver, but when i try to get the website to run alone on the laptop
> > the
> > asp.net pages do not display correctly. This problem needs to be fixed by
> > the
> > end of today so if anyone can help, please reply.
> >
> > ps I am just an intern at our company, my supervisor wrote the rest of the
> > website, and he is conviently gone this week! I have been able to get the
> > website up and going, all the asp pages display fine, its just the asp.net
> > pages that are incorrect. I am running .net framework 1.1 and iis 5.1. I
> > am
> > currently in the process of reinstalling both of them, upgrading to .net
> > framework 2.0.

>
>
>

 
Reply With Quote
 
Grant Merwitz
Guest
Posts: n/a
 
      08-16-2005
SDK is just the developer reference, it is not needed to run .net
applications.
All you need is the .NET framework redistributable

"bahr" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Thanks for your input, I have already uninstalled IIS so i can not check
> to
> see if the aspx extension was listed or not, but i will make sure to
> install
> them in the correct order. Also, is there any need for the .net framework
> SDK
> v2.0? I installed the .net framework v2.0 but the SDK is taking forever
> to
> download (very slow network). Just asking because if i dont have to wait
> for
> it to download that would save me about and hour and a half.
>
> "Grant Merwitz" wrote:
>
>> I've often had the problem, where i installed the .NET framework and then
>> IIS.
>>
>> They need to be installed in the opposite order, or the aspx extension is
>> not registered with IIS
>> i.e.
>> Install IIS
>> Then .NET framework.
>>
>> Running the aspnet_regiis -i might overcome this problem as well
>>
>> oh, and a way to check if this is the problem
>> Open IIS
>> Go to you default website and right click and click properties
>> Click the 'Home Directory' tab
>> Click 'Configuration'
>> Check if the aspx extension is included in the extension list
>> If its not there, thats the problem
>>
>> Hope that can help you
>>
>> "bahr" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>> > Hello, I am fairly new to asp.net so please be patient with me!
>> > I am working on standing up a website to run alone on someones laptop.
>> > So
>> > far, i have been working on the registration pages which are written in
>> > asp.net c#, the rest of the pages are in asp. The website works fine on
>> > our
>> > webserver, but when i try to get the website to run alone on the laptop
>> > the
>> > asp.net pages do not display correctly. This problem needs to be fixed
>> > by
>> > the
>> > end of today so if anyone can help, please reply.
>> >
>> > ps I am just an intern at our company, my supervisor wrote the rest of
>> > the
>> > website, and he is conviently gone this week! I have been able to get
>> > the
>> > website up and going, all the asp pages display fine, its just the
>> > asp.net
>> > pages that are incorrect. I am running .net framework 1.1 and iis 5.1.
>> > I
>> > am
>> > currently in the process of reinstalling both of them, upgrading to
>> > .net
>> > framework 2.0.

>>
>>
>>



 
Reply With Quote
 
=?Utf-8?B?YmFocg==?=
Guest
Posts: n/a
 
      08-16-2005
All right, finally got everything reinstalled and it works, the extensions
are listed. At first i had a problem with parsing the pages but i figured out
that it was a problem with permissions, but now it is all working fine,
thanks alot for your help!
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Japanese Text not displayed on Image Generated by Servlet on winXP, Linux but displayed on Win2000 boney Java 1 12-15-2006 02:24 PM
auto rotation from digital files, not displayed correctly in win64 =?Utf-8?B?cGF1bA==?= Windows 64bit 1 11-10-2005 09:24 PM
Saved HTM File not displayed correctly =?Utf-8?B?TWFya3VzUG9laGxlcg==?= ASP .Net 2 08-01-2005 07:49 PM
Webforms are not displayed correctly in non-MS Browsers? Arnold Franke ASP .Net 2 02-10-2004 10:22 AM
QuickStart mobile page not correctly displayed! Mani ASP .Net Mobile 0 11-20-2003 05:54 AM



Advertisments