Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > CryptographicException Bad Data in Windo

Reply
Thread Tools

CryptographicException Bad Data in Windo

 
 
=?Utf-8?B?ZnJlcXVuZW5jeQ==?=
Guest
Posts: n/a
 
      07-20-2005
Recently I am developing a component (COM) that using Crypto class to perform
TripleDES encryption and decryption.

All instance work well in windows 2003, windows 2000.

However, an exception happens randomly in Windows XP platform.
"
Exception Details: System.Security.Cryptography.CryptographicExceptio n: Bad
Data."

In which I mean, for a ASP.NET web application I may need to refresh several
time until the function perform decryption correctly.

The machine is clean installed with Windows XP SP1 and upgraded to SP2 and
VS.NET 2002. And it happen only in 2 / 5 of machine which operates in Windows
XP.

Anyone facing similar problem?

Thanks
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CryptographicException: Bad Data. Any idea why this happens? simonmarkjones@gmail.com ASP .Net Security 1 08-27-2006 01:17 AM
CryptographicException - Bad Data when changing from SSL to no secure connection z f ASP .Net Security 0 03-05-2005 09:31 PM
Re: "System.Security.Cryptography.CryptographicException: Bad Data" Message Dei401 ASP .Net 0 02-02-2005 04:30 PM
CryptographicException: Bad Data - when storing public key only in key store on encrypting machine pmkatz ASP .Net Security 0 08-25-2004 08:55 PM
CryptographicException: Bad Data jaekim ASP .Net Security 3 09-07-2003 09:16 AM



Advertisments