Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Still problem with Beta 2.0, who can help?

Reply
Thread Tools

Still problem with Beta 2.0, who can help?

 
 
Wernfried Schwenkner
Guest
Posts: n/a
 
      04-26-2005
I've run a site with beta 1.0 without any problems. Since I've
installed Beta 2.0 I can't even run a simple empty page.

Creating an empty site, adding a Default.aspx form. This runs on the
temporary IIS started from within the studio.

But copying the site to the real IIS site, I get the error

Der Typ '_Default' konnte nicht geladen werden.
(Translation: The type '_Default' could not be loaded) within the line
<%@ Page Language="C#" AutoEventWireup="true"
CodeFile="Default.aspx.cs" Inherits="_Default" %>

What am I missing?
One answer I've got from a german page was, that I didn't remove the
prevous beta before installing 2.0. So I've removed and reinstalled it
three times without any sucess, still the same error.

Aren't there any hints? I will not reinstall my windows. Plz help
someone.

--
Sleepless in Berlin
W. Schwenkner
 
Reply With Quote
 
 
 
 
TDAVISJR
Guest
Posts: n/a
 
      04-26-2005
In you @Page directive you have Inherits="_Default" , please make sure that
this is the class name in your codebehind file. Hey, just post the code for
your aspx file and your aspx.cs file. That would help

--
TDAVISJR
aka - Tampa.NET Koder


"Wernfried Schwenkner" <(E-Mail Removed)> wrote in message
news:MPG.1cd892e95b885fd59896db@merlin...
> I've run a site with beta 1.0 without any problems. Since I've
> installed Beta 2.0 I can't even run a simple empty page.
>
> Creating an empty site, adding a Default.aspx form. This runs on the
> temporary IIS started from within the studio.
>
> But copying the site to the real IIS site, I get the error
>
> Der Typ '_Default' konnte nicht geladen werden.
> (Translation: The type '_Default' could not be loaded) within the line
> <%@ Page Language="C#" AutoEventWireup="true"
> CodeFile="Default.aspx.cs" Inherits="_Default" %>
>
> What am I missing?
> One answer I've got from a german page was, that I didn't remove the
> prevous beta before installing 2.0. So I've removed and reinstalled it
> three times without any sucess, still the same error.
>
> Aren't there any hints? I will not reinstall my windows. Plz help
> someone.
>
> --
> Sleepless in Berlin
> W. Schwenkner



 
Reply With Quote
 
 
 
 
Wernfried Schwenkner
Guest
Posts: n/a
 
      04-26-2005
In article <(E-Mail Removed)>,
http://www.velocityreviews.com/forums/(E-Mail Removed) says...
> Hey, just post the code for
> your aspx file and your aspx.cs file. That would help


Here it comes:

<%@ Page Language="C#" AutoEventWireup="true"
CodeFile="Default.aspx.cs" Inherits="_Default" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
<title>Untitled Page</title>
</head>
<body>
<form id="form1" runat="server">
<div>

</div>
</form>
</body>
</html>


using System;
using System.Data;
using System.Configuration;
using System.Collections;
using System.Web;
using System.Web.Security;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.WebControls.WebParts;
using System.Web.UI.HtmlControls;

public partial class _Default : System.Web.UI.Page
{
protected void Page_Load(object sender, EventArgs e)
{

}
}



--
Sleepless in Berlin
W. Schwenkner
 
Reply With Quote
 
Wernfried Schwenkner
Guest
Posts: n/a
 
      04-26-2005
I've seen a hint in the browsers error message (copy from the page)


Serverfehler in der Anwendung '/'.
------------------------------------------------------------------------
--------

Parserfehler
Beschreibung: Beim Verarbeiten einer Resource, die für diese Anforderung
erforderlich ist, ist ein Fehler aufgetreten. Überprüfen Sie folgende
Fehlerinformationen und ändern Sie die Quelldatei entsprechend.

Parser-Fehlermeldung: Der Typ '_Default' konnte nicht geladen werden.

Quellfehler:


Zeile 1: <%@ Page Language="C#" AutoEventWireup="true"
CodeFile="Default.aspx.cs" Inherits="_Default" %>
Zeile 2:
Zeile 3: <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">


Quelldatei: C:\Portale\PortalMerlin\Default.aspx Zeile: 1


------------------------------------------------------------------------
--------
Versionsinformationen: Microsoft .NET Framework Version:1.1.4322.573;
ASP.NET-Version:1.1.4322.573


Here I see, that version 1.1 is used instead of 2.0. Before updating
from beta 1.0 to beta 2.0 an asp site on that direktory worked with the
..Net 2.0 (beta 1). So what have I to do that the IIS also accepts (and
takes) 2.0

--
Sleepless in Berlin
W. Schwenkner
 
Reply With Quote
 
Brock Allen
Guest
Posts: n/a
 
      04-26-2005
My guess is that your application/virtual directory in IIS is still configured
to use ASP.NET 1.1 not 2.0. You need to change the mappings, and if the 2.0
framework installed properly, then the new ASP.NET tab in IIS for your application
should give you an easy way to switch the version used.

-Brock
DevelopMentor
http://staff.develop.com/ballen



> I've run a site with beta 1.0 without any problems. Since I've
> installed Beta 2.0 I can't even run a simple empty page.
>
> Creating an empty site, adding a Default.aspx form. This runs on the
> temporary IIS started from within the studio.
>
> But copying the site to the real IIS site, I get the error
>
> Der Typ '_Default' konnte nicht geladen werden.
> (Translation: The type '_Default' could not be loaded) within the line
> <%@ Page Language="C#" AutoEventWireup="true"
> CodeFile="Default.aspx.cs" Inherits="_Default" %>
> What am I missing?
> One answer I've got from a german page was, that I didn't remove the
> prevous beta before installing 2.0. So I've removed and reinstalled it
> three times without any sucess, still the same error.
> Aren't there any hints? I will not reinstall my windows. Plz help
> someone.
>




 
Reply With Quote
 
Wernfried Schwenkner
Guest
Posts: n/a
 
      04-26-2005
In article <(E-Mail Removed)>,
(E-Mail Removed) says...
> My guess is that your application/virtual directory in IIS is still configured
> to use ASP.NET 1.1 not 2.0. You need to change the mappings, and if the 2.0
> framework installed properly, then the new ASP.NET tab in IIS for your application
> should give you an easy way to switch the version used.


Right, it seams so.

Where do I change the mappings? I don't find any ASP.NET tab.
In the web service extension, v2.0.50215 is anabled.
In ISAPI-Filter of the web site, ASP_NET_2.0.50215.44 is seen with low
priority.

--
Sleepless in Berlin
W. Schwenkner
 
Reply With Quote
 
Juan T. Llibre
Guest
Posts: n/a
 
      04-26-2005
Use Denis Bauer's free ASP.NET Version Switcher.

http://www.denisbauer.com/NETTools/A...nSwitcher.aspx




Juan T. Llibre
ASP.NET MVP
http://asp.net.do/foros/
Foros de ASP.NET en Español
Ven, y hablemos de ASP.NET...
======================

"Wernfried Schwenkner" <(E-Mail Removed)> wrote in message
news:MPG.1cd8aad3330fba679896df@merlin...
> In article <(E-Mail Removed)>,
> (E-Mail Removed) says...
>> My guess is that your application/virtual directory in IIS is still configured
>> to use ASP.NET 1.1 not 2.0. You need to change the mappings, and if the 2.0
>> framework installed properly, then the new ASP.NET tab in IIS for your application
>> should give you an easy way to switch the version used.

>
> Right, it seams so.
>
> Where do I change the mappings? I don't find any ASP.NET tab.
> In the web service extension, v2.0.50215 is anabled.
> In ISAPI-Filter of the web site, ASP_NET_2.0.50215.44 is seen with low
> priority.
>
> --
> Sleepless in Berlin
> W. Schwenkner



 
Reply With Quote
 
Wernfried Schwenkner
Guest
Posts: n/a
 
      04-26-2005
In article <#(E-Mail Removed)>,
(E-Mail Removed) says...
> Use Denis Bauer's free ASP.NET Version Switcher.
>
> http://www.denisbauer.com/NETTools/A...nSwitcher.aspx


You saved my day (night), thanks.
--
Sleepless in Berlin
W. Schwenkner
 
Reply With Quote
 
Brock Allen
Guest
Posts: n/a
 
      04-26-2005
If the tab isn't there, then it means there's a slight problem with the ASP.NET
2.0 install -- this isn't critical, but it means you miss out on the config
stuff in the UI. So, you must do this manually, so you can use aspnet_regiis.exe
to do this or you cann google for the ASP.NET version switcher.

BTW, the incorrect install is typpical when the past version of ASP.NET 2.0
isn't properly uninstalled. I think there's a fix, but again, you'd have
to google for it or search these NGs. I recall someone else posting a link
to the fix. I think it's as simple as registering a COM dll... which one,
I don't know

-Brock
DevelopMentor
http://staff.develop.com/ballen



> In article <(E-Mail Removed)>,
> (E-Mail Removed) says...
>
>> My guess is that your application/virtual directory in IIS is still
>> configured to use ASP.NET 1.1 not 2.0. You need to change the
>> mappings, and if the 2.0 framework installed properly, then the new
>> ASP.NET tab in IIS for your application should give you an easy way
>> to switch the version used.
>>

> Right, it seams so.
>
> Where do I change the mappings? I don't find any ASP.NET tab.
> In the web service extension, v2.0.50215 is anabled.
> In ISAPI-Filter of the web site, ASP_NET_2.0.50215.44 is seen with low
> priority.




 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Request.Browser.MajorVersion.ToString() returns null on ASP.NET 2.0 Beta 1 and Beta 2 ocn0248@hotmail.com ASP .Net 1 05-02-2005 11:46 PM
install Beta 2 after Beta 1? Mark Oliver ASP .Net 3 01-25-2005 01:39 PM
Mozilla: Can I still keep IE and outlook? Or still vulnerable to viruses? lbbss Computer Support 6 08-16-2004 11:55 PM
[ANN] JNIWrapper 2.5 Beta for Windows and JExplorer Beta 3 Eugene Toporov Java 0 07-15-2004 01:15 PM
Beta 70-298 Beta Exam Romila MCSE 1 09-07-2003 11:38 PM



Advertisments