Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > Permissions Issues with ASPNET Account

Reply
Thread Tools

Permissions Issues with ASPNET Account

 
 
=?Utf-8?B?WW9nZXNoIFBhbmNob2xp?=
Guest
Posts: n/a
 
      04-20-2005
For some unexplained reason, I am suddenly unable to browse to a virtual
directory on my laptop. I have a number of sample websites to which I could
happliy browse up until last week. As of Monday, if I browse to any of the
sites, I get an HttpException saying "The directory does not exist or is not
accessible because of security settings." I honestly have not changed
anything at all.

I have checked and re-checked that ASPNET indeed has the three required
permissions on the virtual directories (ie. Read, Read & Execute, and List
Folder Contents). As a workaround, the only way that I am able to currently
browse to the sample websites is I 'upgrade' the access level privilege in
the machine.config as follows:

Go to folder C:\WINNT\Microsoft.NET\Framework\v1.1.4322\CONFIG, and edit the
machine.config file. Find <processModel enable="true" timeout="Infinite"....
and change the username attribute from 'machine' to 'system'. Save the file,
and restart IIS.

I have trawled the internet in the last couple of days, and have discovered
many others have experienced the same problem. For most, it was a matter of
applying the ASPNET account permissions to the virtual folder, but there are
still a number of other people (like myself) for whom this problem persists.
I have even ran aspnet_regiis.exe, but still no joy.

My system specification is as follows:

Windows XP Professional SP1.
Internet Explorer 6.0.2800 SP2.
..NET Framework v1.1
Visual Studio .NET 2003

Below is the exception:

Server Error in '/EC315CH02' Application.
--------------------------------------------------------------------------------

Server cannot access application directory 'E:\Documents and
Settings\...<SubFolders>...\'. The directory does not exist or is not
accessible because of security settings.
Description: An unhandled exception occurred during the execution of the
current web request. Please review the stack trace for more information about
the error and where it originated in the code.

Exception Details: System.Web.HttpException: Server cannot access
application directory 'E:\Documents and Settings\...<SubFolders>...\'. The
directory does not exist or is not accessible because of security settings.

Source Error:

An unhandled exception was generated during the execution of the current web
request. Information regarding the origin and location of the exception can
be identified using the exception stack trace below.

Stack Trace:


[HttpException (0x80004005): Server cannot access application directory
'E:\Documents and Settings\...<SubFolders>...\'. The directory does not exist
or is not accessible because of security settings.]
System.Web.HttpRuntime.EnsureAccessToApplicationDi rectory() +72
System.Web.HttpRuntime.FirstRequestInit(HttpContex t context) +264

[HttpException (0x80004005): ASP.NET Initialization Error]
System.Web.HttpRuntime.FirstRequestInit(HttpContex t context) +990
System.Web.HttpRuntime.ProcessRequestInternal(Http WorkerRequest wr) +128

--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2032; ASP.NET
Version:1.1.4322.2032

Does anyone know what could be the problem???

Can anyone provide any assistance to resolve it???

--
....Yogesh
"If a pig loses its voice, is it disgruntled???"
 
Reply With Quote
 
 
 
 
Brock Allen
Guest
Posts: n/a
 
      04-21-2005
Is E a mapped drive? A mapped drive works only for the current logon session
which isn't the one ASP.NET is running in since it's running as a different
user.

-Brock
DevelopMentor
http://staff.develop.com/ballen



> For some unexplained reason, I am suddenly unable to browse to a
> virtual directory on my laptop. I have a number of sample websites to
> which I could happliy browse up until last week. As of Monday, if I
> browse to any of the sites, I get an HttpException saying "The
> directory does not exist or is not accessible because of security
> settings." I honestly have not changed anything at all.
>
> I have checked and re-checked that ASPNET indeed has the three
> required permissions on the virtual directories (ie. Read, Read &
> Execute, and List Folder Contents). As a workaround, the only way that
> I am able to currently browse to the sample websites is I 'upgrade'
> the access level privilege in the machine.config as follows:
>
> Go to folder C:\WINNT\Microsoft.NET\Framework\v1.1.4322\CONFIG, and
> edit the machine.config file. Find <processModel enable="true"
> timeout="Infinite".... and change the username attribute from
> 'machine' to 'system'. Save the file, and restart IIS.
>
> I have trawled the internet in the last couple of days, and have
> discovered many others have experienced the same problem. For most, it
> was a matter of applying the ASPNET account permissions to the virtual
> folder, but there are still a number of other people (like myself) for
> whom this problem persists. I have even ran aspnet_regiis.exe, but
> still no joy.
>
> My system specification is as follows:
>
> Windows XP Professional SP1.
> Internet Explorer 6.0.2800 SP2.
> .NET Framework v1.1
> Visual Studio .NET 2003
> Below is the exception:
>
> Server Error in '/EC315CH02' Application.
> ----------------------------------------------------------------------
> ----------
> Server cannot access application directory 'E:\Documents and
> Settings\...<SubFolders>...\'. The directory does not exist or is not
> accessible because of security settings. Description: An unhandled
> exception occurred during the execution of the current web request.
> Please review the stack trace for more information about the error and
> where it originated in the code.
>
> Exception Details: System.Web.HttpException: Server cannot access
> application directory 'E:\Documents and Settings\...<SubFolders>...\'.
> The directory does not exist or is not accessible because of security
> settings.
>
> Source Error:
>
> An unhandled exception was generated during the execution of the
> current web request. Information regarding the origin and location of
> the exception can be identified using the exception stack trace below.
>
> Stack Trace:
>
> [HttpException (0x80004005): Server cannot access application
> directory
> 'E:\Documents and Settings\...<SubFolders>...\'. The directory does
> not exist
> or is not accessible because of security settings.]
> System.Web.HttpRuntime.EnsureAccessToApplicationDi rectory() +72
> System.Web.HttpRuntime.FirstRequestInit(HttpContex t context) +264
> [HttpException (0x80004005): ASP.NET Initialization Error]
> System.Web.HttpRuntime.FirstRequestInit(HttpContex t context) +990
> System.Web.HttpRuntime.ProcessRequestInternal(Http WorkerRequest wr)
> +128
> ----------------------------------------------------------------------
> ---------- Version Information: Microsoft .NET Framework
> Version:1.1.4322.2032; ASP.NET Version:1.1.4322.2032
>
> Does anyone know what could be the problem???
>
> Can anyone provide any assistance to resolve it???
>




 
Reply With Quote
 
 
 
 
=?Utf-8?B?WW9nZXNoIFBhbmNob2xp?=
Guest
Posts: n/a
 
      04-21-2005
No, Drive E is a local hard drive.

Cheers....

.....Yogesh


"Brock Allen" wrote:

> Is E a mapped drive? A mapped drive works only for the current logon session
> which isn't the one ASP.NET is running in since it's running as a different
> user.
>
> -Brock
> DevelopMentor
> http://staff.develop.com/ballen
>
>
>
> > For some unexplained reason, I am suddenly unable to browse to a
> > virtual directory on my laptop. I have a number of sample websites to
> > which I could happliy browse up until last week. As of Monday, if I
> > browse to any of the sites, I get an HttpException saying "The
> > directory does not exist or is not accessible because of security
> > settings." I honestly have not changed anything at all.
> >
> > I have checked and re-checked that ASPNET indeed has the three
> > required permissions on the virtual directories (ie. Read, Read &
> > Execute, and List Folder Contents). As a workaround, the only way that
> > I am able to currently browse to the sample websites is I 'upgrade'
> > the access level privilege in the machine.config as follows:
> >
> > Go to folder C:\WINNT\Microsoft.NET\Framework\v1.1.4322\CONFIG, and
> > edit the machine.config file. Find <processModel enable="true"
> > timeout="Infinite".... and change the username attribute from
> > 'machine' to 'system'. Save the file, and restart IIS.
> >
> > I have trawled the internet in the last couple of days, and have
> > discovered many others have experienced the same problem. For most, it
> > was a matter of applying the ASPNET account permissions to the virtual
> > folder, but there are still a number of other people (like myself) for
> > whom this problem persists. I have even ran aspnet_regiis.exe, but
> > still no joy.
> >
> > My system specification is as follows:
> >
> > Windows XP Professional SP1.
> > Internet Explorer 6.0.2800 SP2.
> > .NET Framework v1.1
> > Visual Studio .NET 2003
> > Below is the exception:
> >
> > Server Error in '/EC315CH02' Application.
> > ----------------------------------------------------------------------
> > ----------
> > Server cannot access application directory 'E:\Documents and
> > Settings\...<SubFolders>...\'. The directory does not exist or is not
> > accessible because of security settings. Description: An unhandled
> > exception occurred during the execution of the current web request.
> > Please review the stack trace for more information about the error and
> > where it originated in the code.
> >
> > Exception Details: System.Web.HttpException: Server cannot access
> > application directory 'E:\Documents and Settings\...<SubFolders>...\'.
> > The directory does not exist or is not accessible because of security
> > settings.
> >
> > Source Error:
> >
> > An unhandled exception was generated during the execution of the
> > current web request. Information regarding the origin and location of
> > the exception can be identified using the exception stack trace below.
> >
> > Stack Trace:
> >
> > [HttpException (0x80004005): Server cannot access application
> > directory
> > 'E:\Documents and Settings\...<SubFolders>...\'. The directory does
> > not exist
> > or is not accessible because of security settings.]
> > System.Web.HttpRuntime.EnsureAccessToApplicationDi rectory() +72
> > System.Web.HttpRuntime.FirstRequestInit(HttpContex t context) +264
> > [HttpException (0x80004005): ASP.NET Initialization Error]
> > System.Web.HttpRuntime.FirstRequestInit(HttpContex t context) +990
> > System.Web.HttpRuntime.ProcessRequestInternal(Http WorkerRequest wr)
> > +128
> > ----------------------------------------------------------------------
> > ---------- Version Information: Microsoft .NET Framework
> > Version:1.1.4322.2032; ASP.NET Version:1.1.4322.2032
> >
> > Does anyone know what could be the problem???
> >
> > Can anyone provide any assistance to resolve it???
> >

>
>
>
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ASPNET account permissions Paul Aspinall ASP .Net 5 03-07-2006 09:12 PM
ASPNET Account Permissions for .NET 2.0? =?Utf-8?B?cGFsYWt3YWlfOTE5?= ASP .Net 4 08-17-2005 08:34 PM
Permissions Issues With ASPNET Account Yogesh Pancholi ASP .Net Security 4 04-25-2005 11:18 PM
How to give ACL permissions to ASPNET account djoledjole ASP .Net 2 04-08-2005 01:19 PM
Permissions for ASPNET Account Simon Harris ASP .Net 2 01-06-2005 08:15 AM



Advertisments