Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP.NET 2.0: "hello world" page fails with "Failed to map the path

Reply
Thread Tools

ASP.NET 2.0: "hello world" page fails with "Failed to map the path

 
 
=?Utf-8?B?cmFuZHkgY29sbGlucw==?=
Guest
Posts: n/a
 
      04-15-2005
I've installed Visual Studio 2005 Beta from the MSDN cd dated Aug 2004, which
installs the 2.0 framework and ASP.NET 2.0. I write a simple aspx page
containing <HTML><BODY>Hello world</BODY></HTML> and place it in
inetpub\wwwroot. I run the page http://localhost/test.aspx and it fails with
"Server Error in '/' Application." "Failed to map the path '/test.aspx'. " I
can successfully run asp and htm pages from that same location, however.

Help would be appreciated.

--
randy
 
Reply With Quote
 
 
 
 
Steve C. Orr [MVP, MCSD]
Guest
Posts: n/a
 
      04-15-2005
You might need to repair your IIS mappings.
You can use the instructions listed here:
http://SteveOrr.net/faq/3in1.aspx

--
I hope this helps,
Steve C. Orr, MCSD, MVP
http://SteveOrr.net



"randy collins" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> I've installed Visual Studio 2005 Beta from the MSDN cd dated Aug 2004,
> which
> installs the 2.0 framework and ASP.NET 2.0. I write a simple aspx page
> containing <HTML><BODY>Hello world</BODY></HTML> and place it in
> inetpub\wwwroot. I run the page http://localhost/test.aspx and it fails
> with
> "Server Error in '/' Application." "Failed to map the path '/test.aspx'. "
> I
> can successfully run asp and htm pages from that same location, however.
>
> Help would be appreciated.
>
> --
> randy



 
Reply With Quote
 
 
 
 
=?Utf-8?B?cmFuZHkgY29sbGlucw==?=
Guest
Posts: n/a
 
      04-15-2005
Thanks for your reply, Steve. I gave ASPNET_REGIIS.EXE -i a try, as you
suggested, but it did not change the outcome.

"Steve C. Orr [MVP, MCSD]" wrote:

> You might need to repair your IIS mappings.
> You can use the instructions listed here:
> http://SteveOrr.net/faq/3in1.aspx
>
> --
> I hope this helps,
> Steve C. Orr, MCSD, MVP
> http://SteveOrr.net
>
>
>
> "randy collins" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > I've installed Visual Studio 2005 Beta from the MSDN cd dated Aug 2004,
> > which
> > installs the 2.0 framework and ASP.NET 2.0. I write a simple aspx page
> > containing <HTML><BODY>Hello world</BODY></HTML> and place it in
> > inetpub\wwwroot. I run the page http://localhost/test.aspx and it fails
> > with
> > "Server Error in '/' Application." "Failed to map the path '/test.aspx'. "
> > I
> > can successfully run asp and htm pages from that same location, however.
> >
> > Help would be appreciated.
> >
> > --
> > randy

>
>
>

 
Reply With Quote
 
Matt Berther
Guest
Posts: n/a
 
      04-15-2005
Hello randy,

I think this is because wwwroot is not a vroot. ASP.NET apps need to have
a vroot.

--
Matt Berther
http://www.mattberther.com

> I've installed Visual Studio 2005 Beta from the MSDN cd dated Aug
> 2004, which installs the 2.0 framework and ASP.NET 2.0. I write a
> simple aspx page containing <HTML><BODY>Hello world</BODY></HTML> and
> place it in inetpub\wwwroot. I run the page http://localhost/test.aspx
> and it fails with "Server Error in '/' Application." "Failed to map
> the path '/test.aspx'. " I can successfully run asp and htm pages
> from that same location, however.
>
> Help would be appreciated.
>



 
Reply With Quote
 
=?Utf-8?B?cmFuZHkgY29sbGlucw==?=
Guest
Posts: n/a
 
      04-15-2005
Thanks for your reply, Matt, however, I get this same error regardless of
whether I put the aspx page in a virtual directory or in the root of the
website. I can access asp pages from either of these. I reinstalled visual
studio 2005 a second time and reran the asp.net registration, too, to no
avail.


"Matt Berther" wrote:

> Hello randy,
>
> I think this is because wwwroot is not a vroot. ASP.NET apps need to have
> a vroot.
>
> --
> Matt Berther
> http://www.mattberther.com
>
> > I've installed Visual Studio 2005 Beta from the MSDN cd dated Aug
> > 2004, which installs the 2.0 framework and ASP.NET 2.0. I write a
> > simple aspx page containing <HTML><BODY>Hello world</BODY></HTML> and
> > place it in inetpub\wwwroot. I run the page http://localhost/test.aspx
> > and it fails with "Server Error in '/' Application." "Failed to map
> > the path '/test.aspx'. " I can successfully run asp and htm pages
> > from that same location, however.
> >
> > Help would be appreciated.
> >

>
>
>

 
Reply With Quote
 
=?Utf-8?B?UmljaA==?=
Guest
Posts: n/a
 
      07-13-2005
I'm getting this error as well. Has anyone been able to resolve it?

"randy collins" wrote:

> Thanks for your reply, Matt, however, I get this same error regardless of
> whether I put the aspx page in a virtual directory or in the root of the
> website. I can access asp pages from either of these. I reinstalled visual
> studio 2005 a second time and reran the asp.net registration, too, to no
> avail.
>
>
> "Matt Berther" wrote:
>
> > Hello randy,
> >
> > I think this is because wwwroot is not a vroot. ASP.NET apps need to have
> > a vroot.
> >
> > --
> > Matt Berther
> > http://www.mattberther.com
> >
> > > I've installed Visual Studio 2005 Beta from the MSDN cd dated Aug
> > > 2004, which installs the 2.0 framework and ASP.NET 2.0. I write a
> > > simple aspx page containing <HTML><BODY>Hello world</BODY></HTML> and
> > > place it in inetpub\wwwroot. I run the page http://localhost/test.aspx
> > > and it fails with "Server Error in '/' Application." "Failed to map
> > > the path '/test.aspx'. " I can successfully run asp and htm pages
> > > from that same location, however.
> > >
> > > Help would be appreciated.
> > >

> >
> >
> >

 
Reply With Quote
 
eagle1140 eagle1140 is offline
Junior Member
Join Date: Apr 2011
Posts: 1
 
      04-13-2011
Am also getting the same error. do any one have any idea reagrding the same.
Will appreciate any reply.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Constant.t fails 240 of 272 tests and recurs.t fails 1 of 25 tests on HPUX using perl 5.8.7 dayo Perl Misc 11 12-16-2005 09:09 PM
Server.MapPath() croaking with "failed to map path", but path is legal awbacker@gmail.com ASP .Net 0 05-12-2005 10:50 PM
I can map all files (.*) to asp.net worker.How do I map NO FILE to asp.net worker? alex ASP .Net 1 02-04-2005 03:18 AM
slideshow fails, Firefox debugger also fails lkrubner@geocities.com Javascript 2 12-23-2004 06:22 PM
Forms Authentication Fails Between ASP.NET 1.0 and 1.1 Applications (Cookie Decryption Fails) John Saunders ASP .Net 1 11-18-2003 03:25 PM



Advertisments