Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   HTML (http://www.velocityreviews.com/forums/f31-html.html)
-   -   Re: Cannot use more than one link tag? (http://www.velocityreviews.com/forums/t961428-re-cannot-use-more-than-one-link-tag.html)

richard 06-05-2013 04:51 AM

Re: Cannot use more than one link tag?
 
On 04 Jun 2013 22:34:57 GMT, Marty wrote:

> This is driving me nuts.
>
> In the CSS file I have:
>
> a.blue { display:block ;
> width:120px ;
> height:120px ;
> background:url("bluepicture.gif") no-repeat ;
> }
>
> a.blue:hover {
>
> background:url("differentbluepicture.jpg") no-repeat ;
> }​
>
> a.red { display:block ;
> width:120px ;
> height:120px ;
> background:url("redpicture.gif") no-repeat ;
> }
>
> a.red:hover {
>
> background:url("differentredpicture.jpg") no-repeat ;
> }​
>
> In the code I use:
>
> <td width="140px"><a class="blue" href="gotobluesite.php"></a></td>
> <td width="140px"><a class="red" href="gotoredsite.php"></a></td>
>
> The blue picture and the hover picture will work for blue but not for
> red. If I reverse the order of the css, then the top one will work not
> the second.
>
> What stupid mistake am I making?


I copied and pasted your css code and ran it through a CSS validator.
When you do this, you will find two hidden "?".
I use notepad++. It's an excellent tool for html and css.
it's free too.

Tim Streater 06-05-2013 03:25 PM

Re: Cannot use more than one link tag?
 
In article <51af530f$0$1741$c3e8da3$5d8fb80f@news.astraweb.co m>,
Marty <martyfl@aol.com> wrote:

> On Wed, 05 Jun 2013 00:51:54 -0400, richard wrote:
>
>
> >
> > I copied and pasted your css code and ran it through a CSS validator.
> > When you do this, you will find two hidden "?".
> > I use notepad++. It's an excellent tool for html and css.
> > it's free too.

>
> I want to thank everyone who made an effort to help me. Even those who
> focused on the perfection of the code and not the problem at hand.
>
> I did find a parse error and all I had to do was type in the code once
> again from scratch. I did not change a thing and it works perfectly now.
>
> I unfortunately cannot see hidden characters in Bluefish. Maybe there is
> a way that I have not learned about. But, in most other respects it does
> the job. I might try another editor but it has to work with Ubuntu.
>
> Again, thank you all.


Glad it worked. But do look to see if there is some Bluefish feature to
"show invisibles", or, failing that, see if you can find another editor
which can - even if you only use it for that purpose.

--
Tim

"That excessive bail ought not to be required, nor excessive fines imposed,
nor cruel and unusual punishments inflicted" -- Bill of Rights 1689

Denis McMahon 06-05-2013 07:19 PM

Re: Cannot use more than one link tag?
 
On Wed, 05 Jun 2013 16:25:24 +0100, Tim Streater wrote:

> Glad it worked. But do look to see if there is some Bluefish feature to
> "show invisibles", or, failing that, see if you can find another editor
> which can - even if you only use it for that purpose.


The closest option I could find in bluefish was:

edit / preferences / visible whitespace mode -> all

gedit (which I use) usually shows weird characters as a square box
containing 4 miniaturised hex values, or refuses to load the file if it
finds character codes that are incompatible with what it thinks it should
be displaying.

--
Denis McMahon, denismfmcmahon@gmail.com


All times are GMT. The time now is 12:13 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.