Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Perl Misc (http://www.velocityreviews.com/forums/f67-perl-misc.html)
-   -   Weak references are not implemented in the version of perl at /tmp/replacebinary/Getopt/LL/DLList/Node.pm line 11 (http://www.velocityreviews.com/forums/t905193-weak-references-are-not-implemented-in-the-version-of-perl-at-tmp-replacebinary-getopt-ll-dllist-node-pm-line-11-a.html)

zigzagdna@yahoo.com 11-04-2007 03:30 AM

Weak references are not implemented in the version of perl at /tmp/replacebinary/Getopt/LL/DLList/Node.pm line 11
 
On my UNIX Server, perl 5.8.0 in installed. When I enter command:
perl -X -U plbsed.pl
I get following error:
Weak references are not implemented in the version of perl at /tmp/
replacebinary/Getopt/LL/DLList/Node.pm line 11
BEGIN failed--compilation aborted at /tmp/replacebinary/Getopt/LL/
DLList/Node.pm line 11.
Compilation failed in require at /tmp/replacebinary/Getopt/LL/
DLList.pm line 11.

I do not know how to suppress this error despite reaidng many artcles
on google.


Ben Morrow 11-04-2007 06:01 AM

Re: Weak references are not implemented in the version of perl at /tmp/replacebinary/Getopt/LL/DLList/Node.pm line 11
 

Quoth zigzagdna@yahoo.com:
> On my UNIX Server, perl 5.8.0 in installed. When I enter command:
> perl -X -U plbsed.pl
> I get following error:
> Weak references are not implemented in the version of perl at /tmp/
> replacebinary/Getopt/LL/DLList/Node.pm line 11
> BEGIN failed--compilation aborted at /tmp/replacebinary/Getopt/LL/
> DLList/Node.pm line 11.
> Compilation failed in require at /tmp/replacebinary/Getopt/LL/
> DLList.pm line 11.
>
> I do not know how to suppress this error despite reaidng many artcles
> on google.


You need to install the XS version of Scalar::Util. Make sure you have a
compiler installed, and that it is the one used to build your perl (if
it isn't, you will need to rebuild perl with this compiler), and then
reinstall Scalar::Util from CPAN.

Ben


zigzagdna@yahoo.com 11-04-2007 12:58 PM

Re: Weak references are not implemented in the version of perl at /tmp/replacebinary/Getopt/LL/DLList/Node.pm line 11
 
On Nov 4, 1:01 am, Ben Morrow <b...@morrow.me.uk> wrote:
> Quoth zigzag...@yahoo.com:
>
> > On my UNIX Server, perl 5.8.0 in installed. When I enter command:
> > perl -X -U plbsed.pl
> > I get following error:
> > Weak references are not implemented in the version of perl at /tmp/
> > replacebinary/Getopt/LL/DLList/Node.pm line 11
> > BEGIN failed--compilation aborted at /tmp/replacebinary/Getopt/LL/
> > DLList/Node.pm line 11.
> > Compilation failed in require at /tmp/replacebinary/Getopt/LL/
> > DLList.pm line 11.

>
> > I do not know how to suppress this error despite reaidng many artcles
> > on google.

>
> You need to install the XS version of Scalar::Util. Make sure you have a
> compiler installed, and that it is the one used to build your perl (if
> it isn't, you will need to rebuild perl with this compiler), and then
> reinstall Scalar::Util from CPAN.
>
> Ben


Soory, my knowelege of Perl is so so. How does on einstall XS version
of Scalar::Util. I had gone to CPAN and dowloaded Scalar-List-
Utils-1.19/lib/Scalar/Util.pm.

I ma not HP UNIX 11.11 on Itanium 64. Perl is installed as root, so I
cannot change it. How does
one find what compiler perl was used to compile installed version and
how does one install XS version of Source::Util.


zigzagdna@yahoo.com 11-04-2007 03:20 PM

Re: Weak references are not implemented in the version of perl at /tmp/replacebinary/Getopt/LL/DLList/Node.pm line 11
 
On Nov 4, 7:58 am, zigzag...@yahoo.com wrote:
> On Nov 4, 1:01 am, Ben Morrow <b...@morrow.me.uk> wrote:
>
>
>
>
>
> > Quoth zigzag...@yahoo.com:

>
> > > On my UNIX Server, perl 5.8.0 in installed. When I enter command:
> > > perl -X -U plbsed.pl
> > > I get following error:
> > > Weak references are not implemented in the version of perl at /tmp/
> > > replacebinary/Getopt/LL/DLList/Node.pm line 11
> > > BEGIN failed--compilation aborted at /tmp/replacebinary/Getopt/LL/
> > > DLList/Node.pm line 11.
> > > Compilation failed in require at /tmp/replacebinary/Getopt/LL/
> > > DLList.pm line 11.

>
> > > I do not know how to suppress this error despite reaidng many artcles
> > > on google.

>
> > You need to install the XS version of Scalar::Util. Make sure you have a
> > compiler installed, and that it is the one used to build your perl (if
> > it isn't, you will need to rebuild perl with this compiler), and then
> > reinstall Scalar::Util from CPAN.

>
> > Ben

>
> Soory, my knowelege of Perl is so so. How does on einstall XS version
> of Scalar::Util. I had gone to CPAN and dowloaded Scalar-List-
> Utils-1.19/lib/Scalar/Util.pm.
>
> I ma not HP UNIX 11.11 on Itanium 64. Perl is installed as root, so I
> cannot change it. How does
> one find what compiler perl was used to compile installed version and
> how does one install XS version of Source::Util.- Hide quoted text -
>
> - Show quoted text -


I ot past that error but I have new problems. Problem I am having is
plbsed.pl is that plbsed refers to so many other files which refer to
other files, so it is not clear what all othre Perl files are
required. Is there a way to install complete set of files for plbsed
to work.




All times are GMT. The time now is 01:52 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.