Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net (http://www.velocityreviews.com/forums/f29-asp-net.html)
-   -   DataGrid - BorderStyle="None" and BorderWidth="None" doesn't work for Firefox (http://www.velocityreviews.com/forums/t90382-datagrid-borderstyle-none-and-borderwidth-none-doesnt-work-for-firefox.html)

David Freeman 11-08-2004 10:23 PM

DataGrid - BorderStyle="None" and BorderWidth="None" doesn't work for Firefox
 
Hi There!

I'm using ASP.NET 1.1 and VB.

Below is my DataGrid declaration...

<asp:DataGrid
id="myDataGrid"
runat="server"
AutoGenerateColumns="false"
OnItemCreated="myDataGrid_ItemCreated"
Style="width:100%;border:0px;background-color:transparent;"
cellspacing="0"
cellpadding="0"
BorderWidth="0px">

It worked in MSIE 6 but it doesn't work for Firefox: black lines for rows
and columns are drawn!! I've investigated the responsed HTML code and below
is what I've discovered...

<table cellspacing="0" cellpadding="5" rules="all" border="0"
id="WebControl1_myDataGrid"
style="width:100%;border:0px;background-color:transparent;">

So rules="all" is causing the FireFox to draw these lines.

How do I disable it???

David



David Freeman 11-08-2004 11:13 PM

Re: DataGrid - BorderStyle="None" and BorderWidth="None" doesn't work for Firefox
 
....

"David Freeman" <no-email@mailingspam.com> wrote in message
news:ev67eGexEHA.2996@TK2MSFTNGP10.phx.gbl...
> Hi There!
>
> I'm using ASP.NET 1.1 and VB.
>
> Below is my DataGrid declaration...
>
> <asp:DataGrid
> id="myDataGrid"
> runat="server"
> AutoGenerateColumns="false"
> OnItemCreated="myDataGrid_ItemCreated"
> Style="width:100%;border:0px;background-color:transparent;"
> cellspacing="0"
> cellpadding="0"
> BorderWidth="0px">
>
> It worked in MSIE 6 but it doesn't work for Firefox: black lines for rows
> and columns are drawn!! I've investigated the responsed HTML code and
> below is what I've discovered...
>
> <table cellspacing="0" cellpadding="5" rules="all" border="0"
> id="WebControl1_myDataGrid"
> style="width:100%;border:0px;background-color:transparent;">
>
> So rules="all" is causing the FireFox to draw these lines.
>
> How do I disable it???
>
> David
>




=?Utf-8?B?UGF0cmljay5PLklnZQ==?= 11-08-2004 11:29 PM

Re: DataGrid - BorderStyle="None" and BorderWidth="None" doesn't w
 
the problem i guess david is that Datagrid creates (grid) with HTML
Is it possible to use another control apart from DAtagrid?
Or maybe use javascript to check for the browsersfirst before rendering ur
pages



"David Freeman" wrote:

> ....
>
> "David Freeman" <no-email@mailingspam.com> wrote in message
> news:ev67eGexEHA.2996@TK2MSFTNGP10.phx.gbl...
> > Hi There!
> >
> > I'm using ASP.NET 1.1 and VB.
> >
> > Below is my DataGrid declaration...
> >
> > <asp:DataGrid
> > id="myDataGrid"
> > runat="server"
> > AutoGenerateColumns="false"
> > OnItemCreated="myDataGrid_ItemCreated"
> > Style="width:100%;border:0px;background-color:transparent;"
> > cellspacing="0"
> > cellpadding="0"
> > BorderWidth="0px">
> >
> > It worked in MSIE 6 but it doesn't work for Firefox: black lines for rows
> > and columns are drawn!! I've investigated the responsed HTML code and
> > below is what I've discovered...
> >
> > <table cellspacing="0" cellpadding="5" rules="all" border="0"
> > id="WebControl1_myDataGrid"
> > style="width:100%;border:0px;background-color:transparent;">
> >
> > So rules="all" is causing the FireFox to draw these lines.
> >
> > How do I disable it???
> >
> > David
> >

>
>
>


David Freeman 11-09-2004 05:51 AM

Re: DataGrid - BorderStyle="None" and BorderWidth="None" doesn't w
 
Hi Patrick!

Thanks for the reply! Yea I don't know what I did wrong, before it was OK on
Firefox AND MSIE. And Firefox suddenly starts showing these lines on the
grid. And when I inspected the HTML output code, I found that rules="all"
attribute.

Anyway, I guess I might have to use client-side JavaScript to change the
rules attribute at client side. But I'm sure there should be a way to turn
this off from server side. Hopefully I can find out.

Wish me luck!
David

"Patrick.O.Ige" <PatrickOIge@discussions.microsoft.com> wrote in message
news:274A0B2E-0AF1-46C6-813C-02622B6F0E17@microsoft.com...
> the problem i guess david is that Datagrid creates (grid) with HTML
> Is it possible to use another control apart from DAtagrid?
> Or maybe use javascript to check for the browsersfirst before rendering ur
> pages
>
>
>
> "David Freeman" wrote:
>
>> ....
>>
>> "David Freeman" <no-email@mailingspam.com> wrote in message
>> news:ev67eGexEHA.2996@TK2MSFTNGP10.phx.gbl...
>> > Hi There!
>> >
>> > I'm using ASP.NET 1.1 and VB.
>> >
>> > Below is my DataGrid declaration...
>> >
>> > <asp:DataGrid
>> > id="myDataGrid"
>> > runat="server"
>> > AutoGenerateColumns="false"
>> > OnItemCreated="myDataGrid_ItemCreated"
>> > Style="width:100%;border:0px;background-color:transparent;"
>> > cellspacing="0"
>> > cellpadding="0"
>> > BorderWidth="0px">
>> >
>> > It worked in MSIE 6 but it doesn't work for Firefox: black lines for
>> > rows
>> > and columns are drawn!! I've investigated the responsed HTML code and
>> > below is what I've discovered...
>> >
>> > <table cellspacing="0" cellpadding="5" rules="all" border="0"
>> > id="WebControl1_myDataGrid"
>> > style="width:100%;border:0px;background-color:transparent;">
>> >
>> > So rules="all" is causing the FireFox to draw these lines.
>> >
>> > How do I disable it???
>> >
>> > David
>> >

>>
>>
>>




=?Utf-8?B?UGF0cmljay5PLklnZQ==?= 12-10-2004 06:43 AM

Re: DataGrid - BorderStyle="None" and BorderWidth="None" doesn't w
 
David..
Did u find a solution for that?



"David Freeman" wrote:

> Hi Patrick!
>
> Thanks for the reply! Yea I don't know what I did wrong, before it was OK on
> Firefox AND MSIE. And Firefox suddenly starts showing these lines on the
> grid. And when I inspected the HTML output code, I found that rules="all"
> attribute.
>
> Anyway, I guess I might have to use client-side JavaScript to change the
> rules attribute at client side. But I'm sure there should be a way to turn
> this off from server side. Hopefully I can find out.
>
> Wish me luck!
> David
>
> "Patrick.O.Ige" <PatrickOIge@discussions.microsoft.com> wrote in message
> news:274A0B2E-0AF1-46C6-813C-02622B6F0E17@microsoft.com...
> > the problem i guess david is that Datagrid creates (grid) with HTML
> > Is it possible to use another control apart from DAtagrid?
> > Or maybe use javascript to check for the browsersfirst before rendering ur
> > pages
> >
> >
> >
> > "David Freeman" wrote:
> >
> >> ....
> >>
> >> "David Freeman" <no-email@mailingspam.com> wrote in message
> >> news:ev67eGexEHA.2996@TK2MSFTNGP10.phx.gbl...
> >> > Hi There!
> >> >
> >> > I'm using ASP.NET 1.1 and VB.
> >> >
> >> > Below is my DataGrid declaration...
> >> >
> >> > <asp:DataGrid
> >> > id="myDataGrid"
> >> > runat="server"
> >> > AutoGenerateColumns="false"
> >> > OnItemCreated="myDataGrid_ItemCreated"
> >> > Style="width:100%;border:0px;background-color:transparent;"
> >> > cellspacing="0"
> >> > cellpadding="0"
> >> > BorderWidth="0px">
> >> >
> >> > It worked in MSIE 6 but it doesn't work for Firefox: black lines for
> >> > rows
> >> > and columns are drawn!! I've investigated the responsed HTML code and
> >> > below is what I've discovered...
> >> >
> >> > <table cellspacing="0" cellpadding="5" rules="all" border="0"
> >> > id="WebControl1_myDataGrid"
> >> > style="width:100%;border:0px;background-color:transparent;">
> >> >
> >> > So rules="all" is causing the FireFox to draw these lines.
> >> >
> >> > How do I disable it???
> >> >
> >> > David
> >> >
> >>
> >>
> >>

>
>
>


Nay Myo Aung 12-27-2004 05:27 AM

Re: DataGrid - BorderStyle="None" and BorderWidth="None" doesn't w
 
Hey guys,

As for me, I do not have the "proper solution" from the server side BUT
here's the CSS hack that will fix the problem...

Put "border-collapse: separate;" in the Style attribute of the DataGrid.

Don't ask me how, it just works :) (Hence, it is a hack). I hope we can find
the "proper" one later on.

--
Nay Myo Aung
Chief Visual Software Architect
MCP MCSD MCDBA

Email: owN0SPAMner @naymyoauN0SPAMng.name [remove NOSPAM s]
Homepages:
http://www.naymyoaung.name
http://hyperdisc.unitec.ac.nz/postgrad/aungn01/


"Patrick.O.Ige" <PatrickOIge@discussions.microsoft.com> wrote in message
news:974379DE-B471-41F8-AD81-0B22004D616D@microsoft.com...
> David..
> Did u find a solution for that?
>
>
>
> "David Freeman" wrote:
>
>> Hi Patrick!
>>
>> Thanks for the reply! Yea I don't know what I did wrong, before it was OK
>> on
>> Firefox AND MSIE. And Firefox suddenly starts showing these lines on the
>> grid. And when I inspected the HTML output code, I found that rules="all"
>> attribute.
>>
>> Anyway, I guess I might have to use client-side JavaScript to change the
>> rules attribute at client side. But I'm sure there should be a way to
>> turn
>> this off from server side. Hopefully I can find out.
>>
>> Wish me luck!
>> David
>>
>> "Patrick.O.Ige" <PatrickOIge@discussions.microsoft.com> wrote in message
>> news:274A0B2E-0AF1-46C6-813C-02622B6F0E17@microsoft.com...
>> > the problem i guess david is that Datagrid creates (grid) with HTML
>> > Is it possible to use another control apart from DAtagrid?
>> > Or maybe use javascript to check for the browsersfirst before rendering
>> > ur
>> > pages
>> >
>> >
>> >
>> > "David Freeman" wrote:
>> >
>> >> ....
>> >>
>> >> "David Freeman" <no-email@mailingspam.com> wrote in message
>> >> news:ev67eGexEHA.2996@TK2MSFTNGP10.phx.gbl...
>> >> > Hi There!
>> >> >
>> >> > I'm using ASP.NET 1.1 and VB.
>> >> >
>> >> > Below is my DataGrid declaration...
>> >> >
>> >> > <asp:DataGrid
>> >> > id="myDataGrid"
>> >> > runat="server"
>> >> > AutoGenerateColumns="false"
>> >> > OnItemCreated="myDataGrid_ItemCreated"
>> >> >
>> >> > Style="width:100%;border:0px;background-color:transparent;"
>> >> > cellspacing="0"
>> >> > cellpadding="0"
>> >> > BorderWidth="0px">
>> >> >
>> >> > It worked in MSIE 6 but it doesn't work for Firefox: black lines for
>> >> > rows
>> >> > and columns are drawn!! I've investigated the responsed HTML code
>> >> > and
>> >> > below is what I've discovered...
>> >> >
>> >> > <table cellspacing="0" cellpadding="5" rules="all" border="0"
>> >> > id="WebControl1_myDataGrid"
>> >> > style="width:100%;border:0px;background-color:transparent;">
>> >> >
>> >> > So rules="all" is causing the FireFox to draw these lines.
>> >> >
>> >> > How do I disable it???
>> >> >
>> >> > David
>> >> >
>> >>
>> >>
>> >>

>>
>>
>>





Tim 12-31-2007 07:32 PM

Gridlines
 
Set the gridlines property of the datagrid equal to none.

venkimit04 06-09-2010 09:24 AM

try in pageload function

DataGrid.attributes.add("Rules",None");

tcena9 02-16-2011 11:03 AM

just set a css class to the rowClasses or columnClasses attributes

and add .dataGridBorder { border:0px; } in the css file


All times are GMT. The time now is 04:33 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.