Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Perl Misc (http://www.velocityreviews.com/forums/f67-perl-misc.html)
-   -   Problems with proxy .. (http://www.velocityreviews.com/forums/t887634-problems-with-proxy.html)

Idan Jan 08-15-2004 07:50 PM

Problems with proxy ..
 
Hi all,
Hope you could help me with this problem.
I have the following code (please forgive the ugliness) :

== code start ==
$url = 'http://www.alexa.com/data/details/traffic_details?q=&url=cnn.com';

$ua = LWP::UserAgent->new;
$ua->proxy(http => $proxyserver);
$req = HTTP::Request->new(GET => $url);
$file = $ua->request($req)->as_string;

print "$file\n";
== code end ==

I get the following output:
=== output start ===
HTTP/1.0 202 Accepted
Date: Sun, 15 Aug 2004 19:20:54 GMT
Server:
Content-Length: 0
Content-Type: text/text
Client-Date: Sun, 15 Aug 2004 20:23:44 GMT
Client-Peer: 80.121.233.206:8000
Client-Response-Num: 1
Proxy-Connection: close
X-Cache: MISS from oxo.demo.com
=== output end ===

As you can see, I don't get the actual http data from the site, only
the above output. With other $urls this code works perfectly, but with
this alexa url, I only get the above output.

As far as I know, the HTTP 202 code isn't an Error code, so I really
can't tell what's the problem... ?


Would appriciate any help !

Idan

Idan Jan 08-17-2004 07:25 PM

Re: Problems with proxy ..
 
Thanks for your reply Jim.


All times are GMT. The time now is 10:52 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.