Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Perl Misc (http://www.velocityreviews.com/forums/f67-perl-misc.html)
-   -   GDBM_file install problems (perl 5.8.0, freebsd 4.8-stable) (http://www.velocityreviews.com/forums/t882876-gdbm_file-install-problems-perl-5-8-0-freebsd-4-8-stable.html)

Mike Hunter 10-01-2003 11:31 PM

GDBM_file install problems (perl 5.8.0, freebsd 4.8-stable)
 
Greetings,

A script I have needs GDBM_File. I tried getting it from cpan, but I was
thwarted:

% perl -MCPAN -e 'install GDBM_File'
CPAN: Storable loaded ok
Going to read /usr/cpan/Metadata
Database was generated on Wed, 01 Oct 2003 15:46:16 GMT
Running install for module GDBM_File
Running make for J/JH/JHI/perl-5.8.1.tar.gz

The most recent version "1.07" of the module "GDBM_File"
comes with the current version of perl (5.8.1).
I'll build that only if you ask for something like
force install GDBM_File
or
install J/JH/JHI/perl-5.8.1.tar.gz
Running make test
Make had some problems, maybe interrupted? Won't test
Has no own directory
Running make install
Has no own directory
Make had some problems, maybe interrupted? Won't install

I have cpan set to follow dependencies...when I do force install it proceeds
to try to upgrade perl to 5.8.1. I don't want to do that (I'm afraid because
perl is part of the base system in freebsd 4.8...or should I not be afraid
afterall?)

The script I'm trying to get to compile is quite old, so I can hardly believe
that perl needs to be upgraded to fix this problem. I tried sucking the
GDBM_file.pm into the @INC off of cpan.org, but it didn't like that, I think
because GDBM_file needs to me made with *make* to bind it to the actual GDBM
library from gnu.

Do I need to tell cpan to grab an older version? If so, how do I do that?

Any help appreciated,

Mike


All times are GMT. The time now is 05:57 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.