Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Ruby (http://www.velocityreviews.com/forums/f66-ruby.html)
-   -   Install from source on CentOS question (http://www.velocityreviews.com/forums/t862718-install-from-source-on-centos-question.html)

Cameron Smith 05-03-2010 12:13 AM

Install from source on CentOS question
 
I am attempting to install 1.9.1 from source on CentOS 5.4 and am
running into an issue.

after unpacking the archive and cd-ing into the ruby-1.9.1-p376 I run:
/configure --with-openssl-dir=/usr/lib/openssl

but the last line of the output shows:
config.status: creating Makefile
configure: WARNING: unrecognized options: --with-openssl-dir

What do I need to do to get the creation of the makefile to not throw
that warning?
--
Posted via http://www.ruby-forum.com/.


v4 forums 05-03-2010 03:14 AM

Re: Install from source on CentOS question
 
[Note: parts of this message were removed to make it a legal post.]

Hi Cameron,

I am new to Ruby and I came across this same problem when I was installing
ruby for the first time on my Ubuntu box. But after spending some time on
it, I found the following steps works without much of a problem for
installing ruby with openssl.

Ignore the --with-openssl-dir: I think the problem is to say with using
[dash][dash]with-openssl-dir instead of [dash][dash]
[dash][dash]with-openssl-dir. Google for the same and you will find the
reason

Instead, try this approach:

1. Install ruby with ./configure --prefix = /installation_path
2. Download openssl source and run ./config --perfix= /installation_path
Note: OpenSSL 1.0.X version doesn't seems to be working with ruby.
OpenSSL-0.9.8n worked for me. Also use the same $installation_path for both
'prefix' declarations. e.g., --prefix=/usr/local
3. Complete OpenSSL installation.
4. Go back to the ruby-1.8.6-pxxx/ext/openssl folder and run - ruby
extconf.rb, make, make install respectively.

Now I am sure, all the required packages for openssl can be identified by
ruby whenever required.

Hope this helps. I have also blogged about the same in the following
location. Feel free to check this out too.
http://theflashesofinsight.wordpress...openssl-issue/

With be glad to hear from the group if there are any better solutions.

Thanks

On Mon, May 3, 2010 at 5:43 AM, Cameron Smith <velvetpixel@gmail.com> wrote:

> I am attempting to install 1.9.1 from source on CentOS 5.4 and am
> running into an issue.
>
> after unpacking the archive and cd-ing into the ruby-1.9.1-p376 I run:
> ./configure --with-openssl-dir=/usr/lib/openssl
>
> but the last line of the output shows:
> config.status: creating Makefile
> configure: WARNING: unrecognized options: --with-openssl-dir
>
> What do I need to do to get the creation of the makefile to not throw
> that warning?
> --
> Posted via http://www.ruby-forum.com/.
>
>



Brian Candler 05-03-2010 07:49 AM

Re: Install from source on CentOS question
 
v4 forums wrote:
> With be glad to hear from the group if there are any better solutions.


There's no need to install openssl from source. Just install the
openssl-devel package before building ruby (yum install openssl-devel)
--
Posted via http://www.ruby-forum.com/.



All times are GMT. The time now is 11:18 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.