Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Ruby (http://www.velocityreviews.com/forums/f66-ruby.html)
-   -   irb Failing (http://www.velocityreviews.com/forums/t844224-irb-failing.html)

Ari Brown 09-19-2007 11:12 PM

irb Failing
 
Hey everyone
So let me begin my story...
I wanted to be awesome in my own mind, so I decided to learn to
program ruby. I installed ruby from source on my mac into /usr/local/
bin and everything went dandy. IRB, erb, rdoc, ri, the whole shebang #!!

Then I decided it was time for me to upgrade.
First, I tried installing ruby from darwinports.... No luck....
So then I tried installing it from scratch again, this time in /opt.
Ruby works, erb works, RDoc works, everything EXCEPT irb works.

Here is my error:

[Snow-iMac: ~] ari$ irb
dyld: NSLinkModule() error
dyld: Symbol not found: _rl_filename_completion_function
Referenced from: /opt/ruby-1.8.6/lib/ruby/1.8/powerpc-darwin8.10.0/
readline.bundle
Expected in: flat namespace

Trace/BPT trap

I feel like someone should've seen this error before! Turns out Ryan
Davis, one of my many Ruby gods, has. He had a method which felt sort
of hacked together. I haven't tried it yet, but before I do....

Does anyone have any advice on how to solve or fix this?

Ari
-------------------------------------------|
Nietzsche is my copilot





All times are GMT. The time now is 04:10 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.