Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP General (http://www.velocityreviews.com/forums/f65-asp-general.html)
-   -   Using IIS ASP to display a blob field in SQL Server 2005 (http://www.velocityreviews.com/forums/t805128-using-iis-asp-to-display-a-blob-field-in-sql-server-2005-a.html)

None@none.com 08-30-2010 07:08 AM

Using IIS ASP to display a blob field in SQL Server 2005
 
I'm using Windows 2000 Server IIS ASP and I'm attempting to display a
picture via an vbscript/ASP of a Blob image in SQL Server 2005. Below,
is part of the code (the important part) that I'm using after reading
up a bit. Unfortunately, I'm not getting the Blob image in one of our
Vendor's SQL database to pop up. Instead, I'm getting a box with a
red X in the middle of it

Any ideas?

SQL1 = "SELECT RD.ID, RD.image"
SQL1 = SQL1 & " WHERE RD.ID = '29'"
set rs = my_conn.Execute(SQL1)

<TR>
<TD bgcolor=<%=FieldColor%> align=center
colspan=1><B>ID</B></TD>
<TD bgcolor=<%=FieldColor%> align=center
colspan=1><B>Picture/B></TD>
</TR>
<%if rs.EOF then%>
<TR>
<TD bgcolor=<%=InfoField%> align=center
colspan=10><B>No definition found</B></TD>
</TR>
<%
else
do until rs.EOF%>
<TR>
<TD bgcolor=<%=InfoField%>
align=center><%=rs("ID")%>&nbsp;</TD>
<TD bgcolor=<%=InfoField%> align=center><img
src="<%=rs("image")%>">&nbsp;</TD>

Ziggs 08-30-2010 04:06 PM

Re: Using IIS ASP to display a blob field in SQL Server 2005
 
Small correction. I tried to make the code easier to work with to get
to the main point. I forgot to add the table in the select statement,
so here's the corrected statement. Any help is apprecieated.


SQL1 = "SELECT RD.ID, RD.image from RD"
"SQL1 = SQL1 & " WHERE RD.ID = '29'"

On Mon, 30 Aug 2010 00:08:58 -0700, None@none.com wrote:

>I'm using Windows 2000 Server IIS ASP and I'm attempting to display a
>picture via an vbscript/ASP of a Blob image in SQL Server 2005. Below,
>is part of the code (the important part) that I'm using after reading
>up a bit. Unfortunately, I'm not getting the Blob image in one of our
>Vendor's SQL database to pop up. Instead, I'm getting a box with a
>red X in the middle of it
>
>Any ideas?
>
>SQL1 = "SELECT RD.ID, RD.image"
>SQL1 = SQL1 & " WHERE RD.ID = '29'"
> set rs = my_conn.Execute(SQL1)
>
> <TR>
> <TD bgcolor=<%=FieldColor%> align=center
>colspan=1><B>ID</B></TD>
> <TD bgcolor=<%=FieldColor%> align=center
>colspan=1><B>Picture/B></TD>
> </TR>
><%if rs.EOF then%>
> <TR>
> <TD bgcolor=<%=InfoField%> align=center
>colspan=10><B>No definition found</B></TD>
> </TR>
> <%
> else
> do until rs.EOF%>
> <TR>
> <TD bgcolor=<%=InfoField%>
>align=center><%=rs("ID")%>&nbsp;</TD>
> <TD bgcolor=<%=InfoField%> align=center><img
>src="<%=rs("image")%>">&nbsp;</TD>


Neil Gould 08-31-2010 11:49 AM

Re: Using IIS ASP to display a blob field in SQL Server 2005
 
None@none.com wrote:
> I'm using Windows 2000 Server IIS ASP and I'm attempting to display a
> picture via an vbscript/ASP of a Blob image in SQL Server 2005. Below,
> is part of the code (the important part) that I'm using after reading
> up a bit. Unfortunately, I'm not getting the Blob image in one of our
> Vendor's SQL database to pop up. Instead, I'm getting a box with a
> red X in the middle of it
>
> Any ideas?
>
> SQL1 = "SELECT RD.ID, RD.image"
> SQL1 = SQL1 & " WHERE RD.ID = '29'"
> set rs = my_conn.Execute(SQL1)
>
> <TR>
> <TD bgcolor=<%=FieldColor%> align=center
> colspan=1><B>ID</B></TD>
> <TD bgcolor=<%=FieldColor%> align=center
> colspan=1><B>Picture/B></TD>
> </TR>
> <%if rs.EOF then%>
> <TR>
> <TD bgcolor=<%=InfoField%> align=center
> colspan=10><B>No definition found</B></TD>
> </TR>
> <%
> else
> do until rs.EOF%>
> <TR>
> <TD bgcolor=<%=InfoField%>
> align=center><%=rs("ID")%>&nbsp;</TD>
> <TD bgcolor=<%=InfoField%> align=center><img
> src="<%=rs("image")%>">&nbsp;</TD>
>

Since you haven't received a reply from those who know more than I, I'll
chime in with a couple of items...

Since you are using ...SQL1 & " WHERE RD.ID = '29'" ... I presume that RD.ID
is a text field? If not, it should probably be ...SQL1 & " WHERE RD.ID = 29"

If you are getting data from this query, but no pictures (as your post
implies), I would check the references in the database to verify that the
links are valid, and point to a location that is accessible from the script.

And, finally, there are some errors in your HTML, but that may be just the
way you copied it here and would probably not affect only the images.

--
Hope this helps,

Neil








Sylvain Lafontaine 09-01-2010 06:11 PM

Re: Using IIS ASP to display a blob field in SQL Server 2005
 
You cannot display an image from a Blob field in an ASP page this way;
however, you say that your code is working for other Vendor's SQL databases
and that it doesn't work for only one of them; so I'm very confuse.

My interpretation is that the field "image" is not a blob field but contains
the name of the file on the hard drive; so it's probably more a question of
a bad setup for the (virtual) repertory(ies) in IIS than a problem with the
SQL-Server or the ASP code.

--
Sylvain Lafontaine, ing.
MVP - Access
Blog/web site: http://coding-paparazzi.sylvainlafontaine.com
Independent consultant and remote programming for Access and SQL-Server
(French)


<None@none.com> wrote in message
news:j0mm76t3b2n46l649ttfsi9lhr4sqc6aes@4ax.com...
> I'm using Windows 2000 Server IIS ASP and I'm attempting to display a
> picture via an vbscript/ASP of a Blob image in SQL Server 2005. Below,
> is part of the code (the important part) that I'm using after reading
> up a bit. Unfortunately, I'm not getting the Blob image in one of our
> Vendor's SQL database to pop up. Instead, I'm getting a box with a
> red X in the middle of it
>
> Any ideas?
>
> SQL1 = "SELECT RD.ID, RD.image"
> SQL1 = SQL1 & " WHERE RD.ID = '29'"
> set rs = my_conn.Execute(SQL1)
>
> <TR>
> <TD bgcolor=<%=FieldColor%> align=center
> colspan=1><B>ID</B></TD>
> <TD bgcolor=<%=FieldColor%> align=center
> colspan=1><B>Picture/B></TD>
> </TR>
> <%if rs.EOF then%>
> <TR>
> <TD bgcolor=<%=InfoField%> align=center
> colspan=10><B>No definition found</B></TD>
> </TR>
> <%
> else
> do until rs.EOF%>
> <TR>
> <TD bgcolor=<%=InfoField%>
> align=center><%=rs("ID")%>&nbsp;</TD>
> <TD bgcolor=<%=InfoField%> align=center><img
> src="<%=rs("image")%>">&nbsp;</TD>




Bwig Zomberi 09-02-2010 04:51 AM

Re: Using IIS ASP to display a blob field in SQL Server 2005
 
None@none.com wrote:
> I'm using Windows 2000 Server IIS ASP and I'm attempting to display a
> picture via an vbscript/ASP of a Blob image in SQL Server 2005. Below,
> is part of the code (the important part) that I'm using after reading
> up a bit. Unfortunately, I'm not getting the Blob image in one of our
> Vendor's SQL database to pop up. Instead, I'm getting a box with a
> red X in the middle of it
>
> Any ideas?
>
> SQL1 = "SELECT RD.ID, RD.image"
> SQL1 = SQL1& " WHERE RD.ID = '29'"
> set rs = my_conn.Execute(SQL1)
>
> <TR>
> <TD bgcolor=<%=FieldColor%> align=center
> colspan=1><B>ID</B></TD>
> <TD bgcolor=<%=FieldColor%> align=center
> colspan=1><B>Picture/B></TD>
> </TR>
> <%if rs.EOF then%>
> <TR>
> <TD bgcolor=<%=InfoField%> align=center
> colspan=10><B>No definition found</B></TD>
> </TR>
> <%
> else
> do until rs.EOF%>
> <TR>
> <TD bgcolor=<%=InfoField%>
> align=center><%=rs("ID")%>&nbsp;</TD>
> <TD bgcolor=<%=InfoField%> align=center><img
> src="<%=rs("image")%>">&nbsp;</TD>



If the db contains a binary blob of the image, you can use it as the
address (src) of the image tag.

Use the URL of a separate ASP script in the SRC attribute. In that ASP
script, retrieve the blob from the database, set the content type
whatever mime type the image uses (jpeg, gif...), and
response.binarywrite the contents of the blob. This script should output
only binary content from the blob, it should not write an spaces or HTML
blocks.


Use logic similar to what is presented here
http://groups.google.com/group/micro...0136d1c3e28e0c

--
Bwig Zomberi


All times are GMT. The time now is 09:12 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.