Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP General (http://www.velocityreviews.com/forums/f65-asp-general.html)
-   -   Include path of ASP stop working in Windows 2003 (http://www.velocityreviews.com/forums/t794890-include-path-of-asp-stop-working-in-windows-2003-a.html)

Charts 06-09-2004 10:01 PM

Include path of ASP stop working in Windows 2003
 
I recently upgraded development web server to Windows 2003. I have ASP file contains following line for include file
<!--#include File="../Include/adovbs.inc"--

This ASP file worked fine before. When I ran this file under Windows 2003, I got following error message
The include file “Include/adovbs.inc” cannot contain ‘…’ to indicate the parent directory.

I changed to following lin
<!--#include File="my virtual directory/Include/adovbs.inc"--

Then, IE tells me the file could not be found

If I copy the include file to the current directory and just use
<!--#include File="adovbs.inc"-->
That works

Is there way I can change IIS setting to make my include path work” It really break my existing applications. Thanks


Alan Howard 06-09-2004 10:26 PM

Re: Include path of ASP stop working in Windows 2003
 
Try enabling parent paths - right click the site representing your app in
IIS, select properties, select the Home Directory/Virtual Dir tab, click the
Configuration button, select the App Options tab and select the Enable
Parent Paths box. These instructions are for 2000 so adjust as necessary for
2003 - pretty similar though.

Alan

"Charts" <Wcharts@newsgroups.nospam> wrote in message
news:2A86B4A0-6CBC-49E9-ACBB-546314118FCD@microsoft.com...
> I recently upgraded development web server to Windows 2003. I have ASP

file contains following line for include file.
> <!--#include File="../Include/adovbs.inc"-->
>
> This ASP file worked fine before. When I ran this file under Windows

2003, I got following error message.
> The include file "Include/adovbs.inc" cannot contain '.' to indicate the

parent directory.
>
> I changed to following line
> <!--#include File="my virtual directory/Include/adovbs.inc"-->
>
> Then, IE tells me the file could not be found.
>
> If I copy the include file to the current directory and just use
> <!--#include File="adovbs.inc"-->
> That works.
>
> Is there way I can change IIS setting to make my include path work" It

really break my existing applications. Thanks.
>




Charts 06-10-2004 10:21 PM

Re: Include path of ASP stop working in Windows 2003
 
That works!! Thanks so much!

"Alan Howard" wrote:

> Try enabling parent paths - right click the site representing your app in
> IIS, select properties, select the Home Directory/Virtual Dir tab, click the
> Configuration button, select the App Options tab and select the Enable
> Parent Paths box. These instructions are for 2000 so adjust as necessary for
> 2003 - pretty similar though.
>
> Alan
>
> "Charts" <Wcharts@newsgroups.nospam> wrote in message
> news:2A86B4A0-6CBC-49E9-ACBB-546314118FCD@microsoft.com...
> > I recently upgraded development web server to Windows 2003. I have ASP

> file contains following line for include file.
> > <!--#include File="../Include/adovbs.inc"-->
> >
> > This ASP file worked fine before. When I ran this file under Windows

> 2003, I got following error message.
> > The include file "Include/adovbs.inc" cannot contain '.' to indicate the

> parent directory.
> >
> > I changed to following line
> > <!--#include File="my virtual directory/Include/adovbs.inc"-->
> >
> > Then, IE tells me the file could not be found.
> >
> > If I copy the include file to the current directory and just use
> > <!--#include File="adovbs.inc"-->
> > That works.
> >
> > Is there way I can change IIS setting to make my include path work" It

> really break my existing applications. Thanks.
> >

>
>
>


Charts 06-10-2004 10:22 PM

Re: Include path of ASP stop working in Windows 2003
 
That works!! Thanks so much!!

"Alan Howard" wrote:

> Try enabling parent paths - right click the site representing your app in
> IIS, select properties, select the Home Directory/Virtual Dir tab, click the
> Configuration button, select the App Options tab and select the Enable
> Parent Paths box. These instructions are for 2000 so adjust as necessary for
> 2003 - pretty similar though.
>
> Alan
>
> "Charts" <Wcharts@newsgroups.nospam> wrote in message
> news:2A86B4A0-6CBC-49E9-ACBB-546314118FCD@microsoft.com...
> > I recently upgraded development web server to Windows 2003. I have ASP

> file contains following line for include file.
> > <!--#include File="../Include/adovbs.inc"-->
> >
> > This ASP file worked fine before. When I ran this file under Windows

> 2003, I got following error message.
> > The include file "Include/adovbs.inc" cannot contain '.' to indicate the

> parent directory.
> >
> > I changed to following line
> > <!--#include File="my virtual directory/Include/adovbs.inc"-->
> >
> > Then, IE tells me the file could not be found.
> >
> > If I copy the include file to the current directory and just use
> > <!--#include File="adovbs.inc"-->
> > That works.
> >
> > Is there way I can change IIS setting to make my include path work" It

> really break my existing applications. Thanks.
> >

>
>
>



All times are GMT. The time now is 11:14 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.