Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net (http://www.velocityreviews.com/forums/f29-asp-net.html)
-   -   Impersonation between different workgroups is failed (http://www.velocityreviews.com/forums/t79439-impersonation-between-different-workgroups-is-failed.html)

=?Utf-8?B?bC10b3VjaGVk?= 06-01-2004 12:41 AM

Impersonation between different workgroups is failed
 
Hello,

I have 2 servers disposed in following manner

..- One IIS server (Named IIS-Svr), with a firewall for the Internet output (this server has his own valid IP for Internet), isolated in a Workgroup
(Win2003 Web Server, .NET Framework 1.1, IIS 6.0, ASPX pages, COM+ Applications proxies)

..- One COM+ server (Named COM-Svr), isolated in a Workgroup
(Win2000 Advanced Server, .NET Framework 1.0, COM+ Applications)

ISS server is isolated in a workgroup named WG-ISS, I have a user named UsuarioIIS in this machine, COM+ Server is isolated in another workgroup named WG-COM, I have a user named UsuarioCOM in this machine

Both of them are in the same network segment, they can connecting between themselves, although they are in differents Workgroup

Internet <-> Firewall <-> ISS <-> COM

Ok, like you can appreciate, I am programming in “n” tiers model, I have my bussines rules in COM+ server and my front end code in ASPX pages

Ok, actually, in developing environment I have both servers in the same Domain, the inpersonation is working very well

::Web.config:
<configuration><system.web><identit
impersonate="true
userName="Domain\UserName
password=" Password
/ ></system.web></configuration

But, when I going to production environment explode a fail because both of them not are in the same domain, are in differents Workgroups

Remember

Internet <-> Firewall <-> ISS (Named IIS-Svr in WG-ISS ) <-> COM+ (Named COM-Svr, in WG-COM

In my web application configuration (In IIS Server), I Tried this

::Web.config:
<configuration><system.web><identit
impersonate="true
userName="COM-Svr\UsuarioCOM"  NameMachine\Use
password="Password
/ ></system.web></configuration

But the following error appear

Server Error in '/WebApp' Application
----------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not create Windows user token from the credentials specified in the config file. Error from the operating system 'Logon failure: unknown user name or bad password.

Source Error:

Line 106:
Line 107:
Line 108: <identity impersonate="true"
Line 109: userName="COM-Svr\UsuarioCOM"
Line 110: password="Password"

Source File: c:\inetpub\wwwroot\WebApp\web.config Line: 108

----------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.57

Could someone help me please

I don’t know if I have to change special something in some of severs, or add something to my Config Web application files, or using another method for getting the same result

Perphaps this problem has a easy solution, but I haven´t any idea. Maybe using delegate and not inpersonation is better... I don'nt know..

Thanks in advance

l-touched


All times are GMT. The time now is 08:16 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.