Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP General (http://www.velocityreviews.com/forums/f65-asp-general.html)
-   -   String getting chopped off (http://www.velocityreviews.com/forums/t789608-string-getting-chopped-off.html)

Bill 08-20-2003 11:35 PM

String getting chopped off
 
I am passing a string of text between a page and a database. It is a
book title, which consists of 2 or three words, and only the first
word is passing to the database. The page that passes the string has
the whole string on it, but somewhere between the passing and the
receiving, the string is getting chopped off at the first word.

Here is the text that's passing the string:
response.write "<input type=hidden name=title" & " value=" &
rs("title") & ">"

and here is the code that is receiving it:
title=request.form("title")

I've tried adding various ' here and there, but it only causes the
pages to crash. Can someone please show me where I'm going wrong? I
know it has something to do with having quotes or ' somewhere, but I
can't quite understand where.

Thank you!

Bill

Curt_C [MVP] 08-20-2003 11:38 PM

Re: String getting chopped off
 
.....value='" & rs(..) & "'....

Put single quotes around the Value=''


--
----------------------------------------------------------
Curt Christianson (Software_AT_Darkfalz.Com)
Owner/Lead Designer, DF-Software
http://www.Darkfalz.com
---------------------------------------------------------
...Offering free scripts & code snippits for everyone...
---------------------------------------------------------


"Bill" <billzimmerman@gospellight.com> wrote in message
news:8da5f4f4.0308201535.5c497cfe@posting.google.c om...
> I am passing a string of text between a page and a database. It is a
> book title, which consists of 2 or three words, and only the first
> word is passing to the database. The page that passes the string has
> the whole string on it, but somewhere between the passing and the
> receiving, the string is getting chopped off at the first word.
>
> Here is the text that's passing the string:
> response.write "<input type=hidden name=title" & " value=" &
> rs("title") & ">"
>
> and here is the code that is receiving it:
> title=request.form("title")
>
> I've tried adding various ' here and there, but it only causes the
> pages to crash. Can someone please show me where I'm going wrong? I
> know it has something to do with having quotes or ' somewhere, but I
> can't quite understand where.
>
> Thank you!
>
> Bill





All times are GMT. The time now is 12:19 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.