Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net Web Services (http://www.velocityreviews.com/forums/f64-asp-net-web-services.html)
-   -   WSE 3.0 Kerberos Security problem (http://www.velocityreviews.com/forums/t786765-wse-3-0-kerberos-security-problem.html)

iidelchik@yahoo.com 12-01-2006 05:33 AM

WSE 3.0 Kerberos Security problem
 
Hi All,

Windows service application calls web service using Kerberos security
policy. Win service, running under user, which is administrator for Web
server, does not have any problem.
But if I try to run the win service as plain web server user it runs ok
as long as I wish until web.config is changed. After then I start
getting messages like
"Server was unable to process request. ---> The type initializer for
'Microsoft.Practices.EnterpriseLibrary.ExceptionHa ndling.ExceptionPolicy'
threw an exception. ---> Could not load file or assembly
'Microsoft.Practices.EnterpriseLibrary.Common, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=null' or one of its dependencies.
Access is denied."
It does not happen for admin user or plain user with kerberos switched
off.

I can reproduce the same problem even if I stop IIS (6.0 on Server
2003) and client win service and change web.config after that.

It all looks very weirde for me. Can anybody help?

Cheers,
Elijah



All times are GMT. The time now is 08:31 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.