Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net Web Services (http://www.velocityreviews.com/forums/f64-asp-net-web-services.html)
-   -   Can't diagnose time-out errors (http://www.velocityreviews.com/forums/t785612-cant-diagnose-time-out-errors.html)

Brad Wood 12-02-2005 07:07 PM

Can't diagnose time-out errors
 
<environment>
Consuming a web service from a VS2005 beta 2 test harness on WinXP. Web
service built with VS2003 running on my machine with IIS 5X set to use
ASP.NET 1.1
</environment>

I have a web service wherein I make http calls out using the
HttpWebResponse.GetResponse method. This works fine when making these
calls normally (no threading).

I created a winforms test app and tested using the same code to make
http calls in multiple threads and tested numerous threads (50 threads
would consistently work fine).

When I incorporate that same thread code back into my web service, I get
error "System.Net.WebException: The operation has timed out."

I've:
- Ensured I'm closing all necessary objects in my http code.
- Tried making adjustments to the httpRuntime config element.
- Increased the maxconnection amount in the connectionManagement config
element.
- Set the Timeout property of my HttpWebResponse object to Timeout.Infinite.
- Set the KeepAlive property of my HttpWebResponse object to false.

I'm hoping someone can suggest something else to look at...

Brad Wood 12-02-2005 07:21 PM

Re: Can't diagnose time-out errors
 
Sorry, should have checked this before even researching and posting:
all of the HttpWebResponse.GetResponse calls are returning fine in my
web service - it's just that my test app back in VS2005 times out first.
So it seems to be an issue unrelated to my web service...?

Brad Wood wrote:
> <environment>
> Consuming a web service from a VS2005 beta 2 test harness on WinXP. Web
> service built with VS2003 running on my machine with IIS 5X set to use
> ASP.NET 1.1
> </environment>
>
> I have a web service wherein I make http calls out using the
> HttpWebResponse.GetResponse method. This works fine when making these
> calls normally (no threading).
>
> I created a winforms test app and tested using the same code to make
> http calls in multiple threads and tested numerous threads (50 threads
> would consistently work fine).
>
> When I incorporate that same thread code back into my web service, I get
> error "System.Net.WebException: The operation has timed out."
>
> I've:
> - Ensured I'm closing all necessary objects in my http code.
> - Tried making adjustments to the httpRuntime config element.
> - Increased the maxconnection amount in the connectionManagement config
> element.
> - Set the Timeout property of my HttpWebResponse object to
> Timeout.Infinite.
> - Set the KeepAlive property of my HttpWebResponse object to false.
>
> I'm hoping someone can suggest something else to look at...


Brad Wood 12-02-2005 08:57 PM

Re: Can't diagnose time-out errors
 
Sorry, I shouldn't have posted; it's merely a matter of changing the
Timeout property on the auto-generated web service proxy object used by
my test code.

Brad Wood wrote:
> Sorry, should have checked this before even researching and posting: all
> of the HttpWebResponse.GetResponse calls are returning fine in my web
> service - it's just that my test app back in VS2005 times out first.
> So it seems to be an issue unrelated to my web service...?



All times are GMT. The time now is 03:42 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.