Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net Web Services (http://www.velocityreviews.com/forums/f64-asp-net-web-services.html)
-   -   Forbidden Deployment? (http://www.velocityreviews.com/forums/t783066-forbidden-deployment.html)

Russ 05-06-2004 12:50 PM

Forbidden Deployment?
 
Hello. I have built a web service and C# client to access, which work
correctly when the client is launched from visual studio.

Now I tried to deploy the client using the information in the article:

> Walkthrough: Deploying a Web Solution


First, that article is very confusing because of incorrect and out of
order instructions. It needs to be revised. I can supply details if
desired.

But I eventually get the deployment project built ok, and deploy the
client on my local machine. Now when I try to access the client from
IE, using "http://localhost/xyz", as per the tutorial, I get the "HTTP
Error 403 - Forbidden" error.

I think this is a permissions problem, but as I am new to just about
every aspect of this, I have no clue what permission is lacking, or
how to fix. I did go into IIS on the server and set access for the
web service to anonamous (as well as integrated) but that did not
help. IIS is not installed on my local machine so I cannot do the
same for the client. (The WebService is built on the server and the
client is built on the localhost.)

I also tried to deploy the client on the server and it did deploy, but
when I try to access the client with IE either from my local machine
or on the server directly, I get the same 403 error.

What is the problem?

Thank you, Russ


Manuj Aggarwal 05-07-2004 12:01 AM

Re: Forbidden Deployment?
 
When you deploy a web service project - there is no default page configured
by default. Try to access the asmx file explicitly like this:

http://localhost/xyz/abc.asmx

Alternatively, try setting your asmx file as the default page for your
virtual folder.

Manuj Aggarwal



"Russ" <russk2@eticomm.net> wrote in message
news:fgck909son1987j33s23h1t3u5nund7ems@4ax.com...
> Hello. I have built a web service and C# client to access, which work
> correctly when the client is launched from visual studio.
>
> Now I tried to deploy the client using the information in the article:
>
> > Walkthrough: Deploying a Web Solution

>
> First, that article is very confusing because of incorrect and out of
> order instructions. It needs to be revised. I can supply details if
> desired.
>
> But I eventually get the deployment project built ok, and deploy the
> client on my local machine. Now when I try to access the client from
> IE, using "http://localhost/xyz", as per the tutorial, I get the "HTTP
> Error 403 - Forbidden" error.
>
> I think this is a permissions problem, but as I am new to just about
> every aspect of this, I have no clue what permission is lacking, or
> how to fix. I did go into IIS on the server and set access for the
> web service to anonamous (as well as integrated) but that did not
> help. IIS is not installed on my local machine so I cannot do the
> same for the client. (The WebService is built on the server and the
> client is built on the localhost.)
>
> I also tried to deploy the client on the server and it did deploy, but
> when I try to access the client with IE either from my local machine
> or on the server directly, I get the same 403 error.
>
> What is the problem?
>
> Thank you, Russ
>




Russ 05-07-2004 01:17 AM

Re: Forbidden Deployment?
 
Thank you Mamuj. That works. Now why does the Walkthrough tell me to
access the page as if it had a default page after deploying? It seems
like bad information...

Thanks again, Russ

On Thu, 6 May 2004 17:01:36 -0700, "Manuj Aggarwal"
<manuj@espiderinc.com> wrote:

>When you deploy a web service project - there is no default page configured
>by default. Try to access the asmx file explicitly like this:
>
>http://localhost/xyz/abc.asmx
>
>Alternatively, try setting your asmx file as the default page for your
>virtual folder.
>
>Manuj Aggarwal
>
>
>
>"Russ" <russk2@eticomm.net> wrote in message
>news:fgck909son1987j33s23h1t3u5nund7ems@4ax.com.. .
>> Hello. I have built a web service and C# client to access, which work
>> correctly when the client is launched from visual studio.
>>
>> Now I tried to deploy the client using the information in the article:
>>
>> > Walkthrough: Deploying a Web Solution

>>
>> First, that article is very confusing because of incorrect and out of
>> order instructions. It needs to be revised. I can supply details if
>> desired.
>>
>> But I eventually get the deployment project built ok, and deploy the
>> client on my local machine. Now when I try to access the client from
>> IE, using "http://localhost/xyz", as per the tutorial, I get the "HTTP
>> Error 403 - Forbidden" error.
>>
>> I think this is a permissions problem, but as I am new to just about
>> every aspect of this, I have no clue what permission is lacking, or
>> how to fix. I did go into IIS on the server and set access for the
>> web service to anonamous (as well as integrated) but that did not
>> help. IIS is not installed on my local machine so I cannot do the
>> same for the client. (The WebService is built on the server and the
>> client is built on the localhost.)
>>
>> I also tried to deploy the client on the server and it did deploy, but
>> when I try to access the client with IE either from my local machine
>> or on the server directly, I get the same 403 error.
>>
>> What is the problem?
>>
>> Thank you, Russ
>>

>




All times are GMT. The time now is 06:30 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.