Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net Web Controls (http://www.velocityreviews.com/forums/f63-asp-net-web-controls.html)
-   -   problem with ReportViewer.LocalReport.LoadReportDefinition() method (http://www.velocityreviews.com/forums/t779996-problem-with-reportviewer-localreport-loadreportdefinition-method.html)

rave 06-28-2007 03:33 PM

problem with ReportViewer.LocalReport.LoadReportDefinition() method
 
Hi ,

i have used a techinque, in my case on the button click i have to
generate a report definition and load it using
LocalReport.LoadReportDefinition method.
for the first time it is giving the report correctly, it is giving
the same report even if the report definition changes (some of the
columns were removed)

i am stuckup with this, please help me.

code goes like this

rpvPrint.LocalReport.DataSources.Clear();

rpvPrint.LocalReport.Dispose();


StringReader sr = new StringReader(xd.OuterXml);

rpvPrint.LocalReport.LoadReportDefinition(sr);

sr.Close();

ReportParameter[] rp = new ReportParameter[1];

rp[0] = new ReportParameter("Heading", "Hi ---This Is Test Heading");

rpvPrint.LocalReport.SetParameters(rp);



ReportDataSource rds = new ReportDataSource("DataSet2", dt);

rpvPrint.LocalReport.DataSources.Add(rds);

rpvPrint.LocalReport.Refresh();



thanks in advance



All times are GMT. The time now is 01:33 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.