Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net Web Controls (http://www.velocityreviews.com/forums/f63-asp-net-web-controls.html)
-   -   Templated control not rendering Web User Controls (http://www.velocityreviews.com/forums/t777803-templated-control-not-rendering-web-user-controls.html)

Allan Ebdrup 03-27-2006 11:45 AM

Templated control not rendering Web User Controls
 
I have a templated control, it works fine at runtime, but at designtime I
can't see the web user controls used in the template. I have this template
in my control:
---
<Wizard>test
<uc1:TelephoneNumber ID="TelephoneNumber1" runat="server" />
</Wizard>
---
But in the design view only the "test" text appears, at runtime the web user
control is rendered fine.
How do I get the designtime to render the web user control?

Kind Regards,
Allan Ebdrup



Phillip Williams 03-27-2006 03:00 PM

RE: Templated control not rendering Web User Controls
 
http://msdn.microsoft.com/library/de...imeSupport.asp
--
HTH,
Phillip Williams
http://www.societopia.net
http://www.webswapp.com


"Allan Ebdrup" wrote:

> I have a templated control, it works fine at runtime, but at designtime I
> can't see the web user controls used in the template. I have this template
> in my control:
> ---
> <Wizard>test
> <uc1:TelephoneNumber ID="TelephoneNumber1" runat="server" />
> </Wizard>
> ---
> But in the design view only the "test" text appears, at runtime the web user
> control is rendered fine.
> How do I get the designtime to render the web user control?
>
> Kind Regards,
> Allan Ebdrup
>
>
>


Steven Cheng[MSFT] 03-28-2006 05:22 AM

RE: Templated control not rendering Web User Controls
 
Hi Allan,

I've performed some tests according to the custom template control you
mentioned. Yes, I did reproduce the problem behavior you encountered. I
think it is possibly caused by some additional required implementation we
didn't add, I'm currently doing some further research on this and will
update you as soon as I get any new update. In the mean time, if there is
any new finding on your side, also welcome to post here.

Regards,

Steven Cheng
Microsoft Online Community Support


==================================================

When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.

==================================================


This posting is provided "AS IS" with no warranties, and confers no rights.





Allan Ebdrup 03-28-2006 08:35 AM

Re: Templated control not rendering Web User Controls
 
"Steven Cheng[MSFT]" <stcheng@online.microsoft.com> wrote in message
news:2p10neiUGHA.3608@TK2MSFTNGXA01.phx.gbl...
> Hi Allan,
>
> I've performed some tests according to the custom template control you
> mentioned. Yes, I did reproduce the problem behavior you encountered. I
> think it is possibly caused by some additional required implementation we
> didn't add, I'm currently doing some further research on this and will
> update you as soon as I get any new update. In the mean time, if there is
> any new finding on your side, also welcome to post here.


I'm looking forward to hearing what you find. I've noticed that if you
enable template editing the web user control is displayed correctly when
editing the template. Also if the control is a CompositeControl child web
user controls are rendered correctly in design time.

Kind Regards,
Allan Ebdrup



Steven Cheng[MSFT] 03-30-2006 09:41 AM

Re: Templated control not rendering Web User Controls
 
Hi Allan,

Sorry for keep you waiting. After some further research, I found that for
normal view in design-time, it is the fixed behavior that usercontrol'
won't display. This is the same for those template in FormView and
GridView.... And only in EditMode or those editable template will those
usercontrol be displayed as runtime style. I'm afraid currently it is
limited. However, you can submit this as a request to the MSDN product
feedback center so that the dev teams can get feedback on this:

http://lab.msdn.microsoft.com/produc...k/default.aspx

Regards,

Steven Cheng
Microsoft Online Community Support


==================================================

When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.

==================================================


This posting is provided "AS IS" with no warranties, and confers no rights.



Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)




All times are GMT. The time now is 10:12 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.