Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net Security (http://www.velocityreviews.com/forums/f62-asp-net-security.html)
-   -   Using Windows Integrated Authentication to access Active Directory (http://www.velocityreviews.com/forums/t766910-using-windows-integrated-authentication-to-access-active-directory.html)

K SK 12-06-2004 06:19 PM

Using Windows Integrated Authentication to access Active Directory
 
Hi,
I have disabled "Anonymous Access" & enabled "Integrated Windows
Authentication" on the web server for my ASP.NET application. My
Web.config file has the following entries:

<authentication mode="Windows" />
<identity impersonate="true"/>

Now when I run the application from within Visual Studio.NET, the
application successfully runs after determining the windows user in the
code using "User.Identity.Name" & I am able to access the active
DirectoryEntry for that User.

However, when I navigate to this new aspx page from an existing ASP
page, I am prompted to login to the domain again.

Any help will be greatly appreciated!!! Is urgent for me to solve this
problem.

Thanks



*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!

Daniel Fisher\(lennybacon\) 12-10-2004 04:34 PM

Re: Using Windows Integrated Authentication to access Active Directory
 
Have you turned on Digest Authentication in the IIS properties?

--
Daniel Fisher(lennybacon)
MCP ASP.NET C#
Blog: http://www.lennybacon.com/


"K SK" <metridevkk@hotmail.com> wrote in message
news:e$VCjA82EHA.1564@TK2MSFTNGP09.phx.gbl...
> Hi,
> I have disabled "Anonymous Access" & enabled "Integrated Windows
> Authentication" on the web server for my ASP.NET application. My
> Web.config file has the following entries:
>
> <authentication mode="Windows" />
> <identity impersonate="true"/>
>
> Now when I run the application from within Visual Studio.NET, the
> application successfully runs after determining the windows user in the
> code using "User.Identity.Name" & I am able to access the active
> DirectoryEntry for that User.
>
> However, when I navigate to this new aspx page from an existing ASP
> page, I am prompted to login to the domain again.
>
> Any help will be greatly appreciated!!! Is urgent for me to solve this
> problem.
>
> Thanks
>
>
>
> *** Sent via Developersdex http://www.developersdex.com ***
> Don't just participate in USENET...get rewarded for it!





All times are GMT. The time now is 04:37 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.