Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net Security (http://www.velocityreviews.com/forums/f62-asp-net-security.html)
-   -   asp.net remote [hosted] configuration usse (http://www.velocityreviews.com/forums/t764951-asp-net-remote-hosted-configuration-usse.html)

Toby Considine 08-31-2003 07:53 PM

asp.net remote [hosted] configuration usse
 
I often have a need for a hosted sub-app, for example, adding a secure
dotnet area in a publicly hosted site, a migration to an ASPX area inside of
an existing ASP site. This sub-app may rely on its own security setting
(which are application wide.)

I have talked to the hosting support. THey say "You can create that in
Front Page"

ok

I have installed Frontpage XP to get back just the admin functions.
I have created a sub-directory and then defined a sub-web (using FP Web
Admin) on these 2003-based servers. So far so good.

Now I consistently (on several sites, with two different providers get a
message similar to:

Parser Error Message: It is an error to use a section registered as
allowDefinition='MachineToApplication' beyond application level. This error
can be caused by a virtual directory not being configured as an application
in IIS.

So how do I remotely configure this function. No problem if I own the
server, and I havve IIS Admin close to hand, but how do I do this remotely?

thanks

tc




Lewis Wang [MSFT] 09-01-2003 02:52 PM

RE: asp.net remote [hosted] configuration usse
 
Hi Toby,

You may try one of the two methods to configure the virtual directory as an
application in IIS.

1. The FrontPage Server Extensions Access Method

a. Create an account on the remote Web Server. Add this account to the VS
Developers group. This permits you to create applications on the Web
server. If you want to debug your applications by using Visual Studio .NET,
you must also add this account to the Administrators group on the server.
b. On the local computer, create a duplicate of the account that you
created in step 1 by using the same user name and password. Verify that
this account is listed as a local Administrator. Use this account to log on
to the local computer when you develop applications against the remote Web
server.

2. Connect to the remote web server using your IIS and create an
application on IIS.

a. Open Internet Services Manager. Or, if you run Microsoft Windows XP on
your computer, open Internet Information Services.
b. In the left pane, right-click on the root node and select "connect" on
the pop up menu. Input the remote computer name(Or IP address) and
account(Administrator account on the remote server).
c. Right-click the name of your virtual directory, and then click
Properties.
d. Make sure that the Web site name or the virtual directory name is listed
in the Application Name box under Application Settings. If it is not
listed, click Create.

Hope this helps.

Best regards,
Lewis

This posting is provided "AS IS" with no warranties, and confers no rights.



--------------------
| From: "Toby Considine" <tobias@fac.unc.edu>
| Subject: asp.net remote [hosted] configuration usse
| Date: Sun, 31 Aug 2003 15:53:02 -0400
| Lines: 31
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| Message-ID: <#IGI#l$bDHA.3044@TK2MSFTNGP11.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet.security
| NNTP-Posting-Host: adsl-18-21-78.rdu.bellsouth.net 68.18.21.78
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| Xref: cpmsftngxa06.phx.gbl
microsoft.public.dotnet.framework.aspnet.security: 6476
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.security
|
| I often have a need for a hosted sub-app, for example, adding a secure
| dotnet area in a publicly hosted site, a migration to an ASPX area inside
of
| an existing ASP site. This sub-app may rely on its own security setting
| (which are application wide.)
|
| I have talked to the hosting support. THey say "You can create that in
| Front Page"
|
| ok
|
| I have installed Frontpage XP to get back just the admin functions.
| I have created a sub-directory and then defined a sub-web (using FP Web
| Admin) on these 2003-based servers. So far so good.
|
| Now I consistently (on several sites, with two different providers get a
| message similar to:
|
| Parser Error Message: It is an error to use a section registered as
| allowDefinition='MachineToApplication' beyond application level. This
error
| can be caused by a virtual directory not being configured as an
application
| in IIS.
|
| So how do I remotely configure this function. No problem if I own the
| server, and I havve IIS Admin close to hand, but how do I do this
remotely?
|
| thanks
|
| tc
|
|
|
|


Toby Considine 09-01-2003 04:01 PM

Re: asp.net remote [hosted] configuration usse
 
Both these solutiuons work well with, say a dedicated hosted machine, or one
in which I am actualy the admin. Neither works in the usual small-medium
site hosted scenario in which my site is one of a dozen (or many more - hard
to know) sites hosted on a single rmeote 2003 server. The hoster is not
going to give me access to any tools that will take down someone else's
site. That includes machine admin rights.

The scenario again is that I have a hosted site with an account that is able
to manipulate the that one site, one of many on a remote PC running Win2k3.
FP lets me creat a sub-site. but not, as far as I can tell, set the
application for that remote site.

This means (1) is flat out. (2) I had not tried, but also does not work.

I need a way to access Remote PCs within the context that a hoster is
willing to provide to a single developer.





"Lewis Wang [MSFT]" <v-lwang@online.microsoft.com> wrote in message
news:8lKCyiJcDHA.1928@cpmsftngxa06.phx.gbl...
> Hi Toby,
>
> You may try one of the two methods to configure the virtual directory as

an
> application in IIS.
>
> 1. The FrontPage Server Extensions Access Method
>
> a. Create an account on the remote Web Server. Add this account to the VS
> Developers group. This permits you to create applications on the Web
> server. If you want to debug your applications by using Visual Studio

..NET,
> you must also add this account to the Administrators group on the server.
> b. On the local computer, create a duplicate of the account that you
> created in step 1 by using the same user name and password. Verify that
> this account is listed as a local Administrator. Use this account to log

on
> to the local computer when you develop applications against the remote Web
> server.
>
> 2. Connect to the remote web server using your IIS and create an
> application on IIS.
>
> a. Open Internet Services Manager. Or, if you run Microsoft Windows XP on
> your computer, open Internet Information Services.
> b. In the left pane, right-click on the root node and select "connect" on
> the pop up menu. Input the remote computer name(Or IP address) and
> account(Administrator account on the remote server).
> c. Right-click the name of your virtual directory, and then click
> Properties.
> d. Make sure that the Web site name or the virtual directory name is

listed
> in the Application Name box under Application Settings. If it is not
> listed, click Create.
>
> Hope this helps.
>
> Best regards,
> Lewis
>
> This posting is provided "AS IS" with no warranties, and confers no

rights.
>
>
>
> --------------------
> | From: "Toby Considine" <tobias@fac.unc.edu>
> | Subject: asp.net remote [hosted] configuration usse
> | Date: Sun, 31 Aug 2003 15:53:02 -0400
> | Lines: 31
> | X-Priority: 3
> | X-MSMail-Priority: Normal
> | X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
> | X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
> | Message-ID: <#IGI#l$bDHA.3044@TK2MSFTNGP11.phx.gbl>
> | Newsgroups: microsoft.public.dotnet.framework.aspnet.security
> | NNTP-Posting-Host: adsl-18-21-78.rdu.bellsouth.net 68.18.21.78
> | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
> | Xref: cpmsftngxa06.phx.gbl
> microsoft.public.dotnet.framework.aspnet.security: 6476
> | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.security
> |
> | I often have a need for a hosted sub-app, for example, adding a secure
> | dotnet area in a publicly hosted site, a migration to an ASPX area

inside
> of
> | an existing ASP site. This sub-app may rely on its own security setting
> | (which are application wide.)
> |
> | I have talked to the hosting support. THey say "You can create that in
> | Front Page"
> |
> | ok
> |
> | I have installed Frontpage XP to get back just the admin functions.
> | I have created a sub-directory and then defined a sub-web (using FP Web
> | Admin) on these 2003-based servers. So far so good.
> |
> | Now I consistently (on several sites, with two different providers get a
> | message similar to:
> |
> | Parser Error Message: It is an error to use a section registered as
> | allowDefinition='MachineToApplication' beyond application level. This
> error
> | can be caused by a virtual directory not being configured as an
> application
> | in IIS.
> |
> | So how do I remotely configure this function. No problem if I own the
> | server, and I havve IIS Admin close to hand, but how do I do this
> remotely?
> |
> | thanks
> |
> | tc
> |
> |
> |
> |
>




Lewis Wang [MSFT] 09-04-2003 01:36 AM

Re: asp.net remote [hosted] configuration usse
 
Hi Toby,

The ISP's server must be configured properly in order to be able to create
projects remotely using VS.NET. For more info check:
http://msdn.microsoft.com/library/de...us/dv_vstechar
t/html/vstchremoteserverconfigurationfordevelopingwebproj ectsusingvisualstud
ionet.asp

Now, as far as creating folders on IIS/making a folder an Application, this
is something that requires permissions from ISP. Some of them provide
access to IIS using some sort of Web Interface or let you create folders
using FrontPage etc.

You may need to check with the ISP about both of the above.

Hope this helps.

Best regards,
Lewis

This posting is provided "AS IS" with no warranties, and confers no rights.
--------------------
| From: "Toby Considine" <tobias@fac.unc.edu>
| References: <#IGI#l$bDHA.3044@TK2MSFTNGP11.phx.gbl>
<8lKCyiJcDHA.1928@cpmsftngxa06.phx.gbl>
| Subject: Re: asp.net remote [hosted] configuration usse
| Date: Mon, 1 Sep 2003 12:01:48 -0400
| Lines: 125
| X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| Message-ID: <#XOacJKcDHA.1280@tk2msftngp13.phx.gbl>
| Newsgroups: microsoft.public.dotnet.framework.aspnet.security
| NNTP-Posting-Host: adsl-18-21-78.rdu.bellsouth.net 68.18.21.78
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msftn gp13.phx.gbl
| Xref: cpmsftngxa06.phx.gbl
microsoft.public.dotnet.framework.aspnet.security: 6484
| X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.security
|
| Both these solutiuons work well with, say a dedicated hosted machine, or
one
| in which I am actualy the admin. Neither works in the usual small-medium
| site hosted scenario in which my site is one of a dozen (or many more -
hard
| to know) sites hosted on a single rmeote 2003 server. The hoster is not
| going to give me access to any tools that will take down someone else's
| site. That includes machine admin rights.
|
| The scenario again is that I have a hosted site with an account that is
able
| to manipulate the that one site, one of many on a remote PC running
Win2k3.
| FP lets me creat a sub-site. but not, as far as I can tell, set the
| application for that remote site.
|
| This means (1) is flat out. (2) I had not tried, but also does not work.
|
| I need a way to access Remote PCs within the context that a hoster is
| willing to provide to a single developer.
|
|
|
|
|
| "Lewis Wang [MSFT]" <v-lwang@online.microsoft.com> wrote in message
| news:8lKCyiJcDHA.1928@cpmsftngxa06.phx.gbl...
| > Hi Toby,
| >
| > You may try one of the two methods to configure the virtual directory as
| an
| > application in IIS.
| >
| > 1. The FrontPage Server Extensions Access Method
| >
| > a. Create an account on the remote Web Server. Add this account to the
VS
| > Developers group. This permits you to create applications on the Web
| > server. If you want to debug your applications by using Visual Studio
| .NET,
| > you must also add this account to the Administrators group on the
server.
| > b. On the local computer, create a duplicate of the account that you
| > created in step 1 by using the same user name and password. Verify that
| > this account is listed as a local Administrator. Use this account to log
| on
| > to the local computer when you develop applications against the remote
Web
| > server.
| >
| > 2. Connect to the remote web server using your IIS and create an
| > application on IIS.
| >
| > a. Open Internet Services Manager. Or, if you run Microsoft Windows XP
on
| > your computer, open Internet Information Services.
| > b. In the left pane, right-click on the root node and select "connect"
on
| > the pop up menu. Input the remote computer name(Or IP address) and
| > account(Administrator account on the remote server).
| > c. Right-click the name of your virtual directory, and then click
| > Properties.
| > d. Make sure that the Web site name or the virtual directory name is
| listed
| > in the Application Name box under Application Settings. If it is not
| > listed, click Create.
| >
| > Hope this helps.
| >
| > Best regards,
| > Lewis
| >
| > This posting is provided "AS IS" with no warranties, and confers no
| rights.
| >
| >
| >
| > --------------------
| > | From: "Toby Considine" <tobias@fac.unc.edu>
| > | Subject: asp.net remote [hosted] configuration usse
| > | Date: Sun, 31 Aug 2003 15:53:02 -0400
| > | Lines: 31
| > | X-Priority: 3
| > | X-MSMail-Priority: Normal
| > | X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
| > | X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
| > | Message-ID: <#IGI#l$bDHA.3044@TK2MSFTNGP11.phx.gbl>
| > | Newsgroups: microsoft.public.dotnet.framework.aspnet.security
| > | NNTP-Posting-Host: adsl-18-21-78.rdu.bellsouth.net 68.18.21.78
| > | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
| > | Xref: cpmsftngxa06.phx.gbl
| > microsoft.public.dotnet.framework.aspnet.security: 6476
| > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.security
| > |
| > | I often have a need for a hosted sub-app, for example, adding a secure
| > | dotnet area in a publicly hosted site, a migration to an ASPX area
| inside
| > of
| > | an existing ASP site. This sub-app may rely on its own security
setting
| > | (which are application wide.)
| > |
| > | I have talked to the hosting support. THey say "You can create that
in
| > | Front Page"
| > |
| > | ok
| > |
| > | I have installed Frontpage XP to get back just the admin functions.
| > | I have created a sub-directory and then defined a sub-web (using FP
Web
| > | Admin) on these 2003-based servers. So far so good.
| > |
| > | Now I consistently (on several sites, with two different providers
get a
| > | message similar to:
| > |
| > | Parser Error Message: It is an error to use a section registered as
| > | allowDefinition='MachineToApplication' beyond application level. This
| > error
| > | can be caused by a virtual directory not being configured as an
| > application
| > | in IIS.
| > |
| > | So how do I remotely configure this function. No problem if I own the
| > | server, and I havve IIS Admin close to hand, but how do I do this
| > remotely?
| > |
| > | thanks
| > |
| > | tc
| > |
| > |
| > |
| > |
| >
|
|
|


Toby Considine 09-04-2003 01:12 PM

Re: asp.net remote [hosted] configuration usse
 
Thanks. I am sending that URL to several hosting ISPs. The first one that
comes up with an effective response wins the business of my clients.

tc


"Lewis Wang [MSFT]" <v-lwang@online.microsoft.com> wrote in message
news:MGXiIUocDHA.460@cpmsftngxa06.phx.gbl...
> Hi Toby,
>
> The ISP's server must be configured properly in order to be able to create
> projects remotely using VS.NET. For more info check:
>

http://msdn.microsoft.com/library/de...us/dv_vstechar
>

t/html/vstchremoteserverconfigurationfordevelopingwebproj ectsusingvisualstud
> ionet.asp
>
> Now, as far as creating folders on IIS/making a folder an Application,

this
> is something that requires permissions from ISP. Some of them provide
> access to IIS using some sort of Web Interface or let you create folders
> using FrontPage etc.
>
> You may need to check with the ISP about both of the above.
>
> Hope this helps.
>
> Best regards,
> Lewis
>
> This posting is provided "AS IS" with no warranties, and confers no

rights.
> --------------------
> | From: "Toby Considine" <tobias@fac.unc.edu>
> | References: <#IGI#l$bDHA.3044@TK2MSFTNGP11.phx.gbl>
> <8lKCyiJcDHA.1928@cpmsftngxa06.phx.gbl>
> | Subject: Re: asp.net remote [hosted] configuration usse
> | Date: Mon, 1 Sep 2003 12:01:48 -0400
> | Lines: 125
> | X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
> | X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
> | Message-ID: <#XOacJKcDHA.1280@tk2msftngp13.phx.gbl>
> | Newsgroups: microsoft.public.dotnet.framework.aspnet.security
> | NNTP-Posting-Host: adsl-18-21-78.rdu.bellsouth.net 68.18.21.78
> | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!tk2msftn gp13.phx.gbl
> | Xref: cpmsftngxa06.phx.gbl
> microsoft.public.dotnet.framework.aspnet.security: 6484
> | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.security
> |
> | Both these solutiuons work well with, say a dedicated hosted machine, or
> one
> | in which I am actualy the admin. Neither works in the usual

small-medium
> | site hosted scenario in which my site is one of a dozen (or many more -
> hard
> | to know) sites hosted on a single rmeote 2003 server. The hoster is not
> | going to give me access to any tools that will take down someone else's
> | site. That includes machine admin rights.
> |
> | The scenario again is that I have a hosted site with an account that is
> able
> | to manipulate the that one site, one of many on a remote PC running
> Win2k3.
> | FP lets me creat a sub-site. but not, as far as I can tell, set the
> | application for that remote site.
> |
> | This means (1) is flat out. (2) I had not tried, but also does not

work.
> |
> | I need a way to access Remote PCs within the context that a hoster is
> | willing to provide to a single developer.
> |
> |
> |
> |
> |
> | "Lewis Wang [MSFT]" <v-lwang@online.microsoft.com> wrote in message
> | news:8lKCyiJcDHA.1928@cpmsftngxa06.phx.gbl...
> | > Hi Toby,
> | >
> | > You may try one of the two methods to configure the virtual directory

as
> | an
> | > application in IIS.
> | >
> | > 1. The FrontPage Server Extensions Access Method
> | >
> | > a. Create an account on the remote Web Server. Add this account to the
> VS
> | > Developers group. This permits you to create applications on the Web
> | > server. If you want to debug your applications by using Visual Studio
> | .NET,
> | > you must also add this account to the Administrators group on the
> server.
> | > b. On the local computer, create a duplicate of the account that you
> | > created in step 1 by using the same user name and password. Verify

that
> | > this account is listed as a local Administrator. Use this account to

log
> | on
> | > to the local computer when you develop applications against the remote
> Web
> | > server.
> | >
> | > 2. Connect to the remote web server using your IIS and create an
> | > application on IIS.
> | >
> | > a. Open Internet Services Manager. Or, if you run Microsoft Windows XP
> on
> | > your computer, open Internet Information Services.
> | > b. In the left pane, right-click on the root node and select "connect"
> on
> | > the pop up menu. Input the remote computer name(Or IP address) and
> | > account(Administrator account on the remote server).
> | > c. Right-click the name of your virtual directory, and then click
> | > Properties.
> | > d. Make sure that the Web site name or the virtual directory name is
> | listed
> | > in the Application Name box under Application Settings. If it is not
> | > listed, click Create.
> | >
> | > Hope this helps.
> | >
> | > Best regards,
> | > Lewis
> | >
> | > This posting is provided "AS IS" with no warranties, and confers no
> | rights.
> | >
> | >
> | >
> | > --------------------
> | > | From: "Toby Considine" <tobias@fac.unc.edu>
> | > | Subject: asp.net remote [hosted] configuration usse
> | > | Date: Sun, 31 Aug 2003 15:53:02 -0400
> | > | Lines: 31
> | > | X-Priority: 3
> | > | X-MSMail-Priority: Normal
> | > | X-Newsreader: Microsoft Outlook Express 6.00.2800.1158
> | > | X-MIMEOLE: Produced By Microsoft MimeOLE V6.00.2800.1165
> | > | Message-ID: <#IGI#l$bDHA.3044@TK2MSFTNGP11.phx.gbl>
> | > | Newsgroups: microsoft.public.dotnet.framework.aspnet.security
> | > | NNTP-Posting-Host: adsl-18-21-78.rdu.bellsouth.net 68.18.21.78
> | > | Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP11.phx.gbl
> | > | Xref: cpmsftngxa06.phx.gbl
> | > microsoft.public.dotnet.framework.aspnet.security: 6476
> | > | X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.security
> | > |
> | > | I often have a need for a hosted sub-app, for example, adding a

secure
> | > | dotnet area in a publicly hosted site, a migration to an ASPX area
> | inside
> | > of
> | > | an existing ASP site. This sub-app may rely on its own security
> setting
> | > | (which are application wide.)
> | > |
> | > | I have talked to the hosting support. THey say "You can create that
> in
> | > | Front Page"
> | > |
> | > | ok
> | > |
> | > | I have installed Frontpage XP to get back just the admin functions.
> | > | I have created a sub-directory and then defined a sub-web (using FP
> Web
> | > | Admin) on these 2003-based servers. So far so good.
> | > |
> | > | Now I consistently (on several sites, with two different providers
> get a
> | > | message similar to:
> | > |
> | > | Parser Error Message: It is an error to use a section registered as
> | > | allowDefinition='MachineToApplication' beyond application level.

This
> | > error
> | > | can be caused by a virtual directory not being configured as an
> | > application
> | > | in IIS.
> | > |
> | > | So how do I remotely configure this function. No problem if I own

the
> | > | server, and I havve IIS Admin close to hand, but how do I do this
> | > remotely?
> | > |
> | > | thanks
> | > |
> | > | tc
> | > |
> | > |
> | > |
> | > |
> | >
> |
> |
> |
>





All times are GMT. The time now is 10:17 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.