Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net Mobile (http://www.velocityreviews.com/forums/f61-asp-net-mobile.html)
-   -   WML Input and .NET TextBox not displaying Text Property (http://www.velocityreviews.com/forums/t764218-wml-input-and-net-textbox-not-displaying-text-property.html)

erikpaulmiller@gmail.com 11-10-2005 06:21 PM

WML Input and .NET TextBox not displaying Text Property
 
I have a MobileForm in which I set the text property equal to something
in the designer. When I view the page via a browsers that requires WML
the value is not displayed. Here is the wml that is sent to the
browser. The value attribute of the input field is not getting
set/displayed. When the form posts back the value is set yet not
visible. I created a static WML page to test the functionality of
defaulting a textbox, which was successful when setting the input's
value attribute to some value.

Here is the wml that is sent to the browser...

<?xml version='1.0'?>
<!DOCTYPE wml PUBLIC '-//WAPFORUM//DTD WML 1.1//EN'
'http://www.wapforum.org/DTD/wml_1.1.xml'>
<wml>
<head>
<meta http-equiv="Cache-Control" content="max-age=0" />
</head>
<card title="TEST">
<onevent type="onenterforward">
<refresh>
<setvar name="txtNewNumber" value="123123123" />
</refresh>
</onevent>
<p>New Number:<br/>
<input name="txtNewNumber" format="*N" />
<anchor title="Go">Submit
<go href="Test.aspx" method="post">
<postfield name="__EVENTTARGET" value="btnSubmit" />
<postfield name="txtNewNumber" value="$(txtNewNumber)" />
</go>
</anchor>
<br/>
</p>
</card>
</wml>



All times are GMT. The time now is 12:31 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.