Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net Datagrid Control (http://www.velocityreviews.com/forums/f60-asp-net-datagrid-control.html)
-   -   Datagrid disappearing on Edit, Update, or Cancel (http://www.velocityreviews.com/forums/t760508-datagrid-disappearing-on-edit-update-or-cancel.html)

bgledet 04-27-2004 02:21 AM

Datagrid disappearing on Edit, Update, or Cancel
 
I had an application developed on asp.net 1.0. I recently moved the application to 2003 server and asp.net 1.1. The application loads fine, but everytime you click the edit button the grid, the grid disappears.

dg1.EditItemIndex = e.Item.ItemInde
Dim ponum As Integer = CInt(txtPONumber.Text
coJA.daJACustomPO.SelectCommand.Parameters("@ponum ber").Value = ponu
coJA.daJACustomPO.Fill(DsJACustomPO1
dg1.DataBind(

This code worked before the move to 1.1

Any ideas? This is becoming a real problem as it needs to go back on-line as soon as possible

bgl

Michael Tkachev 04-27-2004 07:14 AM

Re: Datagrid disappearing on Edit, Update, or Cancel
 
try to rebuild your application.

Michael

"bgledet" <anonymous@discussions.microsoft.com> wrote in message
news:53EB586B-BA56-430F-AFBB-69FFA00879F2@microsoft.com...
> I had an application developed on asp.net 1.0. I recently moved the

application to 2003 server and asp.net 1.1. The application loads fine, but
everytime you click the edit button the grid, the grid disappears.
>
> dg1.EditItemIndex = e.Item.ItemIndex
> Dim ponum As Integer = CInt(txtPONumber.Text)
> coJA.daJACustomPO.SelectCommand.Parameters("@ponum ber").Value =

ponum
> coJA.daJACustomPO.Fill(DsJACustomPO1)
> dg1.DataBind()
>
> This code worked before the move to 1.1.
>
> Any ideas? This is becoming a real problem as it needs to go back on-line

as soon as possible.
>
> bgl




bgLedet 04-27-2004 03:11 PM

Re: Datagrid disappearing on Edit, Update, or Cancel
 
I have. Numerous times. Same result. I can put the grid in edit mode from a button outside the grid, but not one of the std edit, delete, cancel buttons. I also can't find a reference to this error anywhere. Any ideas or workarounds would be appreciated

thanks

bg

----- Michael Tkachev wrote: ----

try to rebuild your application

Michae

"bgledet" <anonymous@discussions.microsoft.com> wrote in messag
news:53EB586B-BA56-430F-AFBB-69FFA00879F2@microsoft.com..
> I had an application developed on asp.net 1.0. I recently moved th

application to 2003 server and asp.net 1.1. The application loads fine, bu
everytime you click the edit button the grid, the grid disappears
>> dg1.EditItemIndex = e.Item.ItemInde

> Dim ponum As Integer = CInt(txtPONumber.Text
> coJA.daJACustomPO.SelectCommand.Parameters("@ponum ber").Value

ponu
> coJA.daJACustomPO.Fill(DsJACustomPO1
> dg1.DataBind(
>> This code worked before the move to 1.1
>> Any ideas? This is becoming a real problem as it needs to go back on-lin

as soon as possible
>> bg





Scott G. 04-27-2004 03:51 PM

Re: Datagrid disappearing on Edit, Update, or Cancel
 

The 1.0 to 1.1 release did break some of our DataGrid pages; the primary reason was that we were doing some unnecessary (and improper) DataBind'ing, and we were also lazy about setting up our DataSource's.

What you might do is go through the page and make sure that you aren't DataBind'ing the DataGrid in such a way that you are killing the postback events -- if the event handlers are being called (set a break point on one) then make sure that the dg1 has a DataSource setup (i.e. if you are in the handler you posted, does the dg1 have a DataSource?).

I know this isn't much help.

Scott
"bgledet" <anonymous@discussions.microsoft.com> wrote in message news:53EB586B-BA56-430F-AFBB-69FFA00879F2@microsoft.com...
I had an application developed on asp.net 1.0. I recently moved the application to 2003 server and asp.net 1.1. The application loads fine, but everytime you click the edit button the grid, the grid disappears.

dg1.EditItemIndex = e.Item.ItemIndex
Dim ponum As Integer = CInt(txtPONumber.Text)
coJA.daJACustomPO.SelectCommand.Parameters("@ponum ber").Value = ponum
coJA.daJACustomPO.Fill(DsJACustomPO1)
dg1.DataBind()

This code worked before the move to 1.1.

Any ideas? This is becoming a real problem as it needs to go back on-line as soon as possible.

bgl


All times are GMT. The time now is 10:17 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.