Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Cisco (http://www.velocityreviews.com/forums/f27-cisco.html)
-   -   ios : Source and destination nat on a single interface (http://www.velocityreviews.com/forums/t745860-ios-source-and-destination-nat-on-a-single-interface.html)

Laurent 03-28-2011 01:37 PM

ios : Source and destination nat on a single interface
 
Hi!
nearly everything in the subject..

s:any d:172.16.57.0/24
->
s:136.156.12.1(overload) d:172.16.17.0/24(match-host)

Is it possible to do ?

(IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(13)T8)

The configuration lines about nat, and wich does not seem to work :(

interface Loopback0
ip address 192.168.251.1 255.255.255.252
ip nat inside
!
interface FastEthernet0/0
ip address 136.156.12.1 255.255.0.0
ip nat outside
ip policy route-map Nat
!
ip nat pool castellano 172.16.17.1 172.16.17.254 netmask 255.255.255.0
type match-host
ip nat inside source list 101 interface FastEthernet0/0 overload
ip nat inside destination list 100 pool castellano
!
access-list 100 permit ip any 172.16.57.0 0.0.0.255
access-list 101 permit ip 172.16.104.0 0.0.0.255 172.16.0.0 0.0.63.255
!
route-map Nat permit 10
match ip address 100 101
set ip next-hop 192.168.251.2

thank you :)

Laurent 03-29-2011 08:30 AM

Re: ios : Source and destination nat on a single interface
 
Le 28/03/2011 18:36, Aaron Leonard a écrit :
> Some call this "NAT on a stick." See:
>
> http://www.cisco.com/en/US/tech/tk64...80094430.shtml


Thank you for your answer, i already saw this page.. my configuration is
based on it.

My problem come from the nat source *and* destination "on a stick" ..
with my conf, only source nat works..

vishal31369 06-24-2011 06:06 AM

Not sure why you have ip nat inside the loopback interface (No data is running from the loopback interface)

you can try

ip nat inside/outside source list -acl interface Loopback0 overload


All times are GMT. The time now is 10:52 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.