Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net (http://www.velocityreviews.com/forums/f29-asp-net.html)
-   -   AjaxControlToolkit namespace problem. (http://www.velocityreviews.com/forums/t713146-ajaxcontroltoolkit-namespace-problem.html)

André Freitas 01-28-2010 03:21 PM

AjaxControlToolkit namespace problem.
 
Im using AjaxControlToolkit HTML Editor, and following the documentation, i
got the code:

Webconfig:

<assemblies>
<add assembly="AjaxControlToolkit"/>
</assemblies>

<pages>
<controls>
<add tagPrefix="asp" namespace="AjaxControlToolkit.HTMLEditor"
assembly="AjaxControlToolkit"/>
</controls>
</pages>

AnyName.cs

using AjaxControlToolkit.HTMLEditor;
namespace MyControl
{
public class SimpleEditor : Editor
{
protected override void FillTopToolbar()
{
TopToolbar.Buttons.Add(new
AjaxControlToolkit.HTMLEditor.ToolbarButton.Bold() );
TopToolbar.Buttons.Add(new
AjaxControlToolkit.HTMLEditor.ToolbarButton.Italic ());
}

protected override void FillBottomToolbar()
{
BottomToolbar.Buttons.Add(new
AjaxControlToolkit.HTMLEditor.ToolbarButton.Design Mode());
BottomToolbar.Buttons.Add(new
AjaxControlToolkit.HTMLEditor.ToolbarButton.Previe wMode());
}
}
}

Test.aspx

I got the line <%@ Register namespace="MyControls" tagprefix="custom" %>
at the top of my aspx, but i cant find the reference to get a new instance
of the object.

What am i doing wrong?

Regards




All times are GMT. The time now is 02:31 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.