Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Python (http://www.velocityreviews.com/forums/f43-python.html)
-   -   Re: XML-RPC(using SimpleXMLRPCServer) slow on the first call (http://www.velocityreviews.com/forums/t701515-re-xml-rpc-using-simplexmlrpcserver-slow-on-the-first-call.html)

Gabriel Genellina 10-14-2009 03:52 AM

Re: XML-RPC(using SimpleXMLRPCServer) slow on the first call
 
En Mon, 12 Oct 2009 18:58:45 -0300, Mahi Haile
<begin.middle.end@gmail.com> escribiˇ:

> Hello all,I have an xml-rpc server running on a machine in the same LAN
> as
> the client. Both the server and the client are in Python.
>
> When I have a series of xmlrepc calls from the client to the server, the
> first call usually takes much longer than it should - orders of
> magnitude.
> The latency is usually sub-10ms on the other calls, but the first call
> takes
> up to 10 seconds or so. This are very simple functions, with almost no
> computation.
>
> Do you have any ideas?


I doubt this is a Python problem. I'd look into the network: DNS
resolution, IPv6 (Windows XP has some timeout issues with IPv6 enabled).

--
Gabriel Genellina


Rafal Gulinski 11-05-2009 04:17 PM

Re: XML-RPC(using SimpleXMLRPCServer) slow on the first call
 
On 14 Pa┼║, 04:52, "Gabriel Genellina" <gagsl-...@yahoo.com.ar> wrote:
> En Mon, 12 Oct 2009 18:58:45 -0300, Mahi Haile ┬*
> <begin.middle....@gmail.com> escribi├│:
>
> > Hello all,I have an xml-rpc server running on a machine in the same LAN ┬*
> > as
> > the client. Both the server and the client are in Python.

>
> > When I have a series of xmlrepc calls from the client to the server, the
> > first call usually takes much longer than it should - orders of ┬*
> > magnitude.
> > The latency is usually sub-10ms on the other calls, but the first call ┬*
> > takes
> > up to 10 seconds or so. This are very simple functions, with almost no
> > computation.

>
> > Do you have any ideas?

>
> I doubt this is a Python problem. I'd look into the network: DNS ┬*
> resolution, IPv6 (Windows XP has some timeout issues with IPv6 enabled).
>
> --
> Gabriel Genellina


Hi,

I had quite similar issue and it was caused by some DNS settings. I
solved it by changing host name to host ip (f.e. for 'localhost' it
was '127.0.0.1'). I hope it will help you.

Regards,
Rafal


All times are GMT. The time now is 03:24 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.