Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net (http://www.velocityreviews.com/forums/f29-asp-net.html)
-   -   Accessing Web Service with HTTP status 407: Proxy Access Denied (http://www.velocityreviews.com/forums/t65497-accessing-web-service-with-http-status-407-proxy-access-denied.html)

George 10-30-2003 03:18 AM

Accessing Web Service with HTTP status 407: Proxy Access Denied
 
Hello,

I'm running an ASPX application "WebApplication1" which
consumes a web service (service1.asmx) hosted on a machine
with IP (128.1.7.x) . The web service is located in the
intranet.
The web methods can be invoked successfully
if "WebApplication1" is located in machines with the same
subnet (128.1.7.x).
However, it fails if "WebApplication1" is hosted on
machines with IP (128.1.8.x)
When it tries to execute a web method, the aspx page
returns an error of
a page titled "Server Error in '/WebApplication1'
Application.", with the error message "The request failed
with HTTP status 407: Proxy Access Denied."

[WebException: The request failed with HTTP status 407:
Proxy Access Denied.]

System.Web.Services.Protocols.SoapHttpClientProtoc ol.ReadRe
sponse(SoapClientMessage message, WebResponse response,
Stream responseStream)

System.Web.Services.Protocols.SoapHttpClientProtoc ol.Invoke
(String methodName, Object[] parameters)


However, the proxy server setting has already been
disabled in the internet options.
If I type the web service's URL
(http://xxx.../service1.asmx) in IE, the wsdl page can be
displayed successfully.

Please notice that the error message is "Proxy Access
Denied" but NOT "Proxy authentication required" which will
be returned if the client is accessing through a proxy
server without the right credentials.
And my system administrator has confirmed with me that the
application did not access the proxy.
Therefore, I did not set the Proxy property of the web
service too.
(I've tried out earlier to set the Proxy with a wrong
credential and got that "Proxy Authentication required"
message)

All machines are running on Win2K SP4 with .NET Framework
1.0

Any help will be appreciated! Thank you!

Regards,
George




shijobaby 02-06-2010 08:25 AM

If your web service anonymous authentication is


turned off you must enable that

Otherwise you have to pass username and password


All times are GMT. The time now is 11:21 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.