Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Cisco (http://www.velocityreviews.com/forums/f27-cisco.html)
-   -   need help with sip trunk (long) (http://www.velocityreviews.com/forums/t651280-need-help-with-sip-trunk-long.html)

tg 01-04-2009 08:54 PM

need help with sip trunk (long)
 
cisco router 2651XM
IOS: c2600-adventerprisek9-mz.124-15.T7.bin
cme 4.1
three 7940G ip phones.

sorry this is a long post but I wanted to provide as much info as
possible to whoever may be able to help me with this SIP trunk, which I
have been unable to get to work. I want to be able to make outbound
calls for starters. I've got a sip account with tesco and the connection
settings they gave me were:

SIP Protocol
Domain: sip.tescointernetphone.com
Proxy Server Address: sip.tescointernetphone.com
Proxy Server Port: 5060
Registrar Server: sip.tescointernetphone.com
Registrar Server Port: 5060
Outbound Proxy: sip.tescointernetphone.com
Outbound Proxy Port: 5060
SIP Signalling Port: 5060
User ID / Authentication Name: mysipphonenumber
Authentication Password: mysippassword

The router is connected to the internet throught F0/1 and I can ping
sip.tescointernetphone.com from the cli with 100% success. The phones
can all call each other. I don't know which phone button I should press
for an outside line (is it 9? nothing happens when I press 9))
Here is a copy of my running config. if anyone can point out where I'm
going wrong and help me get this sip trunk working I'd be grateful.


Building configuration...

Current configuration : 5102 bytes
!
! Last configuration change at 20:28:35 gmt Sun Jan 4 2009 by cme
! NVRAM config last updated at 14:07:43 gmt Sun Jan 4 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
no logging buffered
no logging console
enable secret 5 ???????????????????????
enable password xxxxxxxx
!
no aaa new-model
clock timezone gmt 0
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.0.10
!
ip dhcp pool cme
network 10.0.0.0 255.0.0.0
default-router 10.0.0.10
option 150 ip 10.0.0.10
dns-server my.isp.dns1 my.isp.dns2
lease 7
!
!
no ip domain lookup
ip name-server my.isp.dns1
ip name-server my.isp.dns2
ip ddns update method sdm_ddns1
DDNS both
!
!
multilink bundle-name authenticated
!
!
!
!
voice service voip
allow-connections sip to sip
no supplementary-service sip moved-temporarily
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8 bytes 40
codec preference 3 g723r63 bytes 96
codec preference 4 g726r16 bytes 80
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface Loopback0
ip address 172.16.1.35 255.255.0.0
no snmp trap link-status
!
interface FastEthernet0/0
ip address 10.0.0.10 255.0.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
no mop enabled
!
interface Serial0/0
bandwidth 2000000
no ip address
shutdown
!
interface FastEthernet0/1
description SIP-PSTN gateway
ip dhcp client update dns server none
ip ddns update hostname vpn.vpn
ip ddns update sdm_ddns1
ip address dhcp client-id FastEthernet0/1
ip nat outside
ip virtual-reassembly
no ip mroute-cache
speed 100
half-duplex
no cdp enable
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
ip nat inside source route-map SDM_RMAP_1 interface FastEthernet0/1
overload
ip nat inside source route-map s2smap interface FastEthernet0/1 overload
!
access-list 1 permit 10.0.0.0 0.0.0.255
access-list 2 permit 192.168.1.0 0.0.0.255
access-list 3 remark SDM_ACL Category=16
access-list 3 permit 10.0.0.0 0.0.0.255
access-list 101 remark SDM_ACL Category=18
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
access-list 102 remark SDM_ACL Category=2
access-list 102 permit ip 10.0.0.0 0.0.0.255 any
!
!
!
route-map s2smap permit 1
match ip address 101
!
route-map SDM_RMAP_1 permit 1
match ip address 102
!
!
tftp-server flash:P00308000400.loads
tftp-server flash:P00308000400.sb2
tftp-server flash:P00308000400.sbn
tftp-server flash:P00308000400.bin
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 1 voip
description **Incoming call from SIP trunk**
max-conn 1
destination-pattern 01
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
incoming called-number mysipnumber
dtmf-relay rtp-nte
no vad
!
dial-peer voice 2 voip
description **Outgoing call to SIP trunk**
translation-profile outgoing PSTN_Outgoing
destination-pattern 9.T
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
session protocol sipv2
session target sip-server
dtmf-relay rtp-nte
no vad
!
!
sip-ua
authentication username (mysipnumber) password 7 (mysippassword)
no remote-party-id
retry invite 2
retry response 2
retry bye 2
retry cancel 2
retry register 10
timers expires 300000
timers connect 100
registrar dns:sip.tescointernetphone.com expires 3600
sip-server dns:sip.tescointernetphone.com
host-registrar
!
!
!
telephony-service
load 7960-7940 P00308000400
max-ephones 50
max-dn 50
ip source-address 10.0.0.10 port 2000
calling-number initiator
no service local-directory
system message mysystemmessage
url directories http://mydirectories.co.uk/menu.xml
url services http://phone-xml.berbee.com/menu.xml
cnf-file location flash:
network-locale GB
date-format dd-mm-yy
max-conferences 4 gain -6
dn-webedit
time-webedit
transfer-system full-consult
transfer-pattern 9
create cnf-files version-stamp 7960 Jan 04 2009 19:03:06
!
!
ephone-dn 1
number 01
label button1
description phone1
name phone1
hold-alert 30 originator
!
!
ephone-dn 2
number 02
label button1
description phone2
name phone2
hold-alert 30 originator
!
!
ephone-dn 3
number 03
label button1
description phone3
name phone3
hold-alert 30 originator
!
!
ephone 1
device-security-mode none
mac-address xxxx.xxxx.xxxx
after-hour exempt
type 7940
button 1:1
!
!
!
ephone 2
device-security-mode none
mac-address xxxx.xxxx.xxxx
after-hour exempt
type 7940
button 1:2
!
!
!
ephone 3
device-security-mode none
mac-address xxxx.xxxx.xxxx
after-hour exempt
type 7940
button 1:3
!
!
!
line con 0
line aux 0
line vty 0 4
password xxxxxxxxxx
login
!
ntp clock-period 17208193
ntp server 212.13.194.96
ntp server 212.13.194.71
ntp server 212.13.194.87
ntp server 62.84.188.34
!
end




All times are GMT. The time now is 08:26 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.