Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Windows 64bit (http://www.velocityreviews.com/forums/f46-windows-64bit.html)
-   -   ASUS M2V (VIA K8T890 + Marvell 6121 SATA2) (http://www.velocityreviews.com/forums/t626892-asus-m2v-via-k8t890-marvell-6121-sata2.html)

roman modic 07-21-2008 05:25 PM

ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
Hello!

I've installed 64-bit Vista SP1 on PC with motherboard ASUS M2V:
http://www.asus.com/products.aspx?mo...&l2=101&l3=305

OS works OK (PC has 3GB of DDR2), but there are two problems:

1) Both Nero 7.11.10 and Nero 8.3.6 do not recognize SATA optical
drive (Optiarc AD-7173S) which is connected to the VIA Serial ATA
controller (0591). I can normally copy data from it. It also works
OK on dual boot Windows XP SP3.

BTW, I've also installed ImgBurn and when starting it returns:
I/O Error! Device [0:0:0] (F:) (ATA)
CDB: 12 00 00 00 60 00
Interpretation: Inquiry
Reason: The parameter is incorrect.

InfraRecorder x64 does not work either :(


2) Mobo has also SATA2 controller (Marvell 6121), but it seems
that there are no 64-bit drivers with digital signature. The latest on
ASUS site are "V1.0.2.15 beta 6" and Marvell do not offer newer
on its website (there are only drivers for Yukon LAN adapters) :(

Does anyone know the solution to the above two problesms?

Thanks, ROman



Carlos 07-21-2008 05:48 PM

RE: ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
Hi Roman,
Some "optical" SATA issues can be fixed by setting the SATA mode (in BIOS)
to "Native IDE", "Legacy IDE" or something like that.
I had to switch from AHCI Mode for SATA to Native IDE and that fixed my
burner problems.
Carlos

"roman modic" wrote:

> Hello!
>
> I've installed 64-bit Vista SP1 on PC with motherboard ASUS M2V:
> http://www.asus.com/products.aspx?mo...&l2=101&l3=305
>
> OS works OK (PC has 3GB of DDR2), but there are two problems:
>
> 1) Both Nero 7.11.10 and Nero 8.3.6 do not recognize SATA optical
> drive (Optiarc AD-7173S) which is connected to the VIA Serial ATA
> controller (0591). I can normally copy data from it. It also works
> OK on dual boot Windows XP SP3.
>
> BTW, I've also installed ImgBurn and when starting it returns:
> I/O Error! Device [0:0:0] (F:) (ATA)
> CDB: 12 00 00 00 60 00
> Interpretation: Inquiry
> Reason: The parameter is incorrect.
>
> InfraRecorder x64 does not work either :(
>
>
> 2) Mobo has also SATA2 controller (Marvell 6121), but it seems
> that there are no 64-bit drivers with digital signature. The latest on
> ASUS site are "V1.0.2.15 beta 6" and Marvell do not offer newer
> on its website (there are only drivers for Yukon LAN adapters) :(
>
> Does anyone know the solution to the above two problesms?
>
> Thanks, ROman
>
>
>


roman modic 07-21-2008 06:08 PM

Re: ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
Hello!

"Carlos" <Carlos@discussions.microsoft.com> wrote in message
news:B98A1D3F-5B11-4812-8A0B-45171B92AFD3@microsoft.com...
> Hi Roman,
> Some "optical" SATA issues can be fixed by setting the SATA mode (in BIOS)
> to "Native IDE", "Legacy IDE" or something like that.
> I had to switch from AHCI Mode for SATA to Native IDE and that fixed my
> burner problems.
> Carlos


I can choose only SATA or RAID (I have the latest BIOS).
The current setting is SATA. I doubt that RAID will work,
but I'm going to try it.

Thx, Roman


Carlos 07-21-2008 06:40 PM

Re: ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
Roman,
DON'T try RAID.
It won't work with your optical drive!!!
Carlos

"roman modic" wrote:

> Hello!
>
> "Carlos" <Carlos@discussions.microsoft.com> wrote in message
> news:B98A1D3F-5B11-4812-8A0B-45171B92AFD3@microsoft.com...
> > Hi Roman,
> > Some "optical" SATA issues can be fixed by setting the SATA mode (in BIOS)
> > to "Native IDE", "Legacy IDE" or something like that.
> > I had to switch from AHCI Mode for SATA to Native IDE and that fixed my
> > burner problems.
> > Carlos

>
> I can choose only SATA or RAID (I have the latest BIOS).
> The current setting is SATA. I doubt that RAID will work,
> but I'm going to try it.
>
> Thx, Roman
>
>


Bobby Johnson 07-21-2008 07:11 PM

Re: ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
A couple of years ago there was a web site that had a
compatibility chart for SATA optical drives and I almost
think VIA chips were one of the non-compatible chips; you
could use a SATA optical drive to install an OS because of
the chipset.


Carlos wrote:
> Roman,
> DON'T try RAID.
> It won't work with your optical drive!!!
> Carlos
>
> "roman modic" wrote:
>
>> Hello!
>>
>> "Carlos" <Carlos@discussions.microsoft.com> wrote in message
>> news:B98A1D3F-5B11-4812-8A0B-45171B92AFD3@microsoft.com...
>>> Hi Roman,
>>> Some "optical" SATA issues can be fixed by setting the SATA mode (in BIOS)
>>> to "Native IDE", "Legacy IDE" or something like that.
>>> I had to switch from AHCI Mode for SATA to Native IDE and that fixed my
>>> burner problems.
>>> Carlos

>> I can choose only SATA or RAID (I have the latest BIOS).
>> The current setting is SATA. I doubt that RAID will work,
>> but I'm going to try it.
>>
>> Thx, Roman
>>
>>


Carlos 07-21-2008 07:59 PM

Re: ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
Bobby,
I have not had good experiences with the VIA chipset mobos I used in the past.
I am now using an AMD/ATI chipset based motherboard for the first time and I
have also run into some troubles, though I could sort them out.
My very best experiences have been with the NVIDIA chipset boards.
No problems at all and its RAID is natively "seen" by Vista during the
install process.
Getting back to the SATA opticals...
That's why I recommend to have an IDE optical at hand for bullet-proof Vista
installs.
Now this guy is having problems with his optical drive after the installation.
Could it be that in the "Properties" of this device he has unchecked the
mark for enable the burning properties of it?
I cannot think of anything else.
Or maybe a driver update from VIA (there was this web site they had called
viaarena or something like that)
Carlos

"Bobby Johnson" wrote:

> A couple of years ago there was a web site that had a
> compatibility chart for SATA optical drives and I almost
> think VIA chips were one of the non-compatible chips; you
> could use a SATA optical drive to install an OS because of
> the chipset.
>
>
> Carlos wrote:
> > Roman,
> > DON'T try RAID.
> > It won't work with your optical drive!!!
> > Carlos
> >
> > "roman modic" wrote:
> >
> >> Hello!
> >>
> >> "Carlos" <Carlos@discussions.microsoft.com> wrote in message
> >> news:B98A1D3F-5B11-4812-8A0B-45171B92AFD3@microsoft.com...
> >>> Hi Roman,
> >>> Some "optical" SATA issues can be fixed by setting the SATA mode (in BIOS)
> >>> to "Native IDE", "Legacy IDE" or something like that.
> >>> I had to switch from AHCI Mode for SATA to Native IDE and that fixed my
> >>> burner problems.
> >>> Carlos
> >> I can choose only SATA or RAID (I have the latest BIOS).
> >> The current setting is SATA. I doubt that RAID will work,
> >> but I'm going to try it.
> >>
> >> Thx, Roman
> >>
> >>

>


Bobby Johnson 07-21-2008 08:40 PM

Re: ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
I made a typing error in my post. The last sentence should
read "... could NOT use a SATA optical drive to install and
os..." I tried looking for that info, but could find it. I
do remember a lot of people had problems with optical drives
on SATA ports at the time.


Carlos wrote:
> Bobby,
> I have not had good experiences with the VIA chipset mobos I used in the past.
> I am now using an AMD/ATI chipset based motherboard for the first time and I
> have also run into some troubles, though I could sort them out.
> My very best experiences have been with the NVIDIA chipset boards.
> No problems at all and its RAID is natively "seen" by Vista during the
> install process.
> Getting back to the SATA opticals...
> That's why I recommend to have an IDE optical at hand for bullet-proof Vista
> installs.
> Now this guy is having problems with his optical drive after the installation.
> Could it be that in the "Properties" of this device he has unchecked the
> mark for enable the burning properties of it?
> I cannot think of anything else.
> Or maybe a driver update from VIA (there was this web site they had called
> viaarena or something like that)
> Carlos
>
> "Bobby Johnson" wrote:
>
>> A couple of years ago there was a web site that had a
>> compatibility chart for SATA optical drives and I almost
>> think VIA chips were one of the non-compatible chips; you
>> could use a SATA optical drive to install an OS because of
>> the chipset.
>>
>>
>> Carlos wrote:
>>> Roman,
>>> DON'T try RAID.
>>> It won't work with your optical drive!!!
>>> Carlos
>>>
>>> "roman modic" wrote:
>>>
>>>> Hello!
>>>>
>>>> "Carlos" <Carlos@discussions.microsoft.com> wrote in message
>>>> news:B98A1D3F-5B11-4812-8A0B-45171B92AFD3@microsoft.com...
>>>>> Hi Roman,
>>>>> Some "optical" SATA issues can be fixed by setting the SATA mode (in BIOS)
>>>>> to "Native IDE", "Legacy IDE" or something like that.
>>>>> I had to switch from AHCI Mode for SATA to Native IDE and that fixed my
>>>>> burner problems.
>>>>> Carlos
>>>> I can choose only SATA or RAID (I have the latest BIOS).
>>>> The current setting is SATA. I doubt that RAID will work,
>>>> but I'm going to try it.
>>>>
>>>> Thx, Roman
>>>>
>>>>


Carlos 07-21-2008 10:43 PM

Re: ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
I had already figured out the missing "not"
:)
Carlos

"Bobby Johnson" wrote:

> I made a typing error in my post. The last sentence should
> read "... could NOT use a SATA optical drive to install and
> os..." I tried looking for that info, but could find it. I
> do remember a lot of people had problems with optical drives
> on SATA ports at the time.
>
>
> Carlos wrote:
> > Bobby,
> > I have not had good experiences with the VIA chipset mobos I used in the past.
> > I am now using an AMD/ATI chipset based motherboard for the first time and I
> > have also run into some troubles, though I could sort them out.
> > My very best experiences have been with the NVIDIA chipset boards.
> > No problems at all and its RAID is natively "seen" by Vista during the
> > install process.
> > Getting back to the SATA opticals...
> > That's why I recommend to have an IDE optical at hand for bullet-proof Vista
> > installs.
> > Now this guy is having problems with his optical drive after the installation.
> > Could it be that in the "Properties" of this device he has unchecked the
> > mark for enable the burning properties of it?
> > I cannot think of anything else.
> > Or maybe a driver update from VIA (there was this web site they had called
> > viaarena or something like that)
> > Carlos
> >
> > "Bobby Johnson" wrote:
> >
> >> A couple of years ago there was a web site that had a
> >> compatibility chart for SATA optical drives and I almost
> >> think VIA chips were one of the non-compatible chips; you
> >> could use a SATA optical drive to install an OS because of
> >> the chipset.
> >>
> >>
> >> Carlos wrote:
> >>> Roman,
> >>> DON'T try RAID.
> >>> It won't work with your optical drive!!!
> >>> Carlos
> >>>
> >>> "roman modic" wrote:
> >>>
> >>>> Hello!
> >>>>
> >>>> "Carlos" <Carlos@discussions.microsoft.com> wrote in message
> >>>> news:B98A1D3F-5B11-4812-8A0B-45171B92AFD3@microsoft.com...
> >>>>> Hi Roman,
> >>>>> Some "optical" SATA issues can be fixed by setting the SATA mode (in BIOS)
> >>>>> to "Native IDE", "Legacy IDE" or something like that.
> >>>>> I had to switch from AHCI Mode for SATA to Native IDE and that fixed my
> >>>>> burner problems.
> >>>>> Carlos
> >>>> I can choose only SATA or RAID (I have the latest BIOS).
> >>>> The current setting is SATA. I doubt that RAID will work,
> >>>> but I'm going to try it.
> >>>>
> >>>> Thx, Roman
> >>>>
> >>>>

>


roman modic 08-06-2008 11:26 PM

Re: ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
Hello!

"Carlos" <Carlos@discussions.microsoft.com> wrote in message
news:1931CF56-E64B-4547-AB47-BF79B59B2C95@microsoft.com...
> Roman,
> DON'T try RAID.


Too late ... fortunately :)

First, I reinstalled VIA SATA driver by deleting DVD and
VIA controller from device manager and using driver from
VIA Hyperion 5.18a (ViBusX64.sys and ViPrtX64.sys).
DVD-RW still didn't appear in Nero.

Second, I rebooted into BIOS and changed the setting
"Serial ATA IDE Controller" to [RAID]. New setting named
"Serial-ATA BOOTROM" appeared and I left it at [Enabled].

At BIOS boot sequence, the following text now appears:
Quote:

.... VIA VT8237A SATA RAID CDROM BOOT V1.20
.....
Scan Device, Please wait
No Raid
....
Ctrl0 Chnl0 Master Optiarc DVD DW AD-7173S - SATAPI mode
....
I had to replace the SATA driver with VIA RAID driver (viamrx64.sys) and
now Nero is properly working (DVD is recognized as SCSI device).

Last, I've found valid Marvell 61xx SATA2 driver V1.2.0.20
(mv614x.sys) at
http://support.asus.com/download/dow...20Professional
in the wrong (RAID) section ... BTW, there is also new
RAID driver V1.2.0.57 (mv61xx.sys) at
http://support.asus.com/download/dow...model=P5Q%20WS
but I use the non-RAID flavour because of the eSATA port.

Regards, Roman


roman modic 08-06-2008 11:33 PM

Re: ASUS M2V (VIA K8T890 + Marvell 6121 SATA2)
 
Correction:

> Last, I've found valid Marvell SATA 614x driver V1.0.2.20
> (mv614x.sys) at
> http://support.asus.com/download/dow...20Professional
> in the wrong (RAID) section ... BTW, there is also new
> RAID driver V1.2.0.57 (mv61xx.sys) at
> http://support.asus.com/download/dow...model=P5Q%20WS
> but I use the non-RAID flavour because of the eSATA port.





All times are GMT. The time now is 04:14 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.