Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   ASP .Net (http://www.velocityreviews.com/forums/f29-asp-net.html)
-   -   MicrosoftAjax problem with application/xhtml+xml (http://www.velocityreviews.com/forums/t625806-microsoftajax-problem-with-application-xhtml-xml.html)

Guramrit Singh 07-16-2008 06:16 AM

MicrosoftAjax problem with application/xhtml+xml
 
Hi everybody,
I'm having problem with MicrosoftAjax, when my application is in XHTML+XML
mode.
I'd set contenttype of page to application/xhtml+xml. but in this case ajax
doesn't work properly.
since the result returned from webservice ScriptMethod is json. xhtml
doesn't handle it properly.

I'm encountering some problems with updatepanel in xhtml mode. it works fine
in html mode.

Is there any solution of this.


bruce barker 07-16-2008 03:38 PM

RE: MicrosoftAjax problem with application/xhtml+xml
 
neither a json webrequest or an update panel postback response are xml. you
should not be forcing the type.

an update panel response is a piped ("|") delimited string. a json
webrequest is a json formated string for both the request and response.

-- bruce (sqlwork.com)


"Guramrit Singh" wrote:

> Hi everybody,
> I'm having problem with MicrosoftAjax, when my application is in XHTML+XML
> mode.
> I'd set contenttype of page to application/xhtml+xml. but in this case ajax
> doesn't work properly.
> since the result returned from webservice ScriptMethod is json. xhtml
> doesn't handle it properly.
>
> I'm encountering some problems with updatepanel in xhtml mode. it works fine
> in html mode.
>
> Is there any solution of this.
>



All times are GMT. The time now is 05:11 AM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.