Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Windows 64bit (http://www.velocityreviews.com/forums/f46-windows-64bit.html)
-   -   how to fix install issues of XP x64 after Vista & XP x86? (http://www.velocityreviews.com/forums/t623747-how-to-fix-install-issues-of-xp-x64-after-vista-and-xp-x86.html)

crichmon 07-04-2008 04:35 AM

how to fix install issues of XP x64 after Vista & XP x86?
 
Hi,

I installed Windows Vista x64. Then I installed Windows XP MCE (32-bit).
Installations happened without issue. Now I'm attempting to install Windows
XP x64 Pro. The CDRom boots fine and windows starts installing. After the
first reboot, the error message displayed is: "Windows could not start
because the following file is missing or corrupt: <Windows
root>\system32\ntoskrnl.exe Please re-install a copy of the above file."
Attempting to boot to Windows XP MCE displays the same error. After booting
from the Windows XP x64 Pro CDRom to recovery console, and running "fixboot",
rebooting... XP x64 boots with the same error, however MCE boots normally.
(Of course, Vista boot is restored from the Vista DVDRom.)

Scowering the web for articles, I discovered:
http://support.microsoft.com/kb/927817

The kb sort of describes my situation; XP can't be installed after Vista in
a dual-boot Vista/XP scenario. However, the kb article doesn't specify
64-bit or 32-bit, and the only issue is with 64-bit XP. The article
describes how Vista might modify the partitions, so that the correct
partition for XP is plus one of whatever partition is mentioned in the
boot.ini file. I honestly tried every possible rdisk/partition combination
to no avail. So knowledge base solution provided on the Microsoft website is
not complete. I've previously encountered the issue when installing XP x64
and XP x86 in the wrong order, so my guess is that the issue has something to
do with XP x64 vs XP x86, and nothing to do with Vista. My hope is to turn
to the XP expert forum.

regards,
chris


Charlie Russel - MVP 07-04-2008 12:24 PM

Re: how to fix install issues of XP x64 after Vista & XP x86?
 
This is completely the wrong sequence if you intend to multi-boot. If you're
setting up multi-boot on a machine, with these three OS's, you'll need three
different partitions to install onto, and you'll need to do it in the
correct order. Install 32-bit Windows XP first, then 64-bit Windows XP, then
Vista. That's really the only hope you have of getting it right.

You could _try_ recovering the correct files, using first the XP x64 boot CD
and then the Vista boot DVD. But I honestly think, given what you've done so
far, that you should start over.

The problem is that older OS's don't know about newer ones. So you need to
always install in the order the OS was released.

--
Charlie.
http://msmvps.com/blogs/xperts64
http://mvp.support.microsoft.com/profile/charlie.russel

"crichmon" <crichmon@discussions.microsoft.com> wrote in message
news:7B4AF1BB-18F5-43C6-A658-E28500A7CFA1@microsoft.com...
> Hi,
>
> I installed Windows Vista x64. Then I installed Windows XP MCE (32-bit).
> Installations happened without issue. Now I'm attempting to install
> Windows
> XP x64 Pro. The CDRom boots fine and windows starts installing. After
> the
> first reboot, the error message displayed is: "Windows could not start
> because the following file is missing or corrupt: <Windows
> root>\system32\ntoskrnl.exe Please re-install a copy of the above file."
> Attempting to boot to Windows XP MCE displays the same error. After
> booting
> from the Windows XP x64 Pro CDRom to recovery console, and running
> "fixboot",
> rebooting... XP x64 boots with the same error, however MCE boots normally.
> (Of course, Vista boot is restored from the Vista DVDRom.)
>
> Scowering the web for articles, I discovered:
> http://support.microsoft.com/kb/927817
>
> The kb sort of describes my situation; XP can't be installed after Vista
> in
> a dual-boot Vista/XP scenario. However, the kb article doesn't specify
> 64-bit or 32-bit, and the only issue is with 64-bit XP. The article
> describes how Vista might modify the partitions, so that the correct
> partition for XP is plus one of whatever partition is mentioned in the
> boot.ini file. I honestly tried every possible rdisk/partition
> combination
> to no avail. So knowledge base solution provided on the Microsoft website
> is
> not complete. I've previously encountered the issue when installing XP
> x64
> and XP x86 in the wrong order, so my guess is that the issue has something
> to
> do with XP x64 vs XP x86, and nothing to do with Vista. My hope is to
> turn
> to the XP expert forum.
>
> regards,
> chris
>



crichmon 07-04-2008 06:33 PM

Re: how to fix install issues of XP x64 after Vista & XP x86?
 
Alright, I'm reinstall everything in release order (XP MCE, XP x64, Vista
x64....) XP MCE installs fine on the IDE drive. XP x64 begins installing on
the next drive (a SATA), and after reboot, displays the same error message as
before. My guess now is that XP (at least x64) doesn't recognize the SATA
drive.




"Charlie Russel - MVP" wrote:

> This is completely the wrong sequence if you intend to multi-boot. If you're
> setting up multi-boot on a machine, with these three OS's, you'll need three
> different partitions to install onto, and you'll need to do it in the
> correct order. Install 32-bit Windows XP first, then 64-bit Windows XP, then
> Vista. That's really the only hope you have of getting it right.
>
> You could _try_ recovering the correct files, using first the XP x64 boot CD
> and then the Vista boot DVD. But I honestly think, given what you've done so
> far, that you should start over.
>
> The problem is that older OS's don't know about newer ones. So you need to
> always install in the order the OS was released.
>
> --
> Charlie.
> http://msmvps.com/blogs/xperts64
> http://mvp.support.microsoft.com/profile/charlie.russel
>
> "crichmon" <crichmon@discussions.microsoft.com> wrote in message
> news:7B4AF1BB-18F5-43C6-A658-E28500A7CFA1@microsoft.com...
> > Hi,
> >
> > I installed Windows Vista x64. Then I installed Windows XP MCE (32-bit).
> > Installations happened without issue. Now I'm attempting to install
> > Windows
> > XP x64 Pro. The CDRom boots fine and windows starts installing. After
> > the
> > first reboot, the error message displayed is: "Windows could not start
> > because the following file is missing or corrupt: <Windows
> > root>\system32\ntoskrnl.exe Please re-install a copy of the above file."
> > Attempting to boot to Windows XP MCE displays the same error. After
> > booting
> > from the Windows XP x64 Pro CDRom to recovery console, and running
> > "fixboot",
> > rebooting... XP x64 boots with the same error, however MCE boots normally.
> > (Of course, Vista boot is restored from the Vista DVDRom.)
> >
> > Scowering the web for articles, I discovered:
> > http://support.microsoft.com/kb/927817
> >
> > The kb sort of describes my situation; XP can't be installed after Vista
> > in
> > a dual-boot Vista/XP scenario. However, the kb article doesn't specify
> > 64-bit or 32-bit, and the only issue is with 64-bit XP. The article
> > describes how Vista might modify the partitions, so that the correct
> > partition for XP is plus one of whatever partition is mentioned in the
> > boot.ini file. I honestly tried every possible rdisk/partition
> > combination
> > to no avail. So knowledge base solution provided on the Microsoft website
> > is
> > not complete. I've previously encountered the issue when installing XP
> > x64
> > and XP x86 in the wrong order, so my guess is that the issue has something
> > to
> > do with XP x64 vs XP x86, and nothing to do with Vista. My hope is to
> > turn
> > to the XP expert forum.
> >
> > regards,
> > chris
> >

>


R. C. White 07-04-2008 07:17 PM

Re: how to fix install issues of XP x64 after Vista & XP x86?
 
Hi, Chris.

> My guess now is that XP (at least x64) doesn't recognize the SATA
> drive.


Right. You'll need to get the 64-bit SATA drivers onto a floppy and use the
F6 key at the beginning of WinXP x64 Setup, when it is "inspecting the
hardware" and invites you to "Press F6 if you need to install drivers for a
mass storage device" (or similar language). Until you do this, Setup will
halt at some point after you get well into the installation process, telling
you that it can't find any hard drives in this computer - because it can't
see the SATA drives without those drivers. :>(

Unless there has been a recent change that I don't know about, you MUST have
those drivers on a FLOPPY. They can't be loaded from a USB flash drive or a
CD/DVD or anything else.

As you probably know, even if you install WinXP x64 - or Vista - on a second
(or third) HD, the SYSTEM files (NTLDR, NTDETECT.COM and Boot.ini for WinXP,
and bootmgr and the \Boot folder for Vista) must all go into the active
partition on the first HD - unless you change the BIOS settings to boot from
a different HD. The "boot folder" (%SystemRoot%\Windows - NOT the same as
the C:\Boot folder) will go to the location where you point, but those few
startup files will always go into the active partition on the boot device.

RC
--
R. C. White, CPA
San Marcos, TX
rc@grandecom.net
Microsoft Windows MVP
(Running Windows Live Mail 2008 in Vista Ultimate x64 SP1)

"crichmon" <crichmon@discussions.microsoft.com> wrote in message
news:6472015D-3B45-4827-89F3-B6C0BA2D783B@microsoft.com...
> Alright, I'm reinstall everything in release order (XP MCE, XP x64, Vista
> x64....) XP MCE installs fine on the IDE drive. XP x64 begins installing
> on
> the next drive (a SATA), and after reboot, displays the same error message
> as
> before. My guess now is that XP (at least x64) doesn't recognize the SATA
> drive.
>
>
> "Charlie Russel - MVP" wrote:
>
>> This is completely the wrong sequence if you intend to multi-boot. If
>> you're
>> setting up multi-boot on a machine, with these three OS's, you'll need
>> three
>> different partitions to install onto, and you'll need to do it in the
>> correct order. Install 32-bit Windows XP first, then 64-bit Windows XP,
>> then
>> Vista. That's really the only hope you have of getting it right.
>>
>> You could _try_ recovering the correct files, using first the XP x64 boot
>> CD
>> and then the Vista boot DVD. But I honestly think, given what you've done
>> so
>> far, that you should start over.
>>
>> The problem is that older OS's don't know about newer ones. So you need
>> to
>> always install in the order the OS was released.
>>
>> --
>> Charlie.
>> http://msmvps.com/blogs/xperts64
>> http://mvp.support.microsoft.com/profile/charlie.russel
>>
>> "crichmon" <crichmon@discussions.microsoft.com> wrote in message
>> news:7B4AF1BB-18F5-43C6-A658-E28500A7CFA1@microsoft.com...
>> > Hi,
>> >
>> > I installed Windows Vista x64. Then I installed Windows XP MCE
>> > (32-bit).
>> > Installations happened without issue. Now I'm attempting to install
>> > Windows
>> > XP x64 Pro. The CDRom boots fine and windows starts installing. After
>> > the
>> > first reboot, the error message displayed is: "Windows could not start
>> > because the following file is missing or corrupt: <Windows
>> > root>\system32\ntoskrnl.exe Please re-install a copy of the above
>> > file."
>> > Attempting to boot to Windows XP MCE displays the same error. After
>> > booting
>> > from the Windows XP x64 Pro CDRom to recovery console, and running
>> > "fixboot",
>> > rebooting... XP x64 boots with the same error, however MCE boots
>> > normally.
>> > (Of course, Vista boot is restored from the Vista DVDRom.)
>> >
>> > Scowering the web for articles, I discovered:
>> > http://support.microsoft.com/kb/927817
>> >
>> > The kb sort of describes my situation; XP can't be installed after
>> > Vista
>> > in
>> > a dual-boot Vista/XP scenario. However, the kb article doesn't specify
>> > 64-bit or 32-bit, and the only issue is with 64-bit XP. The article
>> > describes how Vista might modify the partitions, so that the correct
>> > partition for XP is plus one of whatever partition is mentioned in the
>> > boot.ini file. I honestly tried every possible rdisk/partition
>> > combination
>> > to no avail. So knowledge base solution provided on the Microsoft
>> > website
>> > is
>> > not complete. I've previously encountered the issue when installing XP
>> > x64
>> > and XP x86 in the wrong order, so my guess is that the issue has
>> > something
>> > to
>> > do with XP x64 vs XP x86, and nothing to do with Vista. My hope is to
>> > turn
>> > to the XP expert forum.
>> >
>> > regards,
>> > chris



Charlie Russel - MVP 07-05-2008 05:29 AM

Re: how to fix install issues of XP x64 after Vista & XP x86?
 
RC is correct - you will need drivers for your SATA controller. They are
loaded via F6 from a floppy, and only a floppy. When you get to Vista, you
may or may not need drivers, but if you do, they can be loaded from a USB
key as well. But most likely you won't - so far it's done a pretty good job
of having SATA drivers on the DVD for me.

--
Charlie Russel
http://msmvps.com/blogs/xperts64

"crichmon" <crichmon@discussions.microsoft.com> wrote in message
news:6472015D-3B45-4827-89F3-B6C0BA2D783B@microsoft.com...
> Alright, I'm reinstall everything in release order (XP MCE, XP x64, Vista
> x64....) XP MCE installs fine on the IDE drive. XP x64 begins installing
> on
> the next drive (a SATA), and after reboot, displays the same error message
> as
> before. My guess now is that XP (at least x64) doesn't recognize the SATA
> drive.
>
>
>
>
> "Charlie Russel - MVP" wrote:
>
>> This is completely the wrong sequence if you intend to multi-boot. If
>> you're
>> setting up multi-boot on a machine, with these three OS's, you'll need
>> three
>> different partitions to install onto, and you'll need to do it in the
>> correct order. Install 32-bit Windows XP first, then 64-bit Windows XP,
>> then
>> Vista. That's really the only hope you have of getting it right.
>>
>> You could _try_ recovering the correct files, using first the XP x64 boot
>> CD
>> and then the Vista boot DVD. But I honestly think, given what you've done
>> so
>> far, that you should start over.
>>
>> The problem is that older OS's don't know about newer ones. So you need
>> to
>> always install in the order the OS was released.
>>
>> --
>> Charlie.
>> http://msmvps.com/blogs/xperts64
>> http://mvp.support.microsoft.com/profile/charlie.russel
>>
>> "crichmon" <crichmon@discussions.microsoft.com> wrote in message
>> news:7B4AF1BB-18F5-43C6-A658-E28500A7CFA1@microsoft.com...
>> > Hi,
>> >
>> > I installed Windows Vista x64. Then I installed Windows XP MCE
>> > (32-bit).
>> > Installations happened without issue. Now I'm attempting to install
>> > Windows
>> > XP x64 Pro. The CDRom boots fine and windows starts installing. After
>> > the
>> > first reboot, the error message displayed is: "Windows could not start
>> > because the following file is missing or corrupt: <Windows
>> > root>\system32\ntoskrnl.exe Please re-install a copy of the above
>> > file."
>> > Attempting to boot to Windows XP MCE displays the same error. After
>> > booting
>> > from the Windows XP x64 Pro CDRom to recovery console, and running
>> > "fixboot",
>> > rebooting... XP x64 boots with the same error, however MCE boots
>> > normally.
>> > (Of course, Vista boot is restored from the Vista DVDRom.)
>> >
>> > Scowering the web for articles, I discovered:
>> > http://support.microsoft.com/kb/927817
>> >
>> > The kb sort of describes my situation; XP can't be installed after
>> > Vista
>> > in
>> > a dual-boot Vista/XP scenario. However, the kb article doesn't specify
>> > 64-bit or 32-bit, and the only issue is with 64-bit XP. The article
>> > describes how Vista might modify the partitions, so that the correct
>> > partition for XP is plus one of whatever partition is mentioned in the
>> > boot.ini file. I honestly tried every possible rdisk/partition
>> > combination
>> > to no avail. So knowledge base solution provided on the Microsoft
>> > website
>> > is
>> > not complete. I've previously encountered the issue when installing XP
>> > x64
>> > and XP x86 in the wrong order, so my guess is that the issue has
>> > something
>> > to
>> > do with XP x64 vs XP x86, and nothing to do with Vista. My hope is to
>> > turn
>> > to the XP expert forum.
>> >
>> > regards,
>> > chris
>> >

>>



Andy 07-05-2008 05:31 AM

Re: how to fix install issues of XP x64 after Vista & XP x86?
 
The devil is in the details.
What motherboard do you have? What drives do you have? How are they
connected to the motherboard. How are they partitioned? How is the
BIOS configured regarding the drive interface?

On Fri, 4 Jul 2008 11:33:03 -0700, crichmon
<crichmon@discussions.microsoft.com> wrote:

>Alright, I'm reinstall everything in release order (XP MCE, XP x64, Vista
>x64....) XP MCE installs fine on the IDE drive. XP x64 begins installing on
>the next drive (a SATA), and after reboot, displays the same error message as
>before. My guess now is that XP (at least x64) doesn't recognize the SATA
>drive.
>
>
>
>
>"Charlie Russel - MVP" wrote:
>
>> This is completely the wrong sequence if you intend to multi-boot. If you're
>> setting up multi-boot on a machine, with these three OS's, you'll need three
>> different partitions to install onto, and you'll need to do it in the
>> correct order. Install 32-bit Windows XP first, then 64-bit Windows XP, then
>> Vista. That's really the only hope you have of getting it right.
>>
>> You could _try_ recovering the correct files, using first the XP x64 boot CD
>> and then the Vista boot DVD. But I honestly think, given what you've done so
>> far, that you should start over.
>>
>> The problem is that older OS's don't know about newer ones. So you need to
>> always install in the order the OS was released.
>>
>> --
>> Charlie.
>> http://msmvps.com/blogs/xperts64
>> http://mvp.support.microsoft.com/profile/charlie.russel
>>
>> "crichmon" <crichmon@discussions.microsoft.com> wrote in message
>> news:7B4AF1BB-18F5-43C6-A658-E28500A7CFA1@microsoft.com...
>> > Hi,
>> >
>> > I installed Windows Vista x64. Then I installed Windows XP MCE (32-bit).
>> > Installations happened without issue. Now I'm attempting to install
>> > Windows
>> > XP x64 Pro. The CDRom boots fine and windows starts installing. After
>> > the
>> > first reboot, the error message displayed is: "Windows could not start
>> > because the following file is missing or corrupt: <Windows
>> > root>\system32\ntoskrnl.exe Please re-install a copy of the above file."
>> > Attempting to boot to Windows XP MCE displays the same error. After
>> > booting
>> > from the Windows XP x64 Pro CDRom to recovery console, and running
>> > "fixboot",
>> > rebooting... XP x64 boots with the same error, however MCE boots normally.
>> > (Of course, Vista boot is restored from the Vista DVDRom.)
>> >
>> > Scowering the web for articles, I discovered:
>> > http://support.microsoft.com/kb/927817
>> >
>> > The kb sort of describes my situation; XP can't be installed after Vista
>> > in
>> > a dual-boot Vista/XP scenario. However, the kb article doesn't specify
>> > 64-bit or 32-bit, and the only issue is with 64-bit XP. The article
>> > describes how Vista might modify the partitions, so that the correct
>> > partition for XP is plus one of whatever partition is mentioned in the
>> > boot.ini file. I honestly tried every possible rdisk/partition
>> > combination
>> > to no avail. So knowledge base solution provided on the Microsoft website
>> > is
>> > not complete. I've previously encountered the issue when installing XP
>> > x64
>> > and XP x86 in the wrong order, so my guess is that the issue has something
>> > to
>> > do with XP x64 vs XP x86, and nothing to do with Vista. My hope is to
>> > turn
>> > to the XP expert forum.
>> >
>> > regards,
>> > chris
>> >

>>



All times are GMT. The time now is 10:58 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.