Velocity Reviews

Velocity Reviews (http://www.velocityreviews.com/forums/index.php)
-   Windows 64bit (http://www.velocityreviews.com/forums/f46-windows-64bit.html)
-   -   Ext HD triggers new hardware, drivers not loaded (http://www.velocityreviews.com/forums/t592585-ext-hd-triggers-new-hardware-drivers-not-loaded.html)

GettingOld 02-18-2008 10:01 PM

Ext HD triggers new hardware, drivers not loaded
 
I have had recent problems installing external hd's on Vista 64. I have
run into problems with USB2.0 as well as eSATA. The drive will appear
under the device manager under "disk drives". But it triggers the new
harware wizard, which can't load a driver, which leads to an unknown device
being listed. Even when the unknown device is listed the drive still
appears under "disk drives". The drive wil appear under disk manager, but
it is unaccesable. You can remove the partition but can not change the
drive letters or format. Drive manager has a message asking to refresh or
restart which has no effect.
The drive works fine under XP. Xp recognizes the drive and loads it right
up. I had the same exact problem with the usb drive. I went through all
of the usbstor files solutions and deleted the infcache file and finally got
the usb drive working. No such luck with the eSATA drive. I have tried
to point the wizard to the windows32\drivers folder with no luck. I have
tried to update the driver manually through the properties dialog box and it
starts to update and then says an error occured and the drivers could not be
loaded. What is the problem with Vista64. If XP does such a great job
recognizing the drive why the problems with Vista.
I will addd that I have a dual boot machine XP/Vista64, so it is not a
hardware problem with the computer.

Any advice?

Colin Barnhorst 02-18-2008 10:49 PM

Re: Ext HD triggers new hardware, drivers not loaded
 
By "eSATA" can I assume that you are using an external SATA enclosure and an
I to I SATA cable to connect to an eSATA port on the back of the computer?
In that configuration no driver is needed and the issues do not stem from
needing a driver. Mobos that provide an external eSATA port also have SATA
drivers in firmware. That doesn't mean that something isn't messed up for
sure, but just installing a driver won't solve it.

Quite a number of these issues are addressed in SP1. Do you have access to
SP1 (MSDN or TechNet subscribers currently should have it)? It is not
available yet for general public use but will be in a few weeks. SP1
released to manufacturing a couple of weeks ago.

If not, I suggest you check out the list of updates and hotfixes included in
SP1 to see which ones may address your issues. It is a long and tedious
list but there are links so you can download the individual packages.

http://technet2.microsoft.com/window....mspx?mfr=true

As far as the usb issues are concerned, a lot of users have found help with
http://technet2.microsoft.com/window....mspx?mfr=true

"GettingOld" <GettingOld@discussions.microsoft.com> wrote in message
news:612DD68D-52BA-4358-BE55-6B98D1DD409E@microsoft.com...
>I have had recent problems installing external hd's on Vista 64. I have
> run into problems with USB2.0 as well as eSATA. The drive will appear
> under the device manager under "disk drives". But it triggers the new
> harware wizard, which can't load a driver, which leads to an unknown
> device
> being listed. Even when the unknown device is listed the drive still
> appears under "disk drives". The drive wil appear under disk manager,
> but
> it is unaccesable. You can remove the partition but can not change the
> drive letters or format. Drive manager has a message asking to refresh
> or
> restart which has no effect.
> The drive works fine under XP. Xp recognizes the drive and loads it
> right
> up. I had the same exact problem with the usb drive. I went through
> all
> of the usbstor files solutions and deleted the infcache file and finally
> got
> the usb drive working. No such luck with the eSATA drive. I have
> tried
> to point the wizard to the windows32\drivers folder with no luck. I
> have
> tried to update the driver manually through the properties dialog box and
> it
> starts to update and then says an error occured and the drivers could not
> be
> loaded. What is the problem with Vista64. If XP does such a great
> job
> recognizing the drive why the problems with Vista.
> I will addd that I have a dual boot machine XP/Vista64, so it is not a
> hardware problem with the computer.
>
> Any advice?



John Barnes 02-19-2008 10:42 AM

Re: Ext HD triggers new hardware, drivers not loaded
 
In particular, the BIOS that is in the enclosure of older USB cases and some
newer. SATA could be a problem if you are enclosing an IDE drive
I have had several enclosures that wouldn't work with 64-bit (Vista or XP)
that work with 32-bit.

"GettingOld" <GettingOld@discussions.microsoft.com> wrote in message
news:612DD68D-52BA-4358-BE55-6B98D1DD409E@microsoft.com...
>I have had recent problems installing external hd's on Vista 64. I have
> run into problems with USB2.0 as well as eSATA. The drive will appear
> under the device manager under "disk drives". But it triggers the new
> harware wizard, which can't load a driver, which leads to an unknown
> device
> being listed. Even when the unknown device is listed the drive still
> appears under "disk drives". The drive wil appear under disk manager,
> but
> it is unaccesable. You can remove the partition but can not change the
> drive letters or format. Drive manager has a message asking to refresh
> or
> restart which has no effect.
> The drive works fine under XP. Xp recognizes the drive and loads it
> right
> up. I had the same exact problem with the usb drive. I went through
> all
> of the usbstor files solutions and deleted the infcache file and finally
> got
> the usb drive working. No such luck with the eSATA drive. I have
> tried
> to point the wizard to the windows32\drivers folder with no luck. I
> have
> tried to update the driver manually through the properties dialog box and
> it
> starts to update and then says an error occured and the drivers could not
> be
> loaded. What is the problem with Vista64. If XP does such a great
> job
> recognizing the drive why the problems with Vista.
> I will addd that I have a dual boot machine XP/Vista64, so it is not a
> hardware problem with the computer.
>
> Any advice?



GettingOld 02-19-2008 04:35 PM

Re: Ext HD triggers new hardware, drivers not loaded
 
The board supports SATA II. The drive is connected straight to the board
via the riser connector. I finally did get the drive to work in both usb
and sata connection. There seems to be a problem with the plug and play
manager. Up until a few weeks ago I had no problems with the usb ports.
Now every time an external drive or flash card is plugged in, the system runs
the new hardware wizard and says the driver can't be located. These are the
same flash memory cards that ran flawlessly three weeks ago. I assume I
either have some corrupted files or one of the windows updates really messed
the system up.

"John Barnes" wrote:

> In particular, the BIOS that is in the enclosure of older USB cases and some
> newer. SATA could be a problem if you are enclosing an IDE drive
> I have had several enclosures that wouldn't work with 64-bit (Vista or XP)
> that work with 32-bit.
>
> "GettingOld" <GettingOld@discussions.microsoft.com> wrote in message
> news:612DD68D-52BA-4358-BE55-6B98D1DD409E@microsoft.com...
> >I have had recent problems installing external hd's on Vista 64. I have
> > run into problems with USB2.0 as well as eSATA. The drive will appear
> > under the device manager under "disk drives". But it triggers the new
> > harware wizard, which can't load a driver, which leads to an unknown
> > device
> > being listed. Even when the unknown device is listed the drive still
> > appears under "disk drives". The drive wil appear under disk manager,
> > but
> > it is unaccesable. You can remove the partition but can not change the
> > drive letters or format. Drive manager has a message asking to refresh
> > or
> > restart which has no effect.
> > The drive works fine under XP. Xp recognizes the drive and loads it
> > right
> > up. I had the same exact problem with the usb drive. I went through
> > all
> > of the usbstor files solutions and deleted the infcache file and finally
> > got
> > the usb drive working. No such luck with the eSATA drive. I have
> > tried
> > to point the wizard to the windows32\drivers folder with no luck. I
> > have
> > tried to update the driver manually through the properties dialog box and
> > it
> > starts to update and then says an error occured and the drivers could not
> > be
> > loaded. What is the problem with Vista64. If XP does such a great
> > job
> > recognizing the drive why the problems with Vista.
> > I will addd that I have a dual boot machine XP/Vista64, so it is not a
> > hardware problem with the computer.
> >
> > Any advice?

>
>



All times are GMT. The time now is 08:05 PM.

Powered by vBulletin®. Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2010, Crawlability, Inc.